Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Android App - Help

I have uploaded the script - showctrlhelp.EZB

I have installed the android app on my tablet. I have followed all the instructions to the best of my knowledge. When I load the script that is posted above, I get the error "Unfortunately, ARC has closed.

Any help on this is appreciated.

PRO
Synthiam
#1  
What kind of device are you using?
#2  
I am using an Asus Tablet. Do you need the specs?
#3  
In case you do need it here are the specs.

Asus Model K017 - Purchased from Best Buy
Android Version 4.3
4GB in internal memory with a 16GB external micro SD card installed.
#4  
Is this what you have?

Compute Performance of Asus MeMo Pad 7 (K017)

Info

OS 

Android 4.3

Display 

1024 x 600, 7.4"

touchscreen with at least 5 finger gesture support

CPU 

quad core CPU @1200MHz

SoC: Intel® Atom CPU Z2520 (x86 CPU)

GPU 

Imagination Technologies PowerVR SGX 544MP2 (dual core)

3D API 

OpenGL ES 2.0

 

Memory 

0.9 GB

Storage 

5.4 GB

Back camera 

picture: 1.8 MP (1600 x 1200)
video: HD (1280 x 720)

autofocus : 

face detection : 

flash : 

HDR photo : 

touch focus : 

Front camera 

picture: 0.3 MP (640 x 480)
video: VGA (640 x 480)

Features 

accelerometer : 

barometer : 

bluetooth : 

camera (face) : 

camera (rear) : 

compass : 

gps : 

gyroscope : 

lightsensor : 

nfc : 

proximity : 

simcards : 0wifi : 

J
:D
#5  
I think so. It was in a clear case and had a tablet cover and a 16gb card all in it.
#6  
To Update on this: I saw on the Mobile App log a lot of references to JavaLang Out of Memory, does anyone know how to fix this?
PRO
Synthiam
#7  
Interesting - I have been trying to figure out what could be the trouble.

Do you know how to close Running Apps on your device? Usually it's by double tapping or holding the button. Some tablets have a Task Manager that is loaded from the menu.
#8  
I closed the ARC App and cleared the cache. I have other projects on my cloud. I will try to see if they will work now.
PRO
Synthiam
#9  
Did you close the other apps that are running with the task manager?

Do you know how to close Running Apps on your device? Usually it's by double tapping or holding the button. Some tablets have a Task Manager that is loaded from the menu.
#10  
Yes, all apps were closed except for ARC.
PRO
Synthiam
#11  
I'm unable to replicate the issue - I feel the 0.9 gb (900mb) of memory on that device isn't enough for ARC Mobile.
#12  
I wanted to update on what I have done. I created a smaller project in file size and I did not get the issue. The error that I am getting every time on different android based devices, is the same. The only common denominator is my project which is 29 meg in size.

I did take a picture of the error from within ARC mobile and I will post it here. If there is a limit to the projects that we can create and use on the tablets that would good to know.

Thanks,
WayneA
User-inserted image
PRO
Synthiam
#13  
The limit is based on your tablet's available memory - it is impossible for us to tell you.
#14  
Update: I installed ARC on an Verizon LG Tablet. http://www.verizonwireless.com/vzw/tablets/g-pad-8-3-lte/#specs. The RAM on this one is 2GB. I ran the exact same project that I was running on my tablet (the one with 1G of RAM). The LG tablet gave me the exact same error. I looked at the available RAM and I saw about 1G.

My project consists of the following, eight mp3's total file sizes are 161Kb. I have 5 Interface builder pages, each page has a picture that I made from within Gimp, and each picture is about 167kb. The total size of my project is 29Meg. When I save to the cloud I get a warning about the file size. I can save it to the cloud. The error occurs when I download from the cloud to my tablet(s) to run.

Could you take a look at it in your spare time?

Thanks.
#15  
Is this the project you attached to the first post, from your description it doesn't look like it? It loads and works fine on my HTC One (M8) phone.

Can you load your current project to the cloud as public? I would be happy to try it on several different Android devices to see if I can help figure out what is wrong.

Alan
#16  
@thetechguru Let me see if I can do that!