Asked — Edited

ARC Crash!

The latest version (Version 2011.05.30.00) of ARC crashes on start under Windows 7 64bit and Windows XP 32bit..

Here is the error log:

EventType : clr20r3 P1 : ARC .exe P2 : 2011.5.30.0 P3 : 4de48c92 P4 : P5 : P6 : 4889dee7 P7 : 2328 P8 : 5d P9 : system.argumentoutofrange

besides this under Windows 7 64bit the projects are also crashing when I try to run them(CTRL+F5 in Visual Studio 2010 Ultimate) Any suggestions??


Upgrade to ARC Pro

ARC Pro is your passport to a world of endless possibilities in robot programming, waiting for you to explore.

United Kingdom

Odd my laptop Windows 7 64bit runs it fine


I compile the software on a Windows 7 64 bit OS. I also test it in a Windows XP 32 bit virtual image.

The message of System Argument Out Of Range could mean a few things. Let me take a quick peak and see what I find that could be specific to your hardware configuration. You can try reinstalling. Also ensure you have the latest .net 3.5 framework updates.


DJ Sures thanks for quick reply:) I have tried to reinstall it and still the same, but the Firmware upgrade software works fine.... :/ btw I have the latest .net framework 3.5SP1 and 4 installed on both OS's..

Update: hmm.. I've found out that the problem occurs only on vaio notebooks. I have two of them at my hand and ARC crashes on both of them, however I have tried to run it under windows server 2003 and windows server 2008R2 on my server PC and also tried on my home PC that runs windows 7 32bit and ARC worked like a charm:( what a pity tired


DJ, could this behavior occur if your form is unable to populate the com port drop-down menu? I'm thinking Sony-specific software/drivers might be monopolizing resources...


radmeck, I was also thinking about the same, but yesterday I have tried to run ARC on my Acer Aspire One D255 netbook and it crashed, however it worked fine on HP and Lenovo laptops.. :/ Ooop... just during the posting of this message I have tried to install ARC under another Windows XP SP3 on my vaio laptop (wich is actually the XP Mode feature under Windows 7) and BAM! it worked!


Interesting......... I have 3 Sony VIAO laptops that I use. They are Windows Server 2003 32 bit, Windows 7 32 bit, and Windows 7 64 bit.

The firmware update utility uses the EZ-B SDK, and the COM Port list is populated by its public method. The Firmware Utility and ARC use the same public method from the SDK DLL. So if one works, so should the other.

I'm wondering if i'm dealing with a .Net bug due to the unmanaged interop calls for handling the joystick and video capture. Let me take a peek at the execution path and see if anything could be causing the crash.

Jeremy from Solarbotics has a 32 bit XP installation on a desktop that has occasional troubles with ARC. Every second or third install crashes and requires a reboot and reinstall. I haven't had time to investigate his machine to find the problem. Wether or not it's the same problem is unknown.

First, let me throw some detailed exception handling around some methods and publish another release. I'll make some time in the next day or two:) .. It's really too bad that you experience an issue with ARC. I put a lot of care into testing each releaes before it is published. They are tested on a XP and 7 in both 32 and 64 bit OS'.


hmm.. that becomes really interesting, cause when I run the Firmware Utility the dropdown list is not being populated, it's just empty.. so I see the problem is really in com ports..


btw.. in the mentioned above Windows XP where I was able to run the ARC, the dropdown list of Firmware Utility is also populated :)


AraMix, do you have a USB to serial adapter cable you can plug in? Curious if adding a new COM port at least resolves the startup crash...

DJ, I was concerned about the unmanaged interop calls when I first stepped through some of the EZ-B SDK functions. Have you considered replacing the DirectX calls using the SlimDX framework? Shouldn't be too difficult and would do a lot to bring the code up to current standards. I'd be happy to help any way I can despite my general disdain for programming...


Okay I built a new release of ARC with a new connection routine and initialization routine. I am wondering if my threaded model might have had a conflicting init in the designer. Try the new download and see if it works for you :)


radmeck, I don't have any (( but I have at least two virtual com ports active..


DJ, hell yeah.. that worked.. but the drop-down list is still unpopulated :)

also sample projects are crashing when I try to run them, since you said the builder and sdk use the same EZ.dll, maybe the problem is there???


The sample projects in the SDK are crashing? Do they give an error when executing, or is it a compile error?

(i have not released a new SDK because there haven't been significant changes to it that requires a release yet. ARC has been where the changes are lately.

If the list is unpopulated, I wonder why! Hmmmmmm.. I'm using the buggy SerialPort.GetPortNames() method. It has given me lots of grief over time. I've used a few options to not use the method (such as collecting the com ports by the registry directly), but even the registry has the names registered incorrectly.

One of the issues is unterminated strings for the com port names in the registry. So occasionally the registry will return strange characters at the end of a com port name. (i.e. COM31 or COM3i instead of COM3)

I was doing a presentation the other day with ARC at the computer history museum and Windows kept messing up with that issue. The only way around it was to delete the Bluetooth Device, reboot and Re-Add. It was embarassing but a problem that is out of my control :(

The only other option I can possibly think of is hardcoding the listbox with COM Port names. But that's not very nice:( ... I just wish Microsoft would fix their reported bugs!


yeah they crash.. I have attached the screenshot.. and no.. no errors during the building operation and running.. however I get some warnings and maybe this one will be interesting for you

================================================================== Warning 25 Referenced assembly 'C:UsersOwnerDesktopEZ-B Win32 v2011.05.09.00DLLEZ_B.dll' targets a different processor than the application. Tutorial 12 - Speech Recognition

User-inserted image

I'm using Sony Vaio VPCEB36GM with Intel i5 processor...

and here is the content of the error that occurs:

User-inserted image

and in the project "Tutorial 14 - HC-SR04 Ping Sensor" when I double click on Form1.cs a page with this error opens: User-inserted image

I can skip this, but sure the program won't work as far as the variable 'uC_EZ_Connect1' is never assigned. Even if I skip it and try to run the program it crashes, and the content of the eror is the same as for the project "Tutorial 12 - Speech Recognition"...

why am I so unlucky... tired btw, I am participating in a competition here in Armenia, called ArmRobotics that takes place every year, and our objective is to make a minesweeper robot.. so as far as I don't have any practice in hardware programming using assembler I decided to use your EZ-B, cause it's really awesome:) anyway.. thanks for the wonderful support and hopefully everything will be fixed soon and be alright :)


AraMix, let's start with resolving your missing References:

In Visual Studio, expand the project's References folder and Right-click/Remove the ones with exclamation points: Fadd.dll, HttpServer.dll & xunit.dll.

Open Windows Explorer and copy those three DLLs from one of the other SDK project's Resources folder into the current project's Resources folder.

Back in Visual Studio, Right-click/Add Reference... on the References folder and add the three DLLs using the Browse tab. Save/Rebuild and see where we're at...

DJ, I noticed the need to manually add those three references for several of the SDK projects for the last few releases...


On some installations of windows, you may need to choose 32 or 64 bit binaries.

There is a disclaimer in the TXT file for the SDK that the references will be broken in the examples. That is because the DLL location is different per installation folder. You will have to add the reference per project yourself.

But, stupid me might have included the fadd, http and xunit accidently in some of the projects. Oooopsie:) I'll remove those :D


radmeck, I knew that.. just in those two projects there were no problems of that kind that's why I haven't spoken about that, anyway thanks for the detailed instructions :)

DJ, what binaries are you talking about? you mean I have to set the parameters for compiler?


Anyword on trying the latest SDK?