Upgrade to ARC Pro

Take control of your robot's destiny by subscribing to Synthiam ARC Pro, and watch it evolve into a versatile and responsive machine.


Do you have the latest release of ARC? If so have you tried removing ARC then downloading a fresh copy and the re-install? I would re boot as well...


I have uninstalled and re downloaded latest ARC and rebooted but still says no DLLs


This has pooped up before. Here's what I found in the internet. I'll keep looking for the final fix. Till then do this:

Did you have GoProCineformStudio installed?

Did you remove it?

Well, that was your problem.

Apparently the uninstaller for that program takes out more than it should when you uninstall it.

The thing is, when you reinstall it, the program puts it back.

I reinstalled GoProCineformStudio and have not had the issue since.

It's kind of annoying that I can't remove it without causing the issue again, but it's the only fix I've found that works. Every other thread about this I've seen has been unresolved.

So, if you're getting this error, try reinstalling GoProCineformStudio and it should clear up. If you've not had GoProCineformStudio in your system before I'm not sure if it will work. However, it might be worth a shot to try anyway. If not, think back to any 3rd party media players you uninstalled before the error popped up. Reinstalling whatever program it was might fix the error as that was likely what happened to that DLL file.


Here's a thread posted six months ago where we solved this issue for a member. DJ posted that he was going to add an exception in ARC for Gopro. Sounds like it got messed up inn one of the latest upgrades.

EZ Robot discussion on GoPro


OK, here's more:

Thanks for the tip that lead me to the final solution. The error is caused because GoPro CineForm Studion version 121 removes ippsw7-6.1.dll from the operating system. The solution is to place ippsw7-6.1.dll in the directory


The attached file No DLLs in Waterfall contains the missing ippsw7-6.1.dll.

Tha attached file mentiond above is in the second post down at:


Also mentioned is:

The above did not work by itself, but doing this in addition did:

Note: I suggest you do not outright delete the DLLs below but save them somewhere just in case.

In some cases after installing GoPro Studio, other applications may report an error that states: "Error at loading if ippSP library - No DLLS were Found in the Waterfall procedure".

If this occurs the solution is to browse to: C:\Windows\SysWOW64 and then remove these files:
ippjw7-6 .. 1

Hope this does it for you, Dave Schulpius

United Kingdom

Dave's got it :)

Waterfall = GoPro problem


Ha, ha... good one @Dave! Great memory too... For the life of me I never would never had of guessed that this was the problem....


I got bit by this one too on one of my computers, and GoPro isn't even that goid a video editor.



@Richard, you know the old saying? "Even a blind pig will find ..........."

In truth my memory sucks. Something just struck a cord here. I think it was the Waterfall name. ;)


The search feature is quite handy for this stuff :). You will find many many results with people who have gopro's. I tried to "detect" the error, but it happens outside of the ARC environment. It's sad that gopro has done nothing to resolve it - even though it's affecting all of their customers from using software that uses webcams.


thank you all. removing ipp stuff seems to have fixed the problem :)