Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Denmark
Asked — Edited
Resolved Resolved by thetechguru!

Wifi Client Mode Wont Connect

Hi

I just recieved my EZ-B v4 yesterday and finally got around to play a bit with it today.
Everything seems to work fine, except that i cant get it to connect in client mode to my wifi.

Heres what ive tried:
Connected to the EZ-B
Then visited 192.168.1.1, and went to "Wifi client mode", Entered the SSID of my network and the WPA2 passphrase.
I then click connect, i get a green light and the "pling" turn on sound, and then i get somthing like "I am unable to connect to your network" and a red light.

I have tripple checked the SSID and Password.
So right now im kinda out of ideas...

Btw. its a ZyXel P-2812HNU-F1 running 802.11 b/g/n mixed with WPA2 (TKIP and AES)

#1  
Do you have an 802.11g, n, or ac router? If ac and you only have 5.2ghz enabled you will need to enable 2.4ghz g and n mode.

Alan
Denmark
#2  
I just updated with the settings.
Its not AC, its running 802.11 b/g/n mixed
#3  
I hate to even suggest it, but verify the ssid and password are correct. Both are case sensitive.

ie, my ssid is FBIsurveillanceVan, fbisurveillancevan would fail to connect even with the right password.

Alan
Denmark
#4  
Ive checked that several times, my ssid is TheHoneyPot and the password is all caps, and also tried copying the password directly from my laptops wifi settings. just to be sure
#5  
just for giggles, try to set your ap to use AES instead of both AES and TKIP.
Denmark
#6  
It was worth a shot, but no luck:(
#7  
Sounds like time to rule out a problem with the EZ-B itself. Do you have a friend with a network you can connect to, or do you have a phone with mobile hotspot ability? If it fails on multiple networks we can stop looking for network config issues.

Alan
Denmark
#8  
Okay this i so weird...
Suddenly when i booted again and about to reset to try the mobil hotspot, but before i got to press reset, it connected successfully.. i then rebooted again to check if it kept working, but then i got the error again.

I have now tried the mobile hotspot, and it works fine, so its not the ez-b it would seem..
But the weird thing i that i actually got a connection 1 time
Denmark
#9  
I think i resolved the issue. i tried changing the channel on the wifi from 13 to 10.
And now it connect fine, wonder if it a general problem? i was on 13 because its the least noisy part of the band.
Denmark
#10  
Cant really set my self as the resolver, so i set thetechguru, thanks for the testing ideas:)
#11  
I was about to ask if you had MAC filtering on, but I see you got it. Glad its working for you.
#12  
Cool deal. Glad you found an answer. I probably would not have thought to try different channels (although now I am going to test all of them when I get my v4 - hopefully next week or so.).

Alan