Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Czech Republic
Asked — Edited

Voice Recognition In Acer Aspire Switch 10

I bought a Acer Aspire Switch 10 (Z3745, 64 GB, 2GB RAM) and I tried to run my Robot setup in Ez-Builder. Everything worked OK except for Speech recognition. In my For example The Lenovo Yoga, i5, 8GB RAM the same robot setup in ARC works OK. However speech recognition for Acer Switch 10 in MS Windows 8.1 works without any problem (commands - open apps, close apps, Scroll left...etc.), but Ez builder not. What am I doing wrong? Thanks for your help.

United Kingdom
#1  
Does the Debug window show anything wrong?
#2  
did you turn on speech under windows?

did you train windows for speech ?

if you did not, then do that, before getting ARC to work.

j
Czech Republic
#3  
To Rich: Nothing
To jdebay: Yes and yes, I did it. Windows work correctly.
United Kingdom
#4  
What does the debug window show when add speech recognition?

It should show something like this;

Code:


EZB 0:
EZB 1:
EZB 2:
EZB 3:
EZB 4:
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:05 PM - TCP Server stopped
07/09/2014 07:06 PM - Speech Recognition Culture: en-US
07/09/2014 07:06 PM - Loaded speech recognition successfully


The speech recognition control works directly with Windows. If it is set up correctly in Windows it will work in ARC.

When you say it doesn't work, can you elaborate? Does it not load? Does it freeze ARC? Does it just not detect any speech? By "not work" it could be a number of things.
Czech Republic
#5  
To Rich: Yes, but window with Speech recognition doesnot show anything.

Debug window:
7. 9. 2014 21:42 - TCP Server stopped
7. 9. 2014 21:42 - Speech Recognition Culture: en-US
7. 9. 2014 21:42 - Loaded speech recognition successfully
PRO
Canada
#6  
@Donesvarc could you give us a screen shot of the Speech recognition window?

Is it possible that your mic is muted?
Czech Republic
#7  
To Jeremie: Yes, I will make it. But recognition in Windows is functional. If I speak into Ez.Builder waves are indicated ?
United Kingdom
#8  
If that's the case it sounds like it is working, it's just not detecting any of the defined voice commands.
PRO
Canada
#9  
That's correct, as soon as you add the speech recognition control you should be able to speak loudly and see the waves in the top right bar of the speech recognition window. If you don't see any waves your mic might be muted or maybe the on-board microphone drivers need to be updated.
Czech Republic
#10  
To Rich: Yes , It looks like. Microfon detect voice, waves are viewed in the ezb window for voice recognition and control windows environment works.
Czech Republic
#11  
To Jeremie: No, microphone detects voice. If the microphone has problem in ezb then Windows will have the same problem, hasn't it ?
United Kingdom
#12  
Train your profile more.
Speak clearer.

If it's showing the sound wave then the control is working, if nothing happens when you speak the problem lies with your speech profile. Further training is required. It may also pay to adjust the phrases in the speech recognition control.

It may be a stupid question but you are trying phrases that are set up in the voice recognition control aren't you?
Czech Republic
#13  
To Rich: No I didn't. Where can I do this? I tried only training wizard...
United Kingdom
#14  
Click the gear icon (highlighted red below)
User-inserted image


That should open this dialogue, the phrases I've highlighted red.
User-inserted image
Czech Republic
#15  
Yes, I Know, where I defined voice commands, but how can I learn this computer these words. For me is little bit strange, that I have other computer, where commands are functional without training.