Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Upgraded Firmware. Now Won't Connect.

Upgraded firmware. Now won't connect.

I must be doing something wrong. it said that it upgraded fine. I updated the EZbuilder also.

Stumped!

AI Support Bot
Related Content
Synthiam
PRO
USA
#22  
The Download has been put on hold. Please let us know when downloading can be resumed.
#23  
OK, I am convinced that no matter what I do, it is NOT going to work. :-(

My system is Windows7 Five Core 16G Ram and 2 T Hard drive and ONE EZBoard that does not work.

Mel
Netherlands
#24  
@ MovieMaker

Have you tried deleting the registered ports for EZ-B with blueTooth before uninstalling?

I have windows 7 too, I first rightclicked my bluetooth icon in windows tray, there i manually took
out the registered ports for the EZ-B connection and then unplugged it. I plugged it back in and then
only had to reactivate the EZ-B connection in windows control panel > hardware and devices, and it automaticly reconnected. That was all I did and it worked.

I noticed that at first that allthough i had my port 3, i did not have my port 4. I again rightclicked my
bluetooth icon in tray and there i anually added the com 4 port to the EZ-B connection. I hope
this may be of some help to you.

Kristian.
Ecuador
#25  
did you try to change your bluetooth device?? in another computer???
Ireland
#26  
Second EZB now works ok also.

On first attempt got " cannot connect to Ez-b" error
But my next click on connect all worked perfectly.

Don't worry what ever the issue DJ will sort it out.
#27  
Everything was working Beautiful right before the Update firmware.

I think there is a BUG . And, of course I am the Lucky one to experience it. I should've been a beta tester. I have beta tested before for some companies.
Ecuador
#28  
now..... we only can say "good luck" to Dj......
PRO
Synthiam
#29  
The 15.3 does indeed have a bug with some bluetooth modules. It's unusual, because it's not with all EZ-B's.

It will be repairable, but require a trick for the connection. You will have to power the EZ-B ON, then OFF, then ON quickly. If you do that, the status led will begin pulsating (Rather than staying on for 4 seconds). If you notice the LED stay on when you first power up, it won't connect. If the LED pulsates right away when you power up, you can connect.

I'm stumped as to why. I'll have a fix soon as I find out what's happening.

We have 10 beta testers for firmware. All 10 boards passed the test (v2, v3 and v3.1). I spent the past while trying board after board and found 3 that won't connect all the time.

I can verify that there is indeed something fishy happening. I'm going to make sure it's fixed today:)
#30  
Plugging and Unplugging could be dangerous maybe?

Also, is it the white or Red light?

Do we want it to flash or stay on?
#32  
OK, that little trick worked for me. I was scared to try it because rapid turning on/off can kill a cpu. Evidently, D.J. has put some protection circuits inside and on the board.

Good Work!!
PRO
USA
#33  
Any chance there will be release tonight?
PRO
Synthiam
#34  
Yup, in about 45 seconds:)
PRO
USA
#35  
LOL..glad i did not goto sleep well done!
PRO
Synthiam
#36  
Okay, the new version is up. If you already have updated to 15.3, you will have to update again and it will fix your issue.

If you already have the buggy version, you'll have to try the quick power recycle in order to receive an immediate pulsing LED before updating.

If anyone is having trouble recovering from the buggy firmware, let me know and i'll try to help you.

I'm tired:) Sleep time!
PRO
USA
#37  
Fantastic work. Get some rest.
Netherlands
#38  
I do have problems updating from the buggy software.

I have downloaded and installed the new version. I have i reset my bluetooth
device, when i try to update it i get a message saying..



Attempting connection to COM3
Connection Failed: System.IO.IOException: The semaphore timeout period has expired.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
at System.IO.Ports.SerialPort.Open()
at EZ_B.EZB.Connect(String portName)
Disconnected.


*EDIT

Never Mind, I have got it to update. After installed the new version, it had 3
different ports set up. Before I had the com3 and com4 port. This time I had
Com3, Com4 and Com5. Turns out that the Com4 port wasnt really assigned
to be any port at all. so I took that out and then it updated.
Netherlands
#39  
Thanks for your work DJ! My EZ-B is working perfectly and the new update is GREAT!
:D

Kristian.
#40  
The power cycle does not result in an immediate pulsing led. It will always just stay on for a bit and start pulsing. I am not sure what I am doing wrong. What else can I try? Thank you in advance.
#41  
D.J.

Thanks for all of your hard work. The bluetooth hooks up 100% of the time according to my tests. Seems that problem is solved. That is really nice not to be agravated by that.

Good Work!!!! I apreciate it. This is on 15.3.

Thanks,

Mel