Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Uart Wifi Elechouse Connection Questions

Hi all, I am adding Wifi to my EZB v3. I got the UART Wifi from Elechouse that is recommended on a number of community posts
Elechouse UART Wifi

I finally got the USB to Serial adapter working on a Win7 machine on COM4. It didn't work on Win8 (code 10).

I have followed the directions in post #32
here
I have never been able to connect to the unit wirelessly on its default ip of 192.168.1.119. My domain is 192.168.0.X - is that the reason? Do I need to set up a separate domain of 192.168.1.X to access this sucker?

Since that didn't work, I tried following the test directions on the Elechouse product page's PDF . I even tried optional Step 9 using Arundio software serial manager. It crashes when I try to send +++ to COM4.

I was hoping to get it configured using the USB to Serial adapter and UART-Wifi.exe. That program will not connect to COM4. It says "Com is invalid; The device is not" then it gets cut off. Could be supported or connected.

Thanks,
Kate

United Kingdom
#1  
Yes, you need to be in the same IP group.

Connect the WiFi module to your PC via USB using the USB adapter. Run the application which should have come with it. In this you can manually change the static IP. You need to change it to 192.168.0.xxx (where xxx is a free IP address).

I remember I had some problems with the config tool (UART-Wifi.exe I think, but not sure) but eventually it connected to the module over the USB/COM port.


OR, manually join the 192.168.1.xxx group by setting your IP on your PC manually to the 192.168.1.xxx group. Once in, open your browser and go to the ip address, you can change the settings through your browser if I recall correctly.
#2  
Thanks for responding Rich:) I'll clarify what I have tried so far:

Wireless connection scenario: Power just the Wifi TLG10UA03 using the EZB 3.3v and ground (other pins empty). I forced my laptop wireless IP to 192.168.1.2 (verified with cmd > ipconfig) and attempted to browse to 192.168.1.119. Didn't work. "This page cannot be displayed". I also tried to ping 192.168.1.119 and it is unreachable. On the TLG10UA03 the red light #1 is on and all appears well (I guess). I'm considering running to Target an getting a cheap Wireless router and configuring it to be the DHCP server 192.168.1.1

Wired USB connection scenario: Wind7 machine. On USB to serial dongle, jumper the 3.3V to select 3.3V power to the pins. Plug in USB dongle. In Device Manager under Ports, my Prolific USB to Serial hardware is listed and the device is working properly. Under properties I set it to COM7 and set the baud to 9600. Plug USB dongle pins to the TLG10UA03 (straight wire, no crossovers). Then in Device Manager I get either code 10 for the USB device or it becomes an "Unknown Device". So I try to cross the RXD and TXD. Unplug USB, plug in USB. Same Unknown Device. If I just plug the USB dongle in without connecting the Wifi cord, there is no problem in Device Manager.

Can you see anything I am doing wrong?
United Kingdom
#3  
If I recall correctly (bearing in mind I stopped trying with my wifi pretty quickly due to this) the EZ-B can't provide enough power for the module and requires a 3.3v regulated supply with more current than what the V3 provides to the header. This may be why you can't connect when powering from the EZ-B.

I could connect to mine via Wifi when I had it connected to the USB dongle (so that the PC was powering it), it may be worth trying that. Provided it has power it doesn't matter if the PC recognises the USB dongle since the communication will be via wifi, the USB is only providing the power for it.

The USB part shouldn't really make any difference to the PC if it's connected to the Wifi part or not. There is a topic somewhere (it may be the other one you posted in actually) where it's covered how to connect the USB to the Wifi correctly since I believe the pin markings are either wrong or are confusing. I'll see if I can find it and will post the link (reading the topic may help me remember what I needed to do, it's up there somewhere I just need something to trigger it lol)

Also, the USB dongle wouldn't work on my Windows 8 Laptop, I had to use Windows 7, like you said. But I can confirm it worked on Windows 7 Ultimate with the drivers from ElecHouse website.
#4  
Kate,

Due to the power issues, fragile nature of the board (several of us had them die, some for known reasons and some seemingly at random) and poor performance once finally configured, a few of us found another board that works better . See this thread http://www.ez-robot.com/Community/Forum/posts.aspx?threadId=3460&page=1 (and ignore my struggle with the roving networks board) .

I purchased one, and just before I was going to start working with it DJ announced the v4, so I put it on a shelf. Yours for the cost of shipping if you are interested. Let me know.
#5  
I thought others had gotten the TLG10UA03 working with EZBv3? I always manage to waste time & money on the path that doesn't work. 1st roadblock is getting the P2303 (HX) USB to Serial adapter that came with my TLG10UA03 wifi module to work. 2nd is my network IP is 192.168.0 instead of 192.168.1 ...what a pain.

@thetechguru - can you confirm this one is the board you mention from the other post?

I built a snow plow out of a Jet 2 power wheelchair base and a Sabertooth 60A. Besides ice traction issues, the plow worked great using EZBv3 as long as I follow it around with my laptop so it doesn't lose Bluetooth connection and run off down the street. Once I have proper control of the plow, I'm going to convert it into a lawnmower :D

Thanks!
#6  
Yes, that is the board I have. The elechouse has been made to work, but inexplicably slows down often, and several of us fried them (mine completely my fault, but some seem to have just died without warning).

I love the snowplow/lawnmower idea.