Asked — Edited
Resolved Resolved by Jeremie!

Sabretooth And L298n Motor Controler Malfunction

Guys having a new issue.

Got the Sabretooth to work and my L298N works with my Arms.

But when I activate one of the arms either Left Right Up or Down.

The Left Motor on the SabreTooth turns on full speed forward.

I Have tried different Digital Pins and I have tried New connecter wires doesn't make a difference.

One thing that may be of note is that if I have the wire connected to the Sabretooth but not the EZB and I touch it with metal the red led blinks and it will actuate a motor for a quick sec.

I need to get the robot to move and work the arms without spinning in a circle:)

Any advice?

One thought I had was to maybe put a resistor on the connector wire but I wouldn't now what my ohm rating should be or if that is even going to drown out any interference.

I need HELP fast please:)




Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.


How did you get the Sabertooth to work? I have the 2x25 and cant get it to work correctly.


Sorry @woodylv I thought that your Sabertooth question may have been the same as @ceberhard's problem But after reading it I can see that it's unrelated.

I guess to start things off, I'll direct you both to the Dimension Engineering website to double check that your jumper settings are correct using the DIP Switch Wizard. I apologize if you guys already are familiar with all this, but figured I'd mention it anyway just in case.

First, You'll want to:

  1. Choose your battery type
  2. Select "With TTL level RS-232 serial data using a PC or microcontroller:
  3. Select "Simplified mode - a single byte for each motor speed command"
  4. Select "Just one please"
  5. Scroll to the bottom of the page and copy the DIP switch settings at 38400 Baud.

Next, boot up ARC:

  1. Go to the Projects tab
  2. Select "Add Controls" on the Ribbon bar
  3. Select the "HBridges" Button
  4. Select the "Sabertooth Serial Movement Panel"
  5. Select the Gear Icon (Settings) on the Movement Panel and select your Serial Port pin from the drop down menu, corresponding to whichever Digital pin you hooked your Sabertooth too.

Remember what @Rich and others have mentioned, it is very important to make sure all your Grounds (negative references) are attached together (at one place or another) or you may get weird results or possibly damage something.

@woodylv What type of power system are you using, single or multiple battery, bench-top power supply, etc? Can you give us a quick pictorial overview of your setup or a picture if you have time?

Is it possible that the port you've selected for the Sabertooth is shared by one of the L298 input lines in the ARC settings. How are you controlling both motor drivers, through a Movement Panel or an EZ-script, or a combination of the two?

The only other thing I can think of is possible Motor (electrical) noise feeding back through your power lines which is affecting the Sabertooth, you could try using some 0.1uF ceramic filter capacitors across your motor lines, and motor lines to ground, and across your power and ground lines as well. Another way to diminish motor noise is to add a fair amount of lubrication to the gear sections of the DC motors you are using for the arms.



Thanks for the Reply.

It was the common ground:)

Funny how something that simple can be a factor.

Thanks again for the info.