Canada
Asked — Edited
Resolved Resolved by Robot Doc!

Roomba Red Help

Hello all, Has anyone tried hooking up a Roomba Red with the EZB4? Ihaven't had any response from the robot yet... Also, the video tutorials, although good, don't reflect the current software/hardware. The tone control doesn't show any response from mouse clicks. Is that normal? I have made a cable up and using D0 output. (Cable also draws power from Roomba although for testing, I haven't used it for power). I have the setting set at use old protocol as I am assuming the Red is definitely "Old"... Any help is appreciated...


ARC Pro

Upgrade to ARC Pro

ARC Pro is your gateway to a community of like-minded robot enthusiasts and professionals, all united by a passion for advanced robot programming.

#1  

Are you sure you have the cable wired properly? You only need ground and signal... What pins of the connector are you using? Also Roomba's built before a certain date won't work... (I think something like 2005 or 2006)

#2  

Hello Richard Yes, I've checked the wiring on the connector... I also followed the post for supplying power from the Roomba. Checked the cable after assembly when it was plugged into the Roomba and it seems to match up properly. About 16 volts on the power pins and 4.9 on the signal. You say older Roombas don't work... I guess protocols maybe? Is there some official listing of models and setups? I've used the 'old protocal' check box on the control... Also tried the other baud rate available on the control. Nothing! The tone control doesn't seem active. Both control panels have changed quite a lot since the video tutorial. Is there documentation somewhere that I'm missing? Again, thanks for your help. It's not the primary reason I got the EZB but since I had the roomba I thought I would start there...

#3  

Any Roomba made in October 2005 and later will have the open interface firmware which is needed to send and receive commands via the Serial Command Interface.

You can tell the date of the software inside the Roomba by performing the following steps:

Disconnect the roomba from the charger. Hold down the power button for about 10 seconds. Count the dits and dahs, it is base 5 Each short beep is 1 and each long beep counts as 5. Its in the format year month day.

A #4210 with a mfg-date of 041014 and got .... - .... ---- . meaning 040921

This indicates a firmware date of September 21, 2004. Therefore this Roomba does not contain the SCI interface. Sometimes referred to as the OSMO Hacker code. This 4210 Roomba would require an OSMO hacker unit to upgrade the Roomba to allow commands to be sent and received.

#4  

The date of manufacture is also in the battery compartment on upc sticker...

#5  

Manufacture date and firmware date may be different. Here's how to read the UPC sticker date.

User-inserted image

#6  

Thanks Robot Doc and Richard for the great info... I will check my serial number. I suspect it is an older pre-OSMO version. This is great info to include into the tutorial to save some time.

#7  

I have both OSMO Hacker versions for the Roombas that are Pre Oct 2005 releases to enable them to work with the TX, Rx leads of microcontrollers like the EZB(3) and EZB(4). iRobot does not make the OSMO units anymore but I managed to get two units. One for the 128 kbyte MCU and one for the 256 kbyte MCU used in the various Roomba models. I don't mail them out since they may get lost in the mail but you can pull the board out and ship it to me to be flashed.

Go to my user profile to get my email for further info if you need it.