USA
Asked — Edited

Roomba 4200 Series: Anyone Have A Charging System Circuit Diagram?

Hi! I picked up several Roomba Discovery 4200 series robots and have refurbed a few and got them running. They're remarkable little machines! I'm having trouble with two of them... they run fine on a full charge but the on-board charging system won't work. I tried connecting the charger directly to the unit (bypassing the dock/charging pad) without success. I do not get the slowly blinking red power light; nothing is lit. When docked, the two green lights are lit on the dock showing a connection but I get nothing on the Roomba itself. I did replace both the U2/U4 transistors but there was no change. There's obviously another problem with the on-board charging circuit. I'm trying to find a main board and charge port circuit diagram so I can attempt to troubleshoot it. Can anybody help? Thanks! confused

Skip to comments

ARC Pro

Upgrade to ARC Pro

With ARC Pro, your robot is not just a machine; it's your creative partner in the journey of technological exploration.

#1  

I had one do this a few years ago. I tried the things you've already tried along with following some good advice form others with no success either. I ended up getting a new main board and that solved the issue. Sorry I cant recommend a place to find the board or what to get. I found mine on Ebay with the guidance of a fellow forum member who I haven't seen around for a while (Robot Doc). He has (or had maybe) a shop where he works on these vacuums. Here's the thread where I was asking for and received help and advice:

synthiam.com/Community/Questions/6470&page=1

Good luck!:)

#2  

Thanks for the link.. I didn't see that thread when I searched the forum. I'll look to see if I can find that R138 resistor mentioned. Chances are, I have a new one squirreled away in my hoard that I can use. I can try to trace back the circuit from the charging plug but was hoping somebody on the forum had a diagram from Roomba that's been leaked. Folks are still selling main boards on eBay but I'd rather repair this one, if possible; there's no guarantee that an eBay board would be trouble-free and they're running about 40-50 bucks right now... about the cost of another little turtle. Thanks! J.C.

#3  

Dave, I see from the thread that you found and tested the R138 resistor. I've looked but can't find it! I suspected it was on the upper right but don't see it. Do you remember where it was on the board and can you give me a general area where I should look? I'd like to try that before giving up on this board. Thanks! J.C.

PRO
USA
#4  

I'm not 100% sure, but, the R138 "issue" is related to the Roomba 5xx family.

User-inserted image

#5  

Ugh! I'm working on a 4210 model so it's a different circuit board. Maybe that's why I can't find that resistor on mine! J.C.

#6  

BTW, that's a cleaner looking board than I'm working on! Many more PLA chips on it. J.C.

PRO
USA
#7  

Maybe this can help you:

mosfets: U2, U4 red part

User-inserted image

I would start with a good battery after fixing the U2, U4.

PDF version: charging_n_control_schema.pdf

#8  

Hey, that looks like a great diagram and is very helpful! BTW, I did start with a new/fresh battery (fully charged from another Roomba with a good internal charging circuit) after installing the new U2/U4 so there must be another part on the board that has failed. Thanks! J.C.

#9  

Thanks! J.C.

PRO
USA
#11  

Will do, I'm working on getting several of these up and running again, thanks!

#12  

I call SPAM... just joined and added questionable links in his first post... Even if it is legit... no ez robot content....