Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Russia
Asked — Edited

Question With Video On Bookstone Rover

hi.

I have problem with video from rover camera in EZ-Builder.
Sorry for bad English, it is not my native language.

First, all was ok. I've connected to robot from EZB, picture was ok, and I ran the robot by office about 10-20 minutes.

Then, after reconnect i saw black screen instead of picture. Motion controls still work fine. I tried to reinstall EZB, reset the robot, tried on another pc - nothing helps. On iphone everything is ok. Even the python script, that grabs jpeg from camera works fine.

I watched traffic between EZB and robot - it seems, that robot sends its video stream, but EZB shows only black screen.

Help me! thanks:)


ARC Pro

Upgrade to ARC Pro

ARC Early Access will give you immediate updates and new features needed to unleash your robot's potential!

PRO
Synthiam
#1  
Hello,

I cannot reproduce the issue - perhaps wifi interference is causing a problem. Please ensure you have the latest copy of ARC:)
#2  
I can record 5-10mb of binary videostream from robot for you. Can it help?
PRO
Synthiam
#3  
No, that will not help - because the video stream will be the same as what I receive.

Open the DEBUG window in ARC and check if any messages appear.
#4  
i checked it before.
it is everything ok there - "Camera initialized".
FPS counter in left upper corner starts show "10 FPS" instead of 0. but still no image.
I've upgraded python script from
here to parse videostream. It works.

Here it is: https://dl.dropbox.com/u/30326398/ac13.py
maybe you find it useful:(
#5  
I've checked traffic between EZB and robot with tcpdump. It seems EZB trying to start streaming - in sends MO_O commands incessantly, but stream not starts - traffic speed is about 5kb/s.
PRO
Synthiam
#6  
I don't know what you mean. It is responsibility of the rover to begin streaming the JFIF when it is told too. There is a packet leaving ARC that starts with MO_OV. That happens during the initialization, following that, the rover transmits the JFIF images.

Ensure you are running the least ARC. Also, iphone or android devices must be disconnected from the rover. If opensource Android devices have been connected to the rover, my suggestion is to RESET the rover using the rest button on the bottom before using ARC.

The rover only accepts on connected device at a time. The must be reset when a second device is used.
#7  
I have great respect for you, and the work you have done. EZB is great program.
But i really tried all possible solutions. Of course, i have last version of EZB. I'm tried to reset rover about 3-5 times.

But it is really not works :((

My last chance, maybe i forward 80 port from robot to some internet IP, so you can figure it out directly?
#8  
Hi

How i can connect my brookstone rover on my wifi network ?

Thanks
#9  
please help me *stress*
#11  
Hi

Thanks I read all the tuto, yes it's true *eek* but I didn't find the answer

How to connect my rover to my WIFI network ( not to my computer through wifi )

Thanks per advance for your HELP :D
PRO
Synthiam
#12  
Please watch the video on the tutorial page.
#13  
I saw also de video *stress* but i didn't find HELP me *blush*
#14  
>How to connect my rover to my WIFI network ( not to my computer through wifi )

I'm now solving the same problem. It is not possible with standart instruments. The solution is to download firmware through com port on bottom of rover (under cover, near to the reset button). Unpack it, change config files and upload it back.

some info here http://www.openipcam.com/forum/index.php/topic,261.0.html



User-inserted image
Canada
#15  
@groniki Hello and welcome. I have been watching your posts and think I understand better what you wish to do. The link between the Rover and the ARC is an ad-hoc network... I believe... (as is its normal routine, only with iPhones/iPads/etc). It looks like what you are trying to do is tie your rover into an infrastructure network, then from there to the ARC. Unfortunately, I think the solution is outside the scope of this forum as you may be the first (here) to try this. If anyone out there knows better, then please correct me, lest I lead someone astray:P

It looks like @robot468 has the idea of looking into other sites that deal with the hacking of the Rover itself... which seems to be the root of the issue, not with DJ's ad-hoc tie-in with ARC.

Of course once you figure it out, please do share the solution with this forum so that it might help the next person who asks:) That way these off-the-scope hacks start to mesh with the whole EZ-Robot concept.
#16  
Hi Gunner
You are understand 100%
It's simple, I just want to remote through internet my Rover *sick*
I think the first step is to connect my rover to my infrastructure wifi network.
I understand that the rover firmware can only connect with ad-hoc network.
Is there a firmware for infrastructure wifi connection ?
*stress* *stress*
#17  
> It's simple, I just want to remote through internet my Rover

You can solve this without firmware hack. You can make server at home, connect it to rover by ad-hoc and simply forward 80 port from rover to external ip address.

My target is to avoid max control distance restriction. We have large office with common, single wi-fi network. It would be cool to travel everywhere :-)
#18  
Hi Robot 468
Ok I understand, but how I can connect my server to my rover through my infrastructure wifi network.
Sorry i don't understand *stress*
#19  
Without "infrastructure wifi network". You can connect server's wi-fi adapter directly to rover's ad-hoc network. Then server will be able to access rover's control port at 192.168.1.100:80. Then you should forward (by firewall, or another software) this port to external Internet IP address.
PRO
Synthiam
#22  
Sorry to say, there is something wrong with your network, laptop or rover.
#23  
Rover, i think. I tried with another laptop.
But iphone/ipad client works well. And my self-made script for parsing videostream works too:(
PRO
Synthiam
#24  
That's really strange. Are there any messages in the debug window?

1) Start ARC
2) Open debug window
3) Add Control->Robots->Brookstone Rover Movement Panel
4) Add Control->Camera->Camera Device
5) Select Brookstone Rover from Camera Device List
6) Press CONNECT on brookstone rover movement panel

Any messages in debug?
#25  
several reconnect/init camera attempts:

Code:


EZB 0: Brookstone Image ID: 212-52-195-11
Camera Disabled
Camera Initialized: Brookstone_Rover

EZB 1:
EZB 2:
EZB 3:
EZB 4:
Camera Disabled
Camera Disabled
Camera Initialized: Brookstone_Rover
Camera Disabled
Camera Disabled
Camera Initialized: Brookstone_Rover
Camera Disabled
Camera Disabled
Camera Initialized: Brookstone_Rover
Camera Disabled
Camera Initialized: Brookstone_Rover
Camera Disabled
Camera Initialized: Brookstone_Rover
Camera Disabled
Camera Disabled
Camera Initialized: Brookstone_Rover
Brookstone Image ID: 8-191-146-69
PRO
Synthiam
#26  
Maybe the ARC application is blocked by the windows firewall accidently. Can you disable the windows firewall and try again. That information looks correct - the image id is valid
#27  
No, it establishes connection - motion controls work fine. I can drive, but i cant see.
PRO
Synthiam
#28  
The camera is on a different port. Can you please try disabling windows firewall.
#29  
all ports are open. can you tell on wich port is camera? i'll check it manually