Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

No Power On Ezb

Tried the troubleshooting tips, I'm good on everything except I'm not getting 3.3 vdc on the power pins. What could it be? No lights on both the blue LED and the Bluetooth LED. Regulators are fine too. I tried to unplug and re-pug the chip too.

Thanks in advance.

#5  
Ok both the regulators seem fine.
PRO
Canada
#6  
Also great to hear, that means that there was a short circuit that happened somewhere and the fuse did it's job to protect the circuit.:)
#7  
Ok I don't think I'm being clear enough.
The fuse is fine.
The regulators are also working fine, I think.
Checking the voltages on the caps, the only thing I'm not getting is the 3.3 vdc, I'm only getting 1.5 vdc.

Could this be a regulator issue?
PRO
Canada
#8  
Hmmm, do you mean that the 3.3V regulator isn't working? This regulator isn't hooked up to anything it is just there for Arduino Shield compatibility you could just cut it right off the board or replace it. The chip runs off the 5V regulated voltage from the MIC23900.

Do you have the blue and red LEDs working now?
#9  
cut off the 3.3v regulator.
Still no LEDs.
PRO
Canada
#10  
Seems like the MIC23900 isn't working, this voltage won't show up on the Rails of the board or the pin labelled 5V, it can only be measured at the regulator pins itself or the VCC pin on the PIC chip. I now think that the MIC23900 needs to be replaced.
#11  
Ok
Replaced the regulator with the one from a working EZb just to troubleshoot, still doesn't work.
I put the same regulator back to the working EZb and it still works.

Not getting any voltage on pin 5 of the chip.
#12  
I may not know what I am talking about and I may be completely off base, but could it be a broken tracer? Did you drop the board at any point?
#13  
No sir it's well taken care of...they are very rare so I have to...
However your theory is not completely off base. Maybe if I solder a jumper from 5v to pin 5? Will that work?
#14  
If I had a schematic it would be so much easier...
#15  
Good luck, I hope you can get this working. Had a problem with mine last month but it was my fault. After asking for help and a schematic I got plenty of help but there doesn't seem to be any schematics around that EZ Robot is willing to show for share. They did however send me all the parts I needed ASAP.
#16  
I'm sure I'll figure something out. Not really worried about the parts, I'm sure I can find em around. I'm more worried about frying the chip.
#17  
I would suggest replacing the fuse anyway. I found that my fuse blew and the plastic held it so close to the other piece that it seemed fine, when it wasn't. My fuse was giving me a reading even when it was blown, but it was really low because it was blown.
#18  
@Technopro
Yeah I'm dead sure the fuse is fine. I have another working EZb, and I switched the fuses just to make sure I'm not getting a false reading. The fuse is fine.
#19  
I always use a continuity tester built-in to my multi Digital tester to test fuses. Best way to find out and always correct. If it buzzes its good
#20  
Sometimes occam's razor rules... have you tried removing the chip and then re-seating it? Since you said you are not reading +v on the 5V pin this maybe a moot point... but you never know...
#21  
@Richard R
Occam's Razor is my credo...my designs may seem intricate but my mechanics are always simple...
That's actually one of the first troubleshooting tricks I did...took the chip out and re-seated it. Same with the BT.
The only thing that boggles me is I never mishandled the board, it's always protected...it just stopped working. But like I said I usually figure stuff out I'll keep trying.

A schematic would really help.
#22  
D.J. has videos on troubleshooting the EZB. He will tell you where to look for the 3.3 and the 5V. If you are not getting those voltages the regulators need to be changed. If you send a request to D.J. he will probably tell you to send it to him and he will fix it and send it back. He usually pays for parts. You need to pay shipping to him. But, ask him and see. Request an RMA#.

Heres the Tutorial.

controller troubleshooting.

Good luck.
#23  
@Doombot... I will have an extra V3 board to sell very soon (as I was one of the lucky ones to get the first shipment of V4)... It's yours if you want it...

Richard
#24  
@Richard R

Send me an email and quote. info@ikoncustoms.com
Thanks bro!

@MovieMaker

Already tried that, and then some. but yeah I may contact them for parts.
Thanks!