Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Germany
Asked — Edited

Linux Support

Hi there,

I'd like to experiment with the EZ-Bot Controller/Builder/SDK and like to know if it runs under Linux, perhaps with mono, too?

Thanks a lot, ysf:)

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
Because there are interop calls to the windows OS, it won't work under mono. The Bluetooth connection is open in the EZ-SDK for observing the protocol. You can put the EZ-SDK into full verbose mode and watch the commands being sent.

If you feel like creating your own linux driver to control the EZ-B, feel free:) .. I have thousands and thousands and thousands of lines of code already between the SDK and ARC (let alone the firmware on the chip). If there were two of me, there would be a linux version:D
#2  
Just read this articel: I'm also interested in an Linux Version. I want to implement the EZ_B functions in C++.

Quote:

ou can put the EZ-SDK into full verbose mode and watch the commands being sent.


I downloaded that ugly-Windows 10 thing with VS2015 and put the SDK in full-verbose Mode.

Code:


_ezb.VerboseLogging = true; //_ezb is the Object
//Things like GetADCValue....
Console.WriteLine(_ezb.GetLastErrorMsg);


Is the last call "GetLastErrorMsg" the right function to get all Command being sent?


Im also trying to connect to the ezrobot via telnet (cause port 23). But I get a connection refused. Do I need a password?


Many thanks for answering:)
PRO
Synthiam
#4  
You have apparently skipped the learn section (for protocol info) and software section (for applicable libraries). As newagetomy showed, there's options in the software section. You can find the software section by pressing the software menu option at the top of this website. There are options for linux there. The sdk is different than the mono which is also different than creating a plugin. If you're already running windows, ARC is a good place to start.

Recoding all of the capabilities of ARC in linux will be an extensive task. There's serious accessible power in ARC that you won't find anywhere else

If you could tell us what you're looking to do, I can direct you to the correct resource - and lend a hand :). Otherwise, if you know what you want to do, the resources are described and presented to you in the software section.

The sdk GetLastErrorMsg has nothing to do with commands. The words are GET LAST ERROR MSG. Which means get the last error message. An error is not a command, it's an error. So the GetLastErrorMsg will return the last error message from the ez-b communication.

What I think you're looking for are the protocol commands? These can be found here in the learn section for the applicable product: http://www.ez-robot.com/Tutorials/Lesson/18?courseId=4

As for telnet, the default port is 8080. You can configure this by looking at the web configuration for the ezb. This of course is also covered in the learn section.

The learn section is easy.

1) click learn from the top menu of this website
2) select the product you would like to learn about

That's it:)
#5  
Seems to work under WineHQ with Net Framework 4.6 installed on a Ubuntu 16.04 machine. Installing the Net Framework with Winetricks was hardest part. Hope this helps someone stay with an Open Source OS.
PRO
Synthiam
#6  
Wow. No way? Good job on wine! Someone should make a user tutorial
#7  
Really pretty easy. I didn't use the Ubuntu PPA release of Wine. Used "wine-3.0.2 (Ubuntu 3.0.2-0ubuntu1~16.04~ricotz0)". But whoever tries this should use the latest release at that time. The Winetricks I used was also latest from Github. Tried to install ARC Installer.msi from wine's drive_c with "msiexec /i *.msi /l*v msiexec.log". Use wildcard because of long filename. But install failed because lt needs Net Framework higher than 4.0. This proved to be the hardest part but the secret is to not use Winetricks menu install with prompts and warnings which fails. There's a lot going on with that install. It Flips Wine from win7 to win10 back to ME and fails at a win OK popup. So after 10 tries... From terminal use "winetricks -q dotnet462" which ls a quiet install. Then ARC installed fine. Seems to work OK but I haven't tried everything yet "video" but I bet it works too. Hope this helps and remember Google is your friend.
PRO
Synthiam
#8  
I had tried and the .net installer was where I struggled. The quiet install is the key. Thanks a bunch for sharing with me. I’m certain a number of people will be happy with your instructions.
PRO
USA
#10  
The last time i tried (2 years ago), a lot of broken issues.
Only SAPI 5.1 is supported (Windows XP applications/.NET 4.0)

Can anyone confirm if it works smooth ?