Welcome to Synthiam!

Program robots using technologies created from industry experts. EZ-Builder is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Australia
Asked

JD Robot Occasionally Spasms When Closing EZ-Builder Without Disconnecting First

Sometimes, when closing EZ-Builder, JD's servos violently spasm and rush towards their limits. However, I noticed this doesn't happen when it's disconnected first before closing. I don't know how to replicate this problem nor do I know why it occurs. Has anyone else seen something similar to this before? Or have any suggestions on how to go about fixing this?


Related Hardware EZ-Robot JD Humanoid
AI Support Bot
AI Support Bot
Synthiam
Hey there! This is an automated response from me, the support bot. I've searched other questions, tutorials and controls related to your question. Take a look at these links. They're all sorted by what I believe is the most relevant:
#1   — Edited
Never happened to me with the new HDD servos, but the only time I close ez builder first is/would be by accident... So How to fix it? You already have your answer... Don't close ez builder first... Instead the correct way is to disconnect first. Even turning JD off first is preferred...  Problem solved and less risk of damaging your robot...
Australia
#2  
Sounds more like a workaround than a solution. I'll try and replicate it every now and again to see if I can find a pattern but in the meantime I'll do that. Thanks for replying.