Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by Steve G!

Inline Voltage Regulator Question

I received my developers kit yesterday and have been working with the hardware and software and things have been progressing quite well.

I tried connecting the ultrasonic sensor with the included inline voltage regulator and was getting a reading of 255 on the display. I checked the voltage from the regulator with a digital multi-meter and got a floating reading around the 1 volt range. I then connected a LM 7805 5 volt regulator and confirmed a solid 5 volt reading. i used this set up along with the ultrasonic sensor and everything functioned correctly.

Could I have gotten a bad voltage regulator with my kit? I'd like to use the provided regulator since it is a little more compact and streamlined than the 7805.

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
It does sound like that could be the case. I haven't heard of anyone here who has problems with the 5v regulators and I have several and never had any issues, but of course that doesn't mean that the one you have in not faulty. As long as you have the ping sensor wired up correctly...

(Assuming use of port D0 and D1)
1) Ground = Black wire to D0 black pin (regulator)
2) Power = Red wire to D0 red pin (regulator)
3) Trigger = white wire to D0 White pin
4) Echo = green wire to D1 White pin

it should be reading 5v. Does the red LED light up when connected? I would say try using different digital ports to see if you get a different or the same reading, but as you have tried a 7805 reg which read correctly I don't think it's going to make a difference, but you could try.

If this is the case, you can submit a warrenty claim by using the Contact us link and copy and paste the URL link of this tread in you in to your message, and if it is indeed faulty EZ-Robot will send a replacement

Sorry I can't be much more help than that.
#2  
It is connected as stated above and i did try it on different ports.
I was told that I need to post the problem on the forum in order to make a warranty claim. I can usually find a solution to my technical problems by searching various forums so I don't end up posting on them much.
United Kingdom
#3  
I suspected you may have had it wired up correctly as you stated you had the ping working when you used the 7805 reg (I just wanted to double check). To make a warrenty claim, when you click on contact us, select "Product Warrenty" and tick the box confirming that "you are not asking for technical assistance". That way you won't be directed back to the forum and you can then write your message and post this thread's URL link.
#4  
Thanks!
That clears things up on how to make a warranty claim.
United Kingdom
#5  
No problem. Unless anyone else chimes in with any ideas, I believe making a claim is the way to go I'm afraid (although the guys at the office are usually quick to respond and get things sorted) as it does indeed sound faulty.
PRO
Canada
#6  
Hello @oldsourkraut could you please have a close look at the 5Vregulator board and see if the Vout side is connected to the Ultrasonic and the Vin side is connected to the ez-b? It could have been hooked up in revere order in manufacturing. You'll be able to see these white silkscreened labels on the regulator PCB.

User-inserted image


If the regulator is hooked up in with the Vin and Vout in reverse order the LED will still come on but the voltage output will be wrong, likely a volt or 2 off. It sounds like this could be the case.
#7  
Yep, I checked that also before posting...v in from the ezb, v out to the sensor. I've hooked a multimeter to the regulator and it reads around one volt.
United Kingdom
#9  
No problem. Im pleased you got it sorted.:)