Welcome to Synthiam!

Program robots using technologies created by industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by thetechguru!

I Need Help With A Camera

I got an ACER W3 tablet. I bought it when I heard it ran windows so I could use it with the Sally robot. It runs windows 8.

Now, I bought a wide screen, self focusing Microsoft HD camera. The W3 is set on it's cameras and do not let me use the Microsoft Life-cam. I have tried to install the drivers, but it still uses the tablet's cameras. My camera operates of the USB ports.

If you have gotten any camera to operate off the usb port or even a wireless one, please give me some information on this. I would like for Sally to be able to track people and colors.

any ideas?

Thanks!
:)

AI Support Bot
Related Content
Synthiam
#1  
The USB port on the W3 requires an OTG cable. Did the micro-USB to USB cable come with the W3, and did you get it new-in-box or was it used? It is possible that the adapter is not the correct type.

Can the USB port see anything else with the adapter like a thumbdrive? If not, you have the wrong adapter. If it can see anything then it is the right adapter.

Alan
#2  
Thanks for the answer, Alan. It will give me a starting place to work on it. I am exhausted right now from putting in the sonar and IR and Pan servo. They are working good now. I just have to install some pull-up/down resistor on the IR.
The electronics was not hard, it was just I had a hard time getting to everything.

Look forward to Sunday. Still have not installed new program. It gets to where it is almost finished and it tries to remove the old program and it can't.
#3  
I am sure I'll be able to figure it out tomorrow.

I have had similar issues with programs at work and alway manage to get to the bottom of it.

Alan
#4  
Alan you are my Hero!

Thank You!

MUSIC "I can be by with a little help from my friends!"
#5  
Looking forward to 1pm today (2pmyour time). But, I have some unexpected guests coming over at 11:00AM. They are family. They usually come to visit and we all go out to eat. I will try to break away in time. I might be a little late.

On the W3. It has only one usb port and I am taking to a hub then to the camera. I have to plug it into a hub because it is a male usb standard size on the other end.
so, I have a small usb coming out to a large usb standard plug. I plug other stuff into the hub and it works. But the cameras on the table are taking over the usb camera.
#6  
Re: install no problem. I'll try to reach you around 1 your time, and if you aren't free I can try later. I am free today until 4:30 your time.

Re: Camera. You have the right cable since the hub works. Is the hub powered? The camera might require more power than an unpowerwd hub can provide. Does the camera work on other computers? Have you upgraded your W3 to Windows 10 yet? I have misplaced my Logitech USB camera, so I can't test to see if this is something unique about the w3.

Alan
#7  
MovieMaker, It's good to see you working on robots again. It helps to keep the brain nimble and quick. Working through problems is frustrating but it's good brain exercise not to mention the gratification of working with friends to overcome them.

I know Alan can help you through this. We'er lucky to have him on this forum and to be so willing to lend his expert help in such a personal way. Good "and" knowledgeable people like him are hard to find these days. When I grow up I want to be just like him. ;)
#8  
Yep! Alan is a Saint. Good to make contact with you,Dave.
#9  
@Richard R just tried his Lifecam with his W3 and it worked. you might want to try going straight from the adapter to the camera to eliminate the hub as a possible source of the problem. If that doesn't do it, I am not sure what to try next. Maybe open up device manager and see if the Lifecam is showing up at all, and if it is, if it is indicating a driver issue. Sometimes if you disable/delete a device, then unplug and plug it back in and search for new devices it will install correctly.

Alan
#10  
The Lifecam has a built in mic.... For some reason it doesn't understand me as well as the built in W3 mic.... Actually I am getting only around .75 voice rec... When I unplug the Lifecam I get .95... When you plug in the Lifecam you get the video and the mic too.... I know the mic on the Lifecam works because on another pc it recognizes me perfectly.... I guess I will need to play with this a bit and see...
#11  
I forgot to mention my Acer w3 has been updated to Windows 10... Not sure that makes a difference, but just an FYI....
#13  
The problem with going from the standard usb to the small usb connector is that if I plug the small end in, I will have a standard usb to a standard usb . They are both the same and do not fit into each other. The only way I can get them to hook together is through a hub.
#14  
Oh, that is why you need an OTG adapter cable, and possibly why the camera isn't working in the hub, since you must be plugged into one of the outputs instead of the input (actually surprised it is working for anything).

I think I have a spare OTG. I'll mail it to you if I do. I'll follow up with email if I need your mailing address (I should still have it).

Alan
#17  
I found it. Probably won't get it out to you until next week. I need to grab a padded envelope and we are going to get snowed in this weekend.

Alan
#18  
that works for me,thanks.

God Bless you, Alan!
#19  
Mel,

I finally got around to getting to the post office to get this out to you. You should have it in a couple of days.

Let me know how it works out.

Alan