Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Getting Started With Ezbv4

very trivial question . I have received the ezb today.Never used it.
I found no information saying if power plug is center pin positive or not , and if the voltage of my 6V Ni-MH battery is ok for internal voltage regulator of its controller .It will My servos require no more than 6 V. thamks for your help

AI Support Bot
Related Content
Synthiam
#5  
ok dj. I don't use lipo batteries, no explosion ! voltage warning configuration ok.
#6  
now i'm trying "record". I think it should work with PC internal microphone , the one working with skype . But I get only a low noise. Is needed some command to PC or ARC to make it work ?
PRO
Synthiam
#7  
By "record", i assume you are referring to the Microphone control? Here is the manual page for it: https://www.ez-robot.com/Tutorials/Help.aspx?id=198

*Note: there is a ? (question mark) next to ever X (close) button on each control. Press the ? (question mark) to view assistance for that control.

To understand more about controls, the learn section has tutorials. Here is a direct link to the tutorial that explains ARC and what a control is, such as the microphone: https://www.ez-robot.com/Tutorials/Lesson/21?courseId=6

Additional activities can be discovered here: https://www.ez-robot.com/Tutorials/Course/6

Skype is a different program than ARC. You will need to ensure the microphone that is selected as a default audio device is selected. The information that you require is on the manual page for the Microphone control by pressing the ? (question mark) next to the X (close) button or following the link above.
#8  
microphone issue solved. Windows problem. There was a microphone volume set to zero.
Now I'm working with servos. I discovered that the hitec servos I intend to use in my robot , when driven by EZB, don't do 180 degrees, but about 140 degrees only. When driven by something else they can do even more than 180 degrees. What can I do with ARC to get more degrees ?
#9  
What model Hitecs do you have? I have many in my inMoov (805bbs and 645s) both have no problem doing 180... There are a few Hitec models that do not do a full 180 rotation...
#10  
I have HS805BB , HS5805MG, and HS5745MG . They all exceed 180 degrees if driven by an adequate PWM pulse, and might reach both mechanical ends.
I can't achieve that with EZB builder.
PRO
Synthiam
#11  
The ezb pwm is calibrated for ezrobot servos which adhere to standard servo specifications. Due to other manufacturers not adhering to servo standards, you may experience incompatibilities. Contact your servo manufacturer and have them fix their servos.
#12  
The HS-805bb and HS-805MG are 180deg servos only (I use them in my inMoov). I have no issues with them as far as rotation. That is they both do pretty much 180 deg with ezb servo commands... I certainly get more than 140, that's for sure...
#13  
Hi DJ. I have seen your link to servo standards, and the waveforms shown there.

they give 0.61 ms (1),1,48ms (90°),2,38(180°)
I have instead:
0.56 ms (1),1.340 ms(90),2.140ms(180)
i attach here an oscilloscope image from EZB set to 180, and I get 2.140 ms.
2.38 would be ok, but EZB can't rise over 2,140 ms.
User-inserted image
PRO
Synthiam
#14  
The link you may be referring to displays the values recorded on a v3. The values you are displaying on the v4 are correct.
#15  
the V3 would have been better . Its pulses were good for hitec.
Hitec is a leader in servos, and I think they know industry standards.
I don't understand why V4 has all pulses so short, shorter than V3.
For example, the (1) pulse is too short (0.56 ms) for all servos I know.
#16  
Richard, which EZB do you have ? V3 or V4 ?
#17  
I have the ezb4.... I just tested a spare HS-805bb I have.... using the basic horizontal servo control I got about 170deg rotation.... The servo can move a little bit more by hand, but not much... Close enough to 180 for me. Certainly much more than 140 you mentioned...
#18  
can you measure the pulse duration with an oscilloscope ?
#19  
I don't have an oscilloscope... I just tested it with a servo horn.... set the servo to 1 and then 180... It moved 170 degrees...
#20  
never mind. I'll test with horizontal servo control as you have done. I tested with "movement control (gait)". Perhaps there might be some difference between the two controls. I should have the same results you had.
#21  
Hi Richard, all controls in EZ give the same result.
Not possible to achieve 180° for Hitec servos from EZ. I measured accurately , the maximum is 163°.
According to DJ Sures Hitec doesn't meet servo standards . Unexpected thing for a world leader in servos.
I'll investigate if Hitec programmable digital servos (HS5805MG) could help.
PRO
Synthiam
#22  
First, i would question if the servo you have is actually Hitec and not a clone. Clones are very popular on eBay and even more hobby shops carry them without knowing.

Second, i should expand on my statement regarding not following servo standards by stating that "there is no standard anymore". Maybe that's easier to digest. The original servo specification was never defined in any ISO or standardized document back in the 70's. As time went on, more servo manufacturers were designing servos and specific models of servos which adhered to their own specifications..

The trouble is that you can purchase servo models from 1,000 servo manufacturers and they will all have a different range based on the PWM cycle.

When EZ-Robot designed our servos, we compared with nearly a hundred different models and brands. This has been discussed in detail on other threads. There's a reason why ez-robot is the only company able to achieve what we have accomplished, and that's with diligence.

Our servo PWM was defined by taking an average of servo positions. This is because the GAIT and usability of EZ-Robot Revolution product requires absolute standardized positioning - which is an obvious statement. 90 degrees on all ez-robot servos must be 90 degrees.

Well, adding 3rd party servos to the mix made things complicated because, as you have noticed, there is no "standard".

Note: if the question in this thread had been answered, please select the individual who assisted with your question.
#23  
OK, DJ. there is no standard. Simply EZ servos and hitec's ones are different.
I suggest some software improvement to ARC so users can configure pwm range for their servos . It should't be a complicated work. All users may buy from different makers and even cloners, and would benefit from such improvement.
#24  
I'm now testing Hbridge PWM control panel. It works well, but I don't understand some details, I don't find explained in tutorials.

1)When I start EZb, I find both PWM sliders set to maximum, but giving all commands, the motors don't turn, because the PWM pins give no pulses, and are at logical zero. I have to move the sliders in some way to make them turn. Why?

2)I click to use arrows keys .It works, but if I now move the sliders, the arrow keys work no more, and I have to use the mouse again.
Why ?

3)how to return from arrow keys to mouse without having to move the sliders ?
Toggling the button doesn't help.

I think sliders shouldn't affect other functions, and could be saved in the desired position independently of other functions.

I'm an untrained ezb user, or is there some bug ?