Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Firmware Update Starts But Doesn't Finish

I've been trying to update the firmware on the board. It seems to start just fine, the progress-bar goes all the way to the end... But it never actually seems to finish.

I've tried rebooting my box, re-running the firmware updater, etc... But seem to always get the same results.

Any suggestions?

Thanks!

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
Does the larger LED flicker when the progress bar is moving?

What firmware does your EZ-B report it currently has?

Are you using a USB Bluetooth Dongle? Or does your computer have a built in bluetooth?
#2  
No, the larger LED does not appear to flicker.

Current firmware is 15.1

I am using a "Rocketfish" bluetooth dongle.

Thanks!
PRO
Synthiam
#3  
We've had reports of some bluetooth dongles not working with the EZ-B. I'm going to put up a diagnostic program tomorrow for you. It will talk to the EZ-B and ask it some questions - to ensure a response. It has to do with third party bluetooth stacks.

Are you using the native windows bluetooth stack? Or did your dongle install something else?
#4  
The dongle came with a CD. However, when I plugged the dongle in, the Windows 7 box recognized it and configured it by itself. I did not have to insert the CD.

Heehee, I love the word "dongle". ;o)

I am going to see if I can find a different bluetooth dongle and see if that works.

If you have any other ideas in the meantime, please shoot them my way.

Thanks!
#5  
Hmm. I have a second EZ-B. I am trying this one via a VMWare virtual machine running on a Mac Pro.

I was able to pair the device without any problems. The large LED flashed white for a bit, but when the firmware upgrade was actually progressing, there was no flashing.

It is now, also, stuck with the progress bar at 100%.

One thing I noticed between the 2 EZ-B boards. The first one's LED is orange all of the time. This one, so far, is white.

I am going to have to unplug the board sometime soon or I'll kill off my batteries. What can I do to get the firmware updated? I really want to get to the fun stuff!

Thank you,
#6  
I finally got one of the EZ-B's to update! Tried a 3rd (or 4th) computer and it worked.

The one with the orange light is still T.U.
PRO
Synthiam
#7  
What does T.U. mean?

The orange light one doesn't update? Even on the same computer as the other EZ-B?
#8  
@DJ Sures

"What does T.U. mean?" tits up! *eek* *blush* :)
#9  
LOL meaning "on its back" or "dead"
#11  
Sorry, T.U. means tits-up, broken.

I just tried again, to make absolutely sure, that the EZ-B with the orange light would not update. It still will not.

I've attached a screenshot of where it just hangs.

Is there any way I can reset it to factory defaults or something?

Thank you!
Brent
#12  
Well, I uploaded an image (twice). It is probably quarantined - check that directory

Thanks.
PRO
Synthiam
#13  
@perlguy the uploader only accepts JPG and EZB files, as stated. Check your file extension of the image you are uploading.

You may copy and paste the text from the debug window of the firmware updater. That will help a bit. Really what matters are two things:

1) does the ez-b report a firmware? What is the firmware it reports?

2) does the firmware updater actually start and status bar moves?

If yes to both of those questions - your ez-b is fine. The firmware does not execute unless there is a valid checksum requirement. The program memory is not written during upload. Only apon a successful upload will the program memory be replaced with the uploaded data. The bootloader is never overwritten.

In a few scenario's, we have had issues with some USB Bluetooth Dongles.

You stated there is another EZ-B that you have working - I suspect this is the same computer? If so, remove the bluetooth device for the unworking EZ-B and try again.

I do not know what other software could be affecting the firmware updater, if that's the case also. Perhaps some security software is blocking the port - or adding a buffer delay. We QA test everything on bare-bone installations of Windows.

Is your Windows running in a VM? Are there any other serial devices connected to your computer? Do not change any Serial/Com settings in the control panel. Default settings are required. If the settings have been manually changed, you will need to uninstall device, reboot, reinstall
#14  
Ok, tried again on a MacBook Pro running Windows 7 in a VM. Totally vanilla install of Windows, nothing modified.

Here is what I get...

----------------------

Attempting connection to COM3
EZ-B reports EZ-B Firmware V15.1
Connected
Press the UPDATE button to start upgrade
Starting Boot Loader...

sending ping
sending ping
I am EZ-B BootLoader. Gimmie Firmware!

sending bootloader
Updating... (16,384 Bytes)
??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

-------------------------------

It just never gets past this point with this particular EZ-B.

Any more ideas?

Brent
PRO
Synthiam
#15  
I think you're best solution is to return it. I can't imagine what the issue could be - unless the microchip itself is damaged
#16  
I sent a message via the "contact us" page that has my email and asks for the mailing address to send the device back to. Please let me know the correct return address and I will get it sent back as soon as I can.

Thanks!