Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Firmware Update Questions, Please Help

I have a new EZ-Robot board and in order to use it I have to update the firmware to the latest version. I have followed the video tutorial exactly and have tried 4 times now and every time the EZ Builder program tells me I have to update the firmware. This is what the screen looks like after I try updating the firmware and I have waited as long as 30 minutes for it to do it's thing.

3/22/2013 12:23:57 PM - Sending bootloader
Starting Boot Loader...

3/22/2013 12:24:02 PM - sending ping
3/22/2013 12:24:03 PM - sending ping
3/22/2013 12:24:04 PM - Sending bootloader
I am EZ-B BootLoader. Gimmie Firmware!


3/22/2013 12:24:09 PM - Step 1 of 2) This process will take 2 minutes. The status bar will display progress.

3/22/2013 12:24:09 PM - Updating... (22,656 Bytes)
3/22/2013 12:24:30 PM - Uploaded

I am assuming that since it says uploaded and nothing happed after that statement that the update was completed, even so I waited 30 minutes before unpluging the batteries ( Yes they were brand new batteries). upon starting up ARC and trying to use it it still says I need to update the firmware.

I need help please. I am under a deadline to get this working for a robot here at the Children's Museum and all I can tell them when they ask about it, is that I am working on it.

Help Please.

Dan Stuettgen
fabricator/ exhibit tech.

AI Support Bot
Related Content
Synthiam
United Kingdom
#1  
I took screenshots of the firmware update procedure last week, they are in this topic.

Which BT stack are you using? Only the microsoft BT stack is supported, third party stacks are often buggy and unstable.
#2  
Rich: Not sure what you mean by BT Stack. My laptop did not have bluetooth on it so I had to purchase a Bluetooth dongle. The one I got is made by ASUS USB-BT211 V2.1+EDR The package says it is for windows XP(32/64) Vista and 7. I am using windows XP. This was the most expensive one the computer electronics store had. I didn't think the $10 or $20 ones were a good idea. I have the Bluetooth installed and it sees the EZ-B board and connects to it when I select it. The red LED on the blue tooth on the board stops flashing and goes solid.

It is when I try to connect to the board with the ARC software that it tells me I need to update the firmware. This is where I have the problem as it seems to not want to do that. I have tried 4 times with the same results.

Dan Stuettgen
#3  
Rich : Are you saying that the Bluetooth dongle has to be a Microsoft dongle otherwise it won't work? I have checked a couple computer stores and none of them have any Microsoft brand bluetooth dongles.

Dan S.
United Kingdom
#4  
No no no. The software needs to be Microsoft. Did the Asus one come with any discs and if so did you install anything from them? The BT Stack is basically the software used when pairing etc.

If you did then that could be the problem. Uninstall it and let windows choose drivers etc. for it.

If not then, as frustrating as it is to hear, check your supply and check the com port.

Personally when I update firmware I use an old router's PSU that fits the socket. If it's between 5v and 18v it should be OK. That would eliminate power as the issue.

Keep it as close to the dongle as possible too, although I updated mine from some 4 or 5 meters away.
#5  
I looked over your screen grabs on adding the bluetooth. Mine do not look anything like that. I would assume that is because I am using windows XP Home edition with service Pack 3. I was able to work through it and get to the pairing code and get that entered 1234 and then the Icon changed to a serial port symbol and when I clicked on the connect button, it connected, but did not tell me what port.

I had to guess which one by going to the control panel and looking in the bluetooth listing and checked the profile manager and it showed it on com8. Thats the port I tried to connect with when I started the ARC.

Dan S.
United Kingdom
#6  
Yes, XP looks different. I don't have XP installed on any PC at home so can't grab some... hold on, google...


User-inserted image


Is yours more like this?
United Kingdom
#7  
Also, your com port is probably right as it received the "I am EZ-B Bootloader. Gimmi Firmware" message.
#8  
Yes the Asus dongle came with a driver disc. It took two tries to get the computer to reconize the dongle. I tried to let the computer find the drivers, but it din't find any so I had to use the disc that came with the dongle. I will try what you said and uninstall it and let windows chose the drivers, but last time it did not work, windows never found any drivers. Com ports are Ok, I check the batteries and they are OK, All brand new just for this board. 8.57 volts. I have the board right next to the computer and the dongle is on the other side of the computer. no more than 2 feet apart.

Dan S.
United Kingdom
#9  
I assume you have tried rebooting?
#10  
Nope I don't even get that screen. when I right click on the bluetooth Icon, I get a screen with a Blue ball that says Linvor next to it and and little check box. The box was empty until I did the pairing with the 1234 and then the box got a red check mark in it. It says disconnected at that time. When I right click on it, a box comes up that says connect. I click on that and it connectes the bluetooth to the board as I see the LED go from flashing to Solid and two little green arrows come up that shows it is connected and it also says connected.


I will uninstall the bluetooth a try what you said and see what happens.

Dan S.
#11  
Yet: tried rebooting. Uninstalled the bluetooth like you suggested. I plugged the bluetooth into the USB port and the computer does not see it. I have no Icon in the tray. When I go to the add hardware screen in the control panel, the Bluetooth dongle does not show up. I tried letting to computer find the hardware and it says it can not find anything.


Dan S.
United Kingdom
#12  
In device manager try making it look for hardware changes.

Right click on "My Computer" and choose manage to get to device manager

User-inserted image


Action in the menu and you should see the option.
It should find it. If not, reboot and try again.

It should at least be listed as something in the device manager - probably "USB Device" with a yellow exclamation mark.
United Kingdom
#13  
Quick thought, is your XP running all updates (or at least SP2)? If memory serves me correctly Bluetooth wasn't part of XP prior to SP2.
#14  
Tried doing the device manager thing and letting it find the bluetooth dongle and it did not find it. I am running XP Home edition with service pack 3. I run the auto updates everyday so it is upto date. This is laptop is a Dell Inspiron 8600 with only one USB port. My next step is to find Dell Blue tooth drivers and install them. Right now the computer does not even see the dongle when it is plugged in. At least when I used the Asus drivers , the computer saw it and was able to connect to it.

Dan S.
United Kingdom
#15  
Do you have the option of not installing "Asus Bluetooth Suite" when you use the driver cd?