Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Firmware Update Question

i have successfully connected my ez robot via bluetooth. everything checks out fine and the com port is working perfect. Everything is working, yet the firmware update will not recognize the robot. It's very frustrating and I've watched all the tutorials and gone through EVERY discusion. This is the message that shows up. P.S. I've tried it on different computers of different brands and still had the same results.

Firmware Updater Version: 2013.03.09.00
3/11/2013 4:32:27 PM - Begin

Attempting connection on COM4
Connection Failed: System.TimeoutException: The write timed out.
at System.IO.Ports.SerialStream.Write(Byte[] array, Int32 offset, Int32 count, Int32 timeout)
at System.IO.Ports.SerialPort.Write(Byte[] buffer, Int32 offset, Int32 count)
at EZ_B.EZB.Connect(String hostname, String tcpPassword, Int32 baudRate)
Disconnected
3/11/2013 4:32:31 PM - Connection attempt error

Available Ports:
- COM1
- COM3
- COM4

Have you selected the correct EZ-B COM port? Use the Help menu option to view the online help and watch a video demonstration.

If you are considering contacting us, ensure you have followed the tutorial first. You may find the tutorial by pressing HELP from the menu. If you still feel necessary to Contact Us or post on the forum, we will require a copy of the debug message by pressing the Edit menu option and pasting the debug window contents to us.

Nearly every issue is resolved by properly following the tutorial and ensuring you have the Microsoft Native Bluetooth Stack. This software is not supported in a Virtual Machine.

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
It looks like your EZ-B is on COM3. The lower com port of the two that are added is the EZ-B:)

Sometimes, bluetooth gets confused and it requires a reboot. Windows is strange like that. Also ensure you are using the microsoft native bluetooth stack.
#2  
Thanks for the speedy response! I rebooted the bluetooth, cycled power, and tried Com 3. It didn't work, yet I notice the red led on the bluetooth stopped blinking and remained solid for a few seconds until the firmware update shows the message above again.
#3  
Just a sidenote, I had the bluetooth control pannel side by side with the firmware update, and selected the EZ Robot's info. I noticed that the same moment the red led became solid -right before the firmware showed the message above-It said the connection was in use, and then goes back again. Maybe this isn't relevant, but I think it proves it's trying to make a connection. Please Help! *confused*
#4  
Just for the heck of it, try COM4, see if that will work.
PRO
Synthiam
#5  
Does the blue light continue to flash and never stop?
#6  
I tried all the ports but it still didn't work. Yes, the blue light will continue to flash.
PRO
Synthiam
#7  
The blue light never stops flashing at all? Not even a pause or a noticably different flicker speed?
#8  
Nope. It never stops blinking at all. Is that Bad?
#9  
Hi All,

I am very new to EZ-robot and I think I am having a similar problem:

(1) I have connected the blue tooth and I see the red and blue lights blinking
(2) When I checked the blue to device it said that I am on comm 8
(3) when I run the ezbot calibration I get the following error:

Received:
Disconnected
Comm Err: Not Connected
BbytesToExpect: 0

Received:
Disconnected
Comm Err: Not Connected
BbytesToExpect: 0

(4) Any suggestions to what I may be doing wrong or how I should troubleshoot?

Thanks!
#10  
I have checked the firmware upgrade as well and this is the message I received. So I don't think it is a firmware issue.

Firmware Updater Version: 2013.03.18.00
20/05/2013 12:02:46 PM - Begin

Attempting connection on COM8
Connected to COM8 at 9600
EZ-B reports EZ-B Firmware V16
Connected
Your EZ-B has the latest firmware. There is no need to update.
Disconnected
#11  
I have noticed that when I load servo-calibrate, I receive this message:
Is this what I supposed to see?

Received
Disconnected
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped
TCP Server stopped


Thanks in advance for any advice you anyone is able to provide.
#12  
Biometric, that always pops up when I open a project. that really isn't anything.
#13  
I can confirm the TCP server stop happens every time for me as well. It's not the root of your problems.
United Kingdom
#14  
TCP server stopped is correct, unless you have the TCP server running (which it is not by default).

See the other topic for my recommendations.:)