Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by DJ Sures!

Ez Builder Crashes

Hi, I'm using EZ Builder to control 2 EZB v3s and have a continued issue with crashes. I do have the latest version of EZ Builder and the firmware on both boards is up to date but each time I try to open my saved project I get the error message as seen in the attached photo. I've rebuilt the project several time and get the error most times I open my project. If I open the project multiple times it will eventually fully load and work but its a bit annoying.

Any ideas what may be going on?

Gwen
User-inserted image

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
Can you post your project for me to review? I do not have a Sabertooth to test with and I believe there is a bug in the sabertooth module - at least that's what I can deceiver from the stack trace.

Reviewing your project will help me
PRO
Synthiam
#3  
thanks! i'l take a look for you today
#4  
Bummer, Now, since I've added more button assignments (PWM commands), My project will not load at all. :(
#5  
Gwen, I'll confirm the project has a problem. I opened it from your link into my Win 8.1 laptop and I got the same message. I X'ed out of the message and the project loaded and had only 4 or 5 controls. Then I saved it to my desktop and tried to open it, got the message, x'ed out and only the Sabertooth control and MP3 Trigger control opened.

DJ's on the job and you can bet he'll get it figured out. Good luck.
#6  
It looks like it's the MP3 Trigger control. I deleted it and now everything loads OK for me. I see you have it set to board 1. I think the MP3 Trigger will only work on board 0. Try moving starting with the file you posted and make the change and see what happens.

EDIT: Nevermind. I tried a few things in the Trigger control and nothing helped. Hopefully DJ can find somthing.
#7  
OMG, Now that sounds simple doesn't it Dave... ;)

Board 0 is in the lower section, board 1 is in the upper section. The two robot sections are connected ONLY by a 30 amp Mercotac rotating connector


Oh, the pain... Lol,,,
Mercotac Slip Ring Connector
#8  
Wow, that's a cool little gadget. I wish I had know about this when I was building. I read a lot of posts where people were looking for something like this. I'll have to keep this in mind.

As far as the MP3 Trigger and the board that it assigned to I really think I remember it having to be assigned to board 0. However I may be wrong and I have no way to check as I've moved on to the V4. This also may have nothing to do with your problem loading. Sometimes I'm just no help but I try. *confused* At least I can give moral support. ;)
PRO
Synthiam
#10  
Thank you for informing me about the error - it is fixed for tonight's release of ARC. The mp3 trigger will work with all EZ-B board indexes (not limited to #0)