Australia
Asked — Edited

Experiencing A Gradual Drop In Voice Rec With Bob - Any Clues ?

First of all, the voice recognition on the EZ-B is excellent. I was blown away by the fact you can add so many actions and sounds to run at the same time with the same voice command. What I'm experiencing now is response drop out. All the commands seem to drop out from a 5 to 10 minute interval. For a while Bob obeys and behaves like a good robot but before long I'm screaming at him with no response. If I switch off the pc and reboot Bob starts off listening as he should then the cycle starts again. Now I have tested the VR on 3 pc's (we have 8 in the house) and it seems to be a consistent problem. Is it Windows 7 I'm using or something else I'm not sure ? Does anyone else have this problem ? ;)


ARC Pro

Upgrade to ARC Pro

Stay at the forefront of robot programming innovation with ARC Pro, ensuring your robot is always equipped with the latest advancements.

#1  

Collect more data,.how many voice commands were used? How many did you give.before the drop in performance? How.much ram.does your PC have? Have you monitored system.resources to see if.they are running low when VR stops working? What kind Mic?

Australia
#2  

Your right, I'll check these areas out - I might be overloading something.. I'm using a guitar hero mic with usb connection to the netbook.

#3  

First thing I recommend is try using a analog Mic. Using a non native USB Mic requires processing power away from your system resources, Netbooks are lower processing power so anything that can speed up getting audio to you hardware the better. Use the actual Mic jack

Australia
#4  

Thanks for the tip jstarne - Analog Mic, - I will be looking to get one soon.... I'll update as soon as I confirm the problem is resolved.. :D

Australia
#5  

Update ..

Realtek audio driver - FIXED PROBLEM

United Kingdom
#6  

Useful to know Hazbot

#7  

Great! I'm glad it was that.simple

Canada
#8  

Ah, good to read this... It is confirmation of my similar issue and tentative resolution (tentative as in seems to work, but haven't tested enough to be totally sure).

My net-book also had voice recognition/speech issues. In my case, no recognition with internal mic (but Windows 7 recorder worked OK). But recognition worked great when plugging in external mic.

Then I also noticed dropout issues, it seemed to recognize my command (at least it showed as such in the little debug window), but whatever speech/action reply stopped working after a few phrases. Simply restarting ARC resolved it for awhile.

Final resolution was back to installing Realtek drivers (only available for Vista) instead of native Windows 7 drivers.

I am finding that all the issues I have had with ARC are all related to the hardware and/or drivers on the PCs I am running at the time. Very robust software to work as well as it does on nearly unlimited hardware/driver combinations. But troubleshooting those issues can add to frustration (And I am a PC tech by training... imagine what it does to non PC savvy users:) )

Gunner