Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Canada
Asked — Edited
Resolved Resolved by thetechguru!

Connection Question - Multiple V4's

Good Day,

I've been burning myself out trying to get this fixed. Read multiple threads
but I'm still stumped.

I was proficient in the V3's but just recently got back to working with the V4's.

I have (2) V4's that I'm trying to connect to my router.
I originally thought it was a router setting (LinkSys) but I'm now on router
#3 with a barebones setup (no internet) and it's giving me the same issue.

Both V4's are setup for Client Mode to router Lumpy#3
Both V4's say connecting to network
Both V4's give me solid green lights
Only (1) V4 shows up in my DCHP client list
Only (1) V4 is found when searching in EZ Builder

Thoughts on why this may be? It seems my router only wants to recognize
(1) of the V4's at a time.

The mac addresses are very close 5D & 5F.

Any help would be appreciated. I'm heading to Red Deer's first Mini Maker Fair next month with my 1:1 Aluminum R2-D2 and would like to have this resolved for then.

Kris

PRO
USA
#1  
Lumpy,

1)connect EZB "one", find the ip from your router page, ping the IP from a Windows console. Write it down. Switch off EZB "one"
2)connect EZB "two", find the ip from your router page, ping the IP from a Windows console. Write it down. Switch off EZB "two"

4) If you have both EZBs returning the same IP, something is wrong the DHCP IP
lease. Stop here!

3) switch ON both EZBS, wait a few seconds.

2) Ping the first and second IP, are they returning data ?
#2  
If these are older (more than 6 months) EZ-B's, you may want to get a PicKit programmer and follow the instructions here: http://synthiam.com/Products/ARC to flash the latest firmware.

Older EZ-Bs had an issue where the DHCP server would keep running in client mode, so the first EZ-B would work fine, but the second could get its address assigned by the first EZ-B instead of the router if the router responded slower to DHCP requests. This caused all kinds of strange behavior both with the EZ-Bs and with other devices on the network because you could wind up with multiple devices having the same IP address.

When you go to the EZ-B's web site to configure it, is there a version number listed on the lower left side? If no version number, then you probably have the issue. If any version number, you probably don't although I am not 100% sure of that. When I am home tonight I can let you know the current version number that I know doesn't have the problem.

Alan
Canada
#3  
Hi ptp,

Something weird going on.

I did as you said.
Board 0 popped up as 192.168.1.14. Ping'd OK
Board 1 popped up as 192.168.1.4 Ping'd OK

After all that went back in to ARC and now they are 192.168.1.3 and 4.

Weird. I'll have to keep an eye on it.

Kris
Canada
#4  
Alan,

That is probably my issue. These were first run V4's as I was an early adopter.

Wonder if the EZ Robot folks could help me out if I swing by their shop sometime.

I see no version # when I connect to these V4's.

Kris

*Edit * Got a Pickit3 clone on order. Not sure if it will be here before June 11th. (MakerFaire). I'll see if anyone locally has one but not counting on it.
#5  
So, there is a workaround since you are familiar with router configuration and it sounds like you will be using a router specifically for this, and not general use so impact to other network devices won't be an issue.

You need to reserve the IP address of the EZ-Bs and the PC and always start them in a certain order.

Reserve the first EZ-B as 192.168.1.2
Reserve the second EZ-B as 192.168.1.3
Reserve the PC as something with a higher last octet. Doesn't matter what. Say 192.168.1.10.

Always start the PC first.
Then start the first EZ-B. It will be assigned IP 192.168.1.2 by the router.
Then start the second EZ-B. It will be assigned 192.168.1.3 by either the first EZ-B or by the Router whichever responds first (the EZ-B will always try to assign the lowest available octet, the router will use the reservation but in either case, it will be .3).

If you are going to have other devices on the network, also reserve their IPs and make sure they boot before the EZ-Bs or give them static IP addresses and DNS settings so they don't rely on the router's DHCP server.

Before the fix was available, I used a second router plugged into my internet router just for the robots so they had their own network and used this procedure.

Alan
Canada
#6  
I'll give that a whirl. I've got it all on a dedicated router.

I've got an email out to the maker group here to see if anyone has a pic kit programmer.
Canada
#7  
Hopefully will have this resolved soon.
Canada
#8  
** Update **

Did the firmware update last night on both my V4's. Everything is working just spiffy now.

I looked back at my initial threads about connection issues when I first
got them a few years ago and had a chuckle.

Now just waiting for ptp's v2 firmware to play with.

Kris