Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Australia
Asked — Edited

Connection Drops Out When Connecting From Android Phone App

I have a ver 1 I/O EZ Robot board, not sure if this is a problem, but when I try to connect to my android phone through the App, the conection drops out straight away. I can however connect to my android tablet through the app. I can't upgrade my board to the latest firmware as it says its only for ver 2 now, so I'm not sure how to downgrade to the last version for the version 1 I/O board, so I can't upgrade the firmware to the latest version compatible with version 1 now. please advise why I can't connet to my android phone?

AI Support Bot
Related Content
Synthiam
Based on your post activity, we found some content that may be interesting to you. Explore these other tutorials and community conversations.
PRO
Synthiam
#1  
I believe the customer support a.i. Answered your question:) very cool.

If you'd like to expand....

What does "connection drops" mean?

Why can't you upgrade the board?

What android phone is it? Are you sure you're using t correctly? There's versions of android that attempt to detect internet connections. The robot is not an internet connection, so the android device will disconnect from wifi. The android device will prompt to tell you there's no internet connection. If you ignore the prompt by the android device, the wifi will disconnect. Do it ignore prompts of the operating system. Android is developed by google, and they have prompts for various scenarios.

See the first link in the robot customer support response above. Here it is to avoid scrolling: http://www.ez-robot.com/Community/Forum/Thread?threadId=10442

There's a great tutorial that explains how to use the app. What robot do you have? Select the robot in the learn section to access relevant tutorials.
Australia
#2  
I have a Samsung Galaxy S7 Android Version 7.0
I connect to the Wi-Fi of the EZ Board ok, open the ARC app, open my installed app, select connect,
It drops out of the App and small window pops up on phone saying " EZ- Builder has stopped
Open app again
Send feedback
I loaded the lates EZ-Robot software on my computer. When I the EZ-B firmware update V4, the window says it is only for /2 Io Board, mine is a /1 io board, it won't update, I can't find any information in videos on this.
Not sure if updating to latest firmware will fix this anyway.
#3  
I don't think the standard V4 will take a firmware update.
#4  
Zap is correct, you need the /2 comm board for firmware upgrades, which is an inexpensive update, but I don't think that is the issue. As DJ pointed out, Android will attempt to connect to a WiFi network with an internet connection and will often drop connections without internet if there is a known good network in view. Have the same issue with my GoPro Hero camera.

If you are within WiFi range of a router that your phone knows, it could be causing this. It could even be dropping the WiFi for an 4g signal.

Simple test is turn off cellular data and tell the phone to forget your home network. If that stabilizes it, there are things you can do to prioritize the robot wifi and keep internet on the cellular network. I believe they work on the G7. Absolutely do on the G8. If the test works for you, I'll power up my G7 Edge and provide instructions.

Alan
Australia
#5  
Thanks for the advice. Tried forgetting my home network and turning off data, and connected to the EZ-Board network ok, but when I opened app, loaded project and as soon as I connected, the app closed the same as before, with the same message. Also switched off Bluetooth.
PRO
Synthiam
#6  
Please read my previous post AND follow the link i provided for more information. On some devices, Google has created this silly "feature" that disables wifi connections if there is no internet connectivity. It's only on some phones - AND when it does, it will pop up a message during wifi connecting. If you ignore the message, what you are experiencing will happen.

I wish there was something ezrobot, or any other company on earth could do to disable this "silly google feature", but there's nothing that can be done.

You simply have to not ignore the message popup. You have to click the message popup with your finger and select an option to allow wifi access. If you ignore the message, you will not have a wifi connection.

Please reread my previous post and visit the provided link.

Also, some people say to do this..

Quote:


From: https://android.stackexchange.com/questions/131132/force-marshmallow-to-keep-a-wi-fi-without-internet-access

To disable automatically disconnecting from a "poor" WiFi network, you will want to toggle the Avoid poor Wi-Fi connections setting.

This can usually be found in Settings > Wi-Fi > [menu] > Advanced > Avoid poor Wi-Fi connections.


Here is a google support conversation regarding this ridiculous "feature": https://github.com/eryngii-mori/android-developer-preview/issues/2218

Here is a stackflow discussion on the topic: https://stackoverflow.com/questions/37218510/android-6-0-1-force-wifi-connection-with-no-internet-access
#7  
Although feature available on the same phone do vary by carrier, my Verizon Wireless Galaxy S7 edge does not have that feature. It does have a feature calls Smart Network Switch which will drop a poor wifi connection in favor of a good 4G connection. It shouldn't activate with cellular data turned off, but if you have that feature, I would suggest trying to turn it off.

Also reached through Settings > Wi-Fi > [menu] > Advanced >

The difference with how Smart Network Switch on Samsungs is supposed to work, is that it will keep the WiFi connection active for devices in its own subnet (ie, EZ-B) but send Internet traffic over the 4G network.

The other thing you should try, assuming you will be using your EZ-B at home, is to put your EZ-B in Client mode and then just leave the phone on your home WiFi network to connect to it. Eliminates the problem of network switching completely. See the connection tutorials in the learn section for instructions on setting client mode.

Alan