Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Bluetooth Troubles

Got my EZB kit today and I'm very excited. All I want to do for now is see a servo move. :D

I've followed the setup instructions. Upgraded the firmware. And now I'm following the steps to just get a standard horizontal servo moving.

The problem is I can only connect on COM3. There is a COM4 option but it won't ever connect to that one.

COM3 will connect but as soon as I start to assign the servo it loses connection.

I'm a Mac/Apple guy using a borrowed PC to try this out. It's running Windows 7 Home premium. It's got 8GB of RAM and has a 2.5GHZ intel i5-2450m CPU. The bluetooth installer looked the same as the video.

The only differences I've noticed from the video are it won't connect to the second port at all and in the tutorial it says you'll find ARC in the Add Device menu but it was called 'livnor' instead. Also, when going to update the firmware it would not connect on COM4, the second option as DJ mentions in the tutorial. It would say the write timed out. But with COM3 (option 1) it connected perfectly.

Any thoughts as to why the connection keeps dropping? Thanks! As I said I just want to see a servo move from my control!:D

AI Support Bot
Related Content
Synthiam
#1  
Also, in an unrelated/but not really question, when attaching a servo cable to the EZB, is there a correct way to do so? I don't want to short circuit anything attaching things the wrong way.
#2  
When connecting the ez-b bluetooth some bluetooths give two ports high and low port low port is the one you connect to and upgrade firmware through. The device is initially named livnor so this is correct. As for servos they should be connected as is: (black or brown) to gnd, red to 5V, and (white or orange) to EXT/Signal. If connected the Bluetooth shouldn't drop connection uneless out of range or a malfunction such as a brown out or damage occurs due to inproper opperation.
#3  
Thanks for the reply and the info on the low port and colors of the wire.

I'm still having no luck connecting and making it work, unfortunately. It's not an 'out of range' problem because the EZB is inches away from the laptop and the laptop is less than a year old, so I think it's in good shape.

Now I can't even get it to connect.

I tried re-pairing it with bluetooth by deleting the old device and re-pairing it with the computer. Also unplugged and plugged back in the EZB. It picked up and this time it said the device was ARC, so that's good. Got it re-paired successfully and then opened the software and it said my firmware was out of date.

I closed the software, reopened the Firmware update and could connect to COM3, but then it gave me an error and disconnected from the EZB.

Not sure what's happening.

Most of the time when it was connected as a bluetooth device, but not able to connect through the software, there's no red light on the EZB (which is, I believe, as it should be) but the blue light just pulses slowly. Is that correct? From the tutorials I thought it was supposed to remain on unless it was receiving commands.

Sorry to be such a noob, but for whatever reason (probably user error), this isn't working for me as it does in the videos.
#4  
No reason to call yourself a noob everyone has to start some where. The EZ-B has two light one located on the board itself and a small surface mount on the bluetooth. Both should blink when not connected, onboard more of breathing but same idea, and both should be solid when connected. The onboard LED is different on everyone's board as DJ likes to mix it up a little and throw in random colors. I have had a couple times when the LED on the bluetooth doesn't turn on when power is introduced but you can usually disconnect power and repower up and it usually comes back on.
#5  
Thanks again for the info on the lights.

Little more info here that hopefully will shed some light on what I'm doing wrong.

Here's the common problem:

Plug in EZB
Open Software
Connect Board 0 to COM3
Got to Add Device
By the time my finger leaves the trackpad after selecting 'Horizontal Servo' the EZB is disconnected.

So I Remove the device from Bluetooth and repair it. Most of the time it won't take, so I unplug and replug in the EZB just to be sure. Finally, after several attempts I was able to get it re-paired.

But then I just got back into the same cycle as above.

Checked the info on the COMs

COM3 - Outgoing - EZ-Robot 'Dev B'
COM4 - Incoming - EZ-Robot

I know on the site here it says to make sure to use the standard Windows Bluetooth and by everything I can see, I am. I checked the System Bluetooth settings and info. THey read as:

HARDWARE
Standard serial over bluetooth link (COM3)

DEVICE FUnction
Manufacturer: Microsoft

Status: Device Working Properly

I also ran an update for bluetooth drivers and they are up to date.

EZ-Robot Device Properties
SERVICES
Serial Port (SPP) Dev B COM 3 (and it's checked)
#6  
I am sure you have gone through the tutorials multiple times. You should be able to simply pair with your ez-b and then be capable of connecting via ARC using the lower port, if all firmware is up-to-date. From what it seems unless you don't have enough battery supply then there would have to be a problem with the unit itself. Check to make sure the batteries are capable of running your ez-b, if have to get some new ones straight out of the pack if your using the standard battery pack that comes with the ez-b.
#7  
Yep. These are brand new Duracells right out of the package. I've set it aside for the night. Will try and tackle it again tomorrow. I'll try a new set of 6 batteries tomorrow and see what happens. I appreciate your help.
#8  
So I'd put everything away and went and had dinner and stuff then I wanted to try again, so I set everything up, removes EZ-Robot as a device, re-paired, etc...and it WORKED! I was programming servos and they were moving and it was neat.

THen I decided I wanted to build a cardboard mock up of the puppet mouth I want to build. As I sat to cutting up a box, EZ_Builder dropped the connection to the Board. Once I had the mouth made for the servo, I couldn't get the computer to reconnect at all.

I, once again, removed the device from bluetooth, repaired, and nothing. Then I can't get it to reconnect.

Is there some sort of PC Bluetooth setting that causes time outs? Remember I'm a Mac/Apple guy so if there's some switch that's common knowledge, I may not know it. Thanks for the help.
#9  
Dj has said that the bluetooth stack that is ran by windows is a bit fishy. I do believe he has stated that if you remove windows bluetooth then reconnect a device and have it reinstall the bluetooth protocal it may fix the problem.
#10  
I had the same problem a week ago. When connecting the link would disconnect after 10 to 20 seconds. I did all the deleting bluetooth devices, restarting the Win7 PC, etc. The only way I finally got a stable connection was by using a different USB bluetooth dongle on the PC. I don't have the vendor name of the bluetooth device but the USB stick is blue and has the bluetooth icon in the plastic.

I just received and installed a new bluetooth USB class 1 stick from Amazon.com and replaced the bluetooth board on the EZ-B V3 with a class 1 BlueSM1RF Gold from Sparkfun.com. After discovery, and password bonding the connection is stable with no disconnects. The bluetooth USB stick is from Targus and is labeled "USB Bluetooth 2.0 class 1 adapter with EDR. It sells for $20 shipped.
#11  
@Robot-Doc Thanks for your advice. Not sure I'm quite technical enough to replace something on the EZ-B myself. Little beyond my tech knowledge.

Tonight I went to Frys and bought a Kensington 2.1 USB Micro Bluetooth adapter ($20). Following directions from online I uninstalled the bluetooth stack from windows. Installed the new drivers.

The EZB worked for about 10 minutes! I was able to test out some things and then it promptly lost connection and I haven't been able to get it back since.

More than a little frustrating. Will keep fiddling till I get it, but I'm about out of ideas.
#12  
According to what I've read posted in these forums, the only bluetooth stack that is supported is the Microsoft bluetooth stack. It is best to uninstall any third party bluetooth stack / drivers and just use the Microsoft versions.
#13  
More experimenting tonight and still no luck.

When I look in the system to see what BlueTOoth stuff is running it says:

Intel Centrino Wireless Bluetooth 3.0 High Speed
Microsoft Bluetooth Enumerator

I checked the drivers for both and they are current.

Here's what happens...

10PM
- Restart computer.
- Plug in EZ-B
- It connects right away and is recognized.
- Open ARC software.
- Add one servo. Test. Works fine.
- Add second servo. Test. Works fine
- Add auto release for both. Works great.
- I'm laying out my robot in cardstock first so I begin attaching the cardstock lower jaw.
- I got to test it and the serve (which was set to only move from 1-20, spins a total 180 and the connection to the computer is lost.
- Try to reconnect and it won't.
10:05PM

The only other thing I can think of, and I'm not a Windows/PC person so I don't know, is there some sort of setting that automatically switches the Bluetooth off after it hasn't been used in x amount of seconds/minutes?

I just don't know what I'm doing wrong or what exactly is not working and I'm starting to feel like I spent $260 on something that I can't use. I just can't see what I can do different.

I've bought a Bluetooth adapter and installed the software and then uninstalled it when it didn't work.
Folks on here say to use the built in Microsoft stack, it works, but disconnects.

Is there more information I could provide here that perhaps would help someone diagnose the problem? Is there and EZ-B expert in SoCal I could take everything too?:)
United Kingdom
#14  
Hi Toaster boy this does sound like power problems check the connections to the EZ-B board or use a seperate PSU rather than batteries. If the connection is stable without any servos connected for a number of minutes then you connect a servo or two and it loses connection then it must be something that is power related. I don't know of any timeout setting on the Windows bluetooth stack which is what I use.

You are obviously getting there keep trying
PRO
Synthiam
#15  
What connections do you have to the ez-b? It does sound like a brownout. If you're putting too much strain on the servos, and the batteries can't handle it, the board will reboot.

Also, if you're using windows in a vm or through parallels, sometimes can be a hassle.

Other than that, it's very straight forward. It's strange to see the issues you are experiencing when there are so many thousands of others without. Perhaps the board is defective, but the fact that it connects says it most likely is fine.

Can you connect the ez-b without any peripherals. Then connect ez-b to ARC. Then wait a few seconds. Ensure the connection is maintained. Then pick up the board and move it around. See If it disconnects.
#16  
Thank for the replies and suggestions. I appreciate the support this community gives.

I am not using parallels or anything. Using an actual Dell PC.

I guess it does seem to be something power related. I plugged in the EZ-B and it connected right away. Let it sit for a few minutes and it was fine. Then opened the ARC software and it connected. I let it sit for a few minutes and the connection was maintained. I moved the board and battery units around and it maintained connection.

I then attached to servos. One had a movement from position 25 to position 75. The other had movement from position 1 to position 100.

I was able to control them for about a minute before connection was lost and I was unable to restore it. Neither the EZ-B or battery pack moved during this time.

I checked the connections on the battery back where I attached the plug when I first got the set and they seem fine.

Can the battery pack, which has brand new Duracell batteries in it, only move one servo at a time? Do I need a bigger power supply if I want two servos to move at once?

Again I thank you all for your patience in helping me work this out.
#17  
You might want to consider either using the power supply offered in the Store page or build you one with a higher capacity. The AA batteries don't really have the ability to provide high current demand that your servos evidently need.
Australia
#18  
Hi TB, Isn't the world of Robotics exciting and frustrating at the same time. I remember how excited my son Austin, brother Dean and I were to see the first servo move via the EZB. Issues I had similar to yours were mainly related to low voltage. If I started with brand new batteries and the voltage dropped to 6 volts or less I would loose connection. Even quality batteries hooked up through the kits battery pack never seemed to last long. Today we use a 11.1 2 amp lipo with a pc fan blowing over the board and in the hundreds of times Bob starts up we've never had a problem. The other thing you need to look at is the bluetooth adapter on the board itself. Whilst everything like the pins and processor are soldered in solid, the adapter saddles on top and is a bit flimsy. Mine wobbled up and down a bit and with it the connection. I used a rubber band to hold it in position and bingo - no problems since.

Anyway, good luck, it's a great and rewarding journey and there is a lot of help at this site.

Cheers




:) :) :)
PRO
Synthiam
#19  
You should be able to move many servos at a time with the battery pack. All 6 that are included in the kit. Can you do these two things for me please...


1) Do the voltage regulators get hot when it is connected to ARC with no servos connected?

2) What happens if you do not connect servos to the EZ-B - but you set the controls to move servos on D1, D2. I'm asking if you can add controls to move servos that aren't actually connected. Have nothing connected to the EZ-B, and merely add a servo Control, Select Port D1, and move it. Does it still disconnect?