Asked — Edited

Ar Drone 2.0 Camera Not Working

I am trying to connect my AR Drone 2.0 to ARC and I can get it to fly but for some reason I cannot get the camera to work. I can activate the camera on my computer however it will not allow me to switch the camera to the drone. I do have V2 selected and the config and connection with the drone appears to be working as the other features are functioning.

I have the latest version of ARC as I just downloaded it 2 days ago and I have the latest firmware on my drone.

Has anyone encountered this?



Upgrade to ARC Pro

Subscribe to ARC Pro, and your robot will become a canvas for your imagination, limited only by your creativity.


Camera is working fine for the AR Drone v2. Perhaps you're not selecting the camera device for the drone. For example, you're using the camera on your computer as you stated. You need to select the drone as an input device THEN press Start.


Thanks for the quick reply unfortunately watching the videos and the posts did not offer a resolution to my issue. I know I am a little late to the AR Drone 2.0 party as far as tech goes and I plan to upgrade/design my own copter in the future but for now I would like to enjoy the features a lower end model has to offer.

I will keep plugging away trying to find the answer.

Thanks Again



When I select the camera for the AR in the dropdown the log runs an error code;

Drone v2 Video Error: System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port) at EZ_B.ARDrone.ARDrone.xFgqNfYKnb()

The IP matches the drone address and it will say it starts the camera but again throws an error.



forbidden by its access permissions

Sounds like maybe a firewall issue. Are you using Avast! internet security? It is particularly aggressive. Suggest disabling your Anti-virus/firewall or adding ARC.exe to the exception list.



Another thought for troubleshooting. If you are on Windows 8.1 or 10, download Parrot AR.Freeflight from the Windows store and see if it works (probably won't be able to fly if you don't have a touchscreen, but should be able to see if the camera is working).



Great idea.... I will give it a shot later and let you know. I do use my laptop for work and have a very aggressive firewall. That may also be causing some lag in QGroundContol.

Thanks I will keep you posted!



What version of Qgroundcontrol are you using? I was using version 2.4, which I didn't actually like as much as 1.6 with the AR Drone, but 1.6 stopped being able to download maps. Everything between 2.4.1 and 2.7 I could not get to work (and the UI completely changed), but because of the expanded flight restriction area around Washington DC I stopped flying last summer. They have adjusted the restriction to allow hobby drone flying near me (although I need to tell the local Police Helipad when I plan to fly because I am within 5 miles) but I haven't tried 2.8 or 2.9 yet (I didn't even know they had an Android version in Beta now).

Even when it worked I found the application very frustrating. Virtually no documentation and a not very intuitive user interface. Frustrating too that most of the developers of other apps have moved onto newer and higher end drones and stopped doing any work on the AR Drone even thought Parrot is still selling it (and they clearly have moved their attention onto the Beebop and their other products. They had promised to add Director mode to the Android app years ago and it never happened).




Thanks for the input. I am using 2.9.4 and I honestly cannot get it to utilize all of the functions of the GPS, very difficult to load maps, and it does not recognize my location in degrees of lat/long. I really got into hobby aircraft while obtaining my class A pilot's license (still have a few solo hours left) but I am handy in the shop and decided I wanted to build fixed wing model flyers from scratch materials.

I had quite a few successful attempts and as a Christmas gift from my Mom and Dad this year (I am in my early thirties so its not like a make a list for Santa haha), they decided to purchase a Parrot AR 2.0 Drone. Advice from my girlfriend and my dad having come out for a few flights (crashes on my fixed wing prototypes) they figured it would be a good gift. Honestly I never considered the world of drones and quadcopters, being fearful as a young pilot probably, so I was quite skeptical. Since the first flight I was fascinated by the concept and physics of keeping this aircraft airborne so my mind immediately wanted more.

I have purchased multiple upgrades, apps, controllers, etc and I am very agitated that this product, as you said, has been left in the dust. Now nothing against EZ Build as this is not their product nor is this a flagship program for AR, but Parrot so quickly discarding the thought of upgrades for a newer version. The best and most "fun" I have had with the Parrot 2.0 is a good ol ipad and freeflight with a TP-link repeater to extend the range.

All of the other add-ons, Nexus 7 (no updated software) PC versions of ground controllers, Shield ios controller, GPS USB flight controller.... all rendered useless by Parrot's failure to support this model. Frustrating as I see videos from 2013-2014 where these were being used seemingly flawlessly. Shame on Parrot as they forgot the limitless imagination of its users.

No onto my next venture. I am going to attempt to construct a drone titrated to my own wants. I just need to do some research so my hardware is compatible with all the capability I want it to have.


PS Sucks about the flying restrictions! Glad they got the loosened so you can get out and fly. I am in North Eastern PA, as long as you can get over the mountains it all smooth calm sky.



Several hours trying to allow the specifics through my firewall, though no exclusions should prohibit the camera operation, still no luck. I have concluded that yet again the newest version of control software has overlooked the Parrot 2.0. I even went down to the details of allowing the designated IP that was an "error" or not allowed.

All other function exists, even emergency mode and clearing the emergency mode.(The Drone responds with the same LED response as when on the basic IOS which tells me the software is relatively functional.) The drone is mildly responsive, maybe more so with the camera activated. I even explored my directX and video settings to make sure this was not a hiccup. No such luck in discovering a problem. I was able to connect video through other means with the same IP and firmware which tells me this is not a firmware nor a hardware issue.

I even tried the repair installation for EZ Build which I initially installed 72 hours ago. Bottom line, when you begin flying either resume using the older version of this program that may or may not have worked or stick to the basics and fly for fun and not function.



I'll test the camera with mine as soon as possible. Probably later this week (maybe tonight). DJ did do an unrelated fix for video recording since the last time I used my drone with ARC. Maybe it broke something. I'll confirm.



Tested on my AR Drone V2 and after a little trial and error, I got it working.

Your project needs to have an AR Drone movement panel. In the settings of hte movement panel, select V2, then in the movement panel, click the "Connect" button. Only after the Movement Panel is selected can you select the AR Drone camera in the camera object and have it work. If you have connected the Movement Panel but are not currently connected, the camera will give that error (if you try to connect without ever having connected the Movement Panel in this session, it does not give an error, but the camera does not display).

I suspect you may have V1 selected in your movement panel. All of the flight controls are the same, only the video API is version dependent.



Also to note: There is a ? (question mark) next to the X (close) button of every control. Pressing the ? (question mark) will bring you to the manual page of that control. The two controls in question are the Camera Device and AR Parrot Drone Movement Panel. Pressing the question mark on either of those controls will provide you with their respective manual page.

The manual page of both devices specifies that the AR Parrot Drone Movement Panel must be connected and configured for the video device to work.

Camera Device manual Page:

AR Parrot Drone Movement Panel manual Page:


Thanks for the help guys but still no luck.

Camera Initialized: AR Parrot Drone @ 320x240 Drone v2 Video Error: System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port) at EZ_B.ARDrone.ARDrone.xFgqNfYKnb()

Still this error.

I have tried the following:

  1. Allowed all EzBuild .exe files through my firewall.
  2. V2 has been selected PRIOR to connection since the start
  3. Movement panel has been opened and active prior to attempt to connect the camera.
  4. All sequences have resulted in this error along with changing resolution quality.

What am I missing?




I'm am unsure how, but you may want to make exceptions in your antivirus for the ports the AR drone uses, which I am also unsure of.



I'm am unsure how, but you may want to make exceptions in your antivirus for the ports the AR drone uses, which I am also unsure of.

Well, we know from the error that 5555 is one of them.

Were you able to try the Windows version of AR Free Flight to see if it can see the camera?



Ah... I missed that. It does not.

So now how to I get this through the anti-virus or firewall?

I am running McAfee to open a Citrix VPN and my firewall may e controlled by an administrator. I do however own my Laptop.



So now I can take pictures in Free Flight but still unable to sync the video.


So, just to be clear, you can take stills in freeflight but not see video? Just verifying we are not dealing with am ARC issue anymore. We'll still see what we can do for suggestions, but you might have better results at one if the drone specific forums since there are just a handful of AR Drone users here.




Yes that is correct, but the plot has thickened. Since I have been making rules for my firewall I was able to FLY the drone in FF. If I remove all of the exceptions I cannot connect to the drone in Free Flight but I can connect to the Movement Panel in EZ Build with full control.

Also, by adding the rules I can take stills in better resolution with EZ-B and view them in FF.

The issue I believe is the, the :5555 is not a true endpoint just a default error message. I am not sure how to properly notate IP Addresses(ranges) to be recognized by windows.

I understand this is support for this particular software and I really appreciate the help you have been providing. To be blunt, most drone support forums I have found are more concerned with simplistic issues like setting up a repeater or connecting a joystick but my intention is to further my education and experience with drones and robotics.

Thanks again and if you want to fold from this issue I completely understand it is not a software issue and appreciate your help!



So the AR Drone (unless you flash a custom firmware and then SSH to it and change its I settings) will always just be address

the :5555 is the port, (UDP I believe) that the video streams back to the computer on.

Here are the standard ports for the AR Drone:

Port 5556- UDP packets with regular commands; Port 5554- Reply UDP data packets from AR.Drone; Port 5555- Reply video stream packets from AR.Drone; Port 5559- TCP packets for critical data that cannot be lost usually for configuration

So opening those ports or all traffic to and from in your firewall should resolve it.

Here is a site with some other useful information (that I copied the port list from):