Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

All Servos On My Jd Are Locked And Unresponsive

I have a very irritating problem. All servos on my JD are locked and unresponsive. The EZ Builder software doesn't show anything wrong, but when I run the script that I want played out, only the LED's in JD's head function properly. This isn't a coding issue; the script ran exactly the way I wanted last time I used it, as it has worked unchanged since February. Something is up with the servos. Even when the servos are in random positions and the initialize script is run, they don't rotate to their 90 degree positions as they are supposed too...NONE of them. All are properly plugged in and were totally functional a week ago. Nothing has changed since then. There is no buzzing at all, or any abnormal warmth coming from any servo. The battery warning is turned on and has not activated the charging message yet. However, the robot was charged overnight a few weeks ago, and once in December both with charging periods of over 14 hours. I believe this may be the cause of the issue, but not quite sure. This happened 2 weeks ago as well, but after being powered off for 5-6 days, it resumed normal functionality. Now it is doing it again and I would like to find a permanent solution to the issue.

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
Forgive any steps that you have already taken :)... Please answer the bullet points in my response

1) verify that you are connected to the robot. There is a connection procedure in the learn section for your robot. When connection occurs, a beep will be heard from be ezb.

- can you confirm that you hear a beep when the connect button is pressed in ARC?

2) verify the wires connected to jd are plugged in the correct direction. Black wire connects to black, etc.. There is a tutorial on how to connect the wires in the learn section for your robot as reference if needed.

3) ensure you are using the latest ARC software. There have been no status or diagnostic updates from your software, so I'm unable to determine the version

4) if the speaker is repeating "my battery is low", the battery saver will disable the servos until it is charged

- can you confirm the ezb startups up with correct audio chime?

- does the camera display video when it is connected?
#2  
Well, the ezb does make the correct sound when connected, and the camera and LED's in the head work perfectly, only the servos are unresponsive. The wires are connected in the same way they have been connected since I first assembled the robot, and everything has worked before now. No connections have been changed in the last 7 months. Upon connecting with the computer, JD is supposed to move all servos to 90 degrees, right? Right now, they remain in the same position. The arms don't go out straight from the shoulders, the head doesn't center itself on the neck joint, and the legs do not straighten after connection has occurred (beep included). Speech recognition and synthesis both work normally, as well as the camera, only issue is with all servos. The battery warning is turned on, and has been turned on a functional since first use. No message has been played regarding the battery since the problem began. Again, the speech synthesis works fine, so the speaker is definitely functional.
PRO
Synthiam
#3  
when you flick the power on and off, do the servos jerk a little?
PRO
Synthiam
#5  
When is the last time that you updated ARC? We do not have any diagnostic information from your ARC sessions. Visit the Software section of this website and update to the lastest ARC please.
PRO
Canada
#6  
@Tim.Bloomfield when you connect to JD does a little red LED in the upper left corner of the ez-bv4 light up and stay on? I'm just wondering if this issue could be I2C related.
#8  
DJ Sures, I am trying to get the software updated, but the computer I use is a school computer so I can't just download stuff for anything. I need to wait for the division computer tech guys to come and install it for me. It's the end of the year too, so they're really busy. I am not sure if they will get to it before summer.:( *tired*
PRO
Synthiam
#9  
Awe Tim, that's rough! We hear that a lot this last few weeks with end of year hectic schedules. Maybe they'll let you bring it home:) the robot, that is.

Also, are you near Calgary? Who's your reseller for the school? They will be able to provide support or assistance.
#10  
Tim, that sounds pretty frustrating, mostly because it sounds like your hands are tied when it comes to updating the software. Perhaps you could ask for temporary local admin rights on your computer to update the software on your own? The school IT might deny it, but it usually never hurts to ask. If I was there and you were a trusted student and it expedited the implementation of software used for educational advancement I would grant it.

Is JD connecting to the computers WiFi locally or was it configured for wireless access to a router?

When you click connect in ARC does it say connect and can you get the view from JD's camera?

If I were trouble shooting it myself, beyond upgrading the software I would be tempted to unplug all of the servos, then plug them in one at a time to see if I could get them to move via manual servo controls just to make sure every thing works one at a time.