Asked — Edited
Resolved Resolved by thetechguru!

Roli Is Still Not Moving

I have taken Roli apart and took the steps for the wiring. I have connected everything together, multiple times. The fuse is fine as well. Roli's hands and head will move but Roli will not move the wheels at all. I am unsure of what to do at this point. I have taken all the steps that are requested to do within the question of why Roli isn't moving.

Also in the box that we received, we did not get 3 rotation servos, we got 2 rotation sevros and an extra lever servo.

Skip to comments


Upgrade to ARC Pro

Don't limit your robot's potential – subscribe to ARC Pro and transform it into a dynamic, intelligent machine.


Your profile shows you have not taken any of the tutorials. There are detailed tutorials about checking the H-Bridge connections and button. (specifically this one: but you should take the whole Roli lesson). If you took the lessons and didn't mark them complete, you should so you don't get pestered to take the tutorials every time you ask a question.

Anyway, assuming you did take the lesson or have seen other discussions or troubleshooting tutorials (as your question implies) one more thing to try is to turn the little button that the lesson I linked says should be down back to up and try again. I have heard of at least 2 cases where the H-bridge was slightly different than the standard and the button needed to be up instead of down to work (these were not H-bridges inside Roli, but same or similar model).

For the Servos, file a warranty claim at the Contact Us link. Reference this thread in your claim. If the H-bridge doesn't work and you have followed all of the troubleshooting steps, include that in your claim as well. If it was mis-wired, it could have burned out. They are fairly easy to cook if wired incorrectly.



It looks like having it up instead of down worked. Thank you for the help.