Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Australia
Asked — Edited

Parts Not Working

Hello DJ,

I recently bought a EZ-ROBOT Developer Kit and I have sadly had some setbacks. As you may be aware, the Developer kit does not come with a power adaptor to plug into a power socket or a lithium battery. So I went out and purchased some AA NiMH batteries. I then put them in the battery holder as instructed in one of your videos. It did not work. I then tested the battery holder with my multi-meter and found that there was no power coming through either of the cables. I then tested each individual terminal and found there was a faulty one in the series.

I have also sadly had a issue with the ultrasonic sensor. The first time I plugged it in, it worked well, however, on the meter in ARC it said there was an object right in front of it, but there actually wasn't. Then I noticed there was something in the ultrasonic sensor behind the screen. I don't know what it is but I know it does not belong there. I know this as I also use Arduino.

The next day, I wanted to see if it was just a temporary issue, I plugged the ultrasonic in, and then I started to smell plastic burning the safety circuit connected to the power cables had got really hot! - I immediately removed the power. I am a bit disappointed to have these issues as your robots are awesome!:(

Images of the Ultrasonic sensor and safety circuit below

Any help is appreciated (so I can continue building my robot :))

Joshua

User-inserted image




User-inserted image

Australia
#2  
Hello NEWAGETOMY,

Thanks for your reply. That is a good idea, though I was hoping it would work without me having to buy more equipment. It should have worked. Is there any other alternative that you would know of by any chance. Perhaps could I get it replaced?

Thanks,

Joshua
Australia
#3  
No worries.

Were the cables damaged at all, or was anything covering the terminals inside for shipping?

Do you have a 7.4v lipo laying around by any chance?
Australia
#4  
Sadly I don't have a LiPo battery. The cables weren't damaged though one of the terminals were damaged according to my multi-meter. So I hope EZ-ROBOT will replace it.
Australia
#5  
Hi NEWAGETOMY,

Do you have any ideas on how to fix the ultrasonic sensor?

Joshua
Australia
#7  
Are you close to a Jaycar? They have the sensors you need. : )

I never knew they had them until just now.
Australia
#8  
I am close to Jaycar, though if you are talking about an ultrasonic sensor I have one. As I stated earlier I also use Arduino and many other platforms.
Australia
#9  
Thanks for the idea. Though it looks like I am going to have to buy some sort of battery from EZ-ROBOT. Unless something else pops up. :(
Australia
#10  
Yep the ones from Jaycar are Arduino sensors.
Australia
#11  
Personally i would get a jack with a plug so you can at least dis-connect one lipo, charge it and throw another one on.
Australia
#12  
Actually, that might work for power, however do you know of any way I can ask EZ-Robot about getting the broken parts replaced?

Joshua :)
Australia
#13  
Yeah of course, i would email them, trust me they will help you straight away.
Australia
#14  
Do you know hat their email is?
Australia
#15  
Oh also, is there any battery besides the EZ-robot battery that will fit in their robot bodies?
Australia
#18  
Your welcome, hope you get it up and running soon.