Welcome to Synthiam!

The easiest way to program the most powerful robots. Use technologies by leading industry experts. ARC is a free-to-use robot programming software that makes servo automation, computer vision, autonomous navigation, and artificial intelligence easy.

Get Started
Asked — Edited
Resolved Resolved by thetechguru!

Connecting To Two V4 Ezb's

First question and problem: I think the intent is to be able to connect up to 5 EZB's through EZ Builder. However I've hit a wall trying to connect EZ Builder to two V4 EZB's when they are in AP (Access Point) mode. Using my laptop I've followed directions and connected EZ Builder to the first V4 after establishing a wireless connection through the "Wireless Network Connection" icon on my Win 7 Taskbar. Then when I try to connect wirelessly to the second V4 EZB I lose the wireless connection to the first. My laptop will only let me have more then one wireless connection at a time. What am I missing here?

Second question and problem: With both V4's in Client mode and the Green light blinking (the voice says she's attached to my network), I can only have one EZB powered up at a time and have a successful search of my router for a IP address. If both are powered up and attached to the network EZ Builder cant find an address. Is this normal? I've watched the tutorial several times.

Third Problem: For two nights now after the laptop and robot are powered down the second EZB entry in EZ Builder will not connect to the second EZB board. I have to push the network reset button on EZB and redo the IP search in client mode.


ARC Pro

Upgrade to ARC Pro

ARC Early Access will give you immediate updates and new features needed to unleash your robot's potential!

#1  
I can only help with the first question. At least one of the ez-b's must be in client mode. You can use the AP on one as the master for both your computer and the secind ez-b, or you can connect both ez-b's as clients to your network and your computer to the same network. To connect to two ez-b's in ap mode, you would need two wireless cards in your computer, and even that can get tricky.

Alan
United Kingdom
#2  
I can't check this but I believe the second EZ-B can connect to the first EZ-B's network much like your PC does.

First set up the first EZ-B for AP mode (default) and set any passwords, change the SSID etc.

Next connect to the second EZ-B, log in to the config through your web browser and set it to connect in client mode to the first EZ-B's SSID.

Now connect the PC to the first EZ-B's WiFi
In ARC, the first EZ-B should always be 192.168.1.1:23
The second EZ-B could be anything in the 192.168.1.x range, scan for it and it should come up.

Sorry it's a bit brief, just writing this before heading off to work.
#3  
thanks rich. I remember now reading this somewhere. I'll give it a try to see if I can get it to work.

However my preferred method of connection at this time is to have both connected in client mode to my home network
Connected like this I have noticed some lag in response. Most noticeable in sending sound files to the EZB speaker. At times several seconds will pass before EZB will respond. Most times response time is right away. I wonder if its due to heavy traffic of other devices on my home network?

Also an update; I had both V4 ezb's Connected to ARC in client mode and for the third day now after everything sitting powered off overnight (except the network) I can't connect the second EZB to ARC. Any ideas on this. Seems to be a pattern. BTW, I did power cycle the ezb's after setup to client mode.
United Kingdom
#4  
I've had no lag issues with my EZ-B, I was genuinely shocked at how responsive it is, as can probably be heard in my unboxing/first look videos. That said, I do have very strong, fast WiFi signal and few other WiFi devices connected to it. Network traffic or even lower signal strength may affect it. My router tells me the connection speeds and quality however it does run DD-WRT firmware (IMO the best firmware for a router), your router may not show that information.

The first issue that comes to mind is a problem with the IP addresses or the DHCP service. I have my router specify fixed IP addresses based on the MAC address of the NIC connecting, I need this for my home network to function correctly. Again, this may not be available in your router.

The other thing to check is any MAC filters you have on. Is it possible you added the one EZ-B to the MAC filter enable list but forgot the second or mistyped the second?

Provided your SSID and network key are entered correctly (and remember, they are case sensitive) and the MAC filters are off or set correctly then I can't see any other reason for it other than an issue with the DHCP of your router.

If the first EZ-B is not connected does the second one connect?

Have you tried rebooting your router?

Some routers will give you hell. I know if I go to my brothers house and log on to his WiFi with my phone and tablet my phone will connect fine but my tablet is given the IP of 169.x.x.x which isn't what it should be. My sister in law's laptop often boots up and gets given a 169.x.x.x IP too. This is due to the router they have. Sometimes it'll let you on but others it wont.

If you let me know the make/model of your router I may be able to find some info on what services are available on it and guide you through setting up some MAC based static IPs.
#5  
I'm sure it's something with my router or other devices on the network. I had considdered setting up a Static IP address for each EZB but not sure how to do it or even if my router will do it. I looked in it's setup web page but only thing I could find was a way to sit my the main IP Supplier's address as a static number (I think). I know just enough about all this stuff to make myself dangerous. *eek* Thanks for the offer of guideance.

I'll ahve to wait till later to get the router make and model.

I do know this; the only way I could get ARC to find a number to assign to EZB #2 when doing an IP serch was to power down the first EZB. #1 EZB had already been installed and connected in Cliant mode. Only then with EZB #1 powered down would ARC find a number and I could connect both units. I would then power cycle as advised. Then after being powered off for many hours EZB #2 can not connect. I did try a short powerdown of an hour or so and I did have success with both units connection. BYW, both EZB's would have the green light flashing and the voice would tell me that she was connected to my network uopn powerup.
United Kingdom
#6  
I have a suspicion that the voice may tell you that if your router assigns the 169.x.x.x IP address as, in theory it's connected to a network.

The normal way to assign static IP addresses is on the PC in the network options however you don't have this option with the V4. Some routers can, as previously mentioned assign IPs based on MAC address but some can't. My current router is the first and only router I've owned which can.

Another option may be (however I am unsure) to use an Access Point. I haven't used one for close to 10 years now but I am pretty sure they can be set up to use their own DHCP service and assign IPs to devices connected to them rather than the router itself. I am sure the one I used would assign an IP and it would be in the correct range (i.e. router IP of 192.168.1.1, Access Point IP 192.168.1.100, WiFi devices connected to the Access Point assigned 192.168.1.150-192.168.1.169). If nothing else works I'll see what info I can dig up on Access Points however their popularity has probably shot down now all routers have WiFi capabilities (I used mine as my router didn't).
#7  
The AP methoid you discrib sounds like it may add a layer of comlpaction I would rather avoid if possable.
#8  
Now that I am thinking about it I do remember seeing a EZB in the filter section of the router. I didnt put it there that I can remeber an useing the old V3 and bluetooth I dont think I did it in the past. I'll have to take a look at that when I get home.
PRO
Synthiam
#9  
The answers you are looking for...

1) Like all wireless devices, having them too close will cause radio interference. The EZ-B's should not be within a foot or so from each other. It's not a distance that I can just tell you. It's a variable distance that depends lots of stuff... it even depends on humidity and temperature believe it or not, which is the source of all radio and static interference. The main reason of course is the electrical radio hardware in the EZ-B.

2) When you are at home, connecting multiple EZ-Bs to your network is the way to go. If you are experiencing performance issues, that is to be expected with low signal strength. If your EZ-B is inside a metal robot, the signal strength will be much less than what your laptop reports. Keep in mind that your EZ-B is a Wi-Fi device and will therefore suffer from Wi-Fi related requirements.

Keep in mind that the EZ-B uses all available bandwidth. It is bandwidth hungry! There are millions of things happening per second to make it as awesome as it is - specifically with the camera and audio. The communication/audio protocol uses 3.3 mbps and the camera video also uses an additional 3.3 mbps... Yeah, she's bandwidth hungry! But hey, it's 2014 right? We're pushing the limits of technology to make 2015 a year full of EZ-Robots

3) If you are out at a show - the best way to connect multiple EZ-B's is by putting your laptop in Access Point Mode. That is quite a simple process and it can be turned on and off - so it doesn't require a lot of configuration before heading to a conference or walking your robot down the street. Google will be your friend on how to setup your OS as a Wi-Fi access point:)
#10  
OK, Thanks for the good info. I've made some changes to filters in my router firewall. We'll see what happens tomorrow. If I cant connect to EZB #2 I'll turn the laptop into an access point and try it like that.
#11  
Woke up this morning and tried to connect both ezb's to ARC. No go. Don't really understand what is happing here. I can shut everything down and reboot within an hour and I can connect EZB #2. If things are off hours and hours it won't connect. I'll try tonight after being powered off all day but this time leave EZB #1 powered off. That way I can rule out interference between each board. They are mounted in my robot about 2 feet apart and open to the air. Maybe the next step will be removing it from the robot and well away from everything and closer to the router. I have my doubts though, the router clearly sees it. EZB says she's connected to my network, ARC finds it and lists it but won't connect to this second board after starting powered down for hours
PRO
Synthiam
#12  
That's really strange Dave. Are you able to find both ezb's with the scan tool when they're connected to the router?
#13  
@DJ, I can find both EZB's but not if both are turned on and connected to the network (at least the voice tells me they are connected). I have to power down one while the other uses the scan tool and then do the same with the other unit.

This afternoon I tried to leave EZB #1 powered down while starting up ARC and I can then connect to EZB #2 just fine. However then I cant connect to #1. I have to go through the whole setup and scan procedure on each EZB to get them to connect to ARC at the same time again.

I'm about out of options. I guess my next step is to move the EZB's farther away from each other to see if they will connect that way at the same time. Maybe they are interfering with each other's Wifi.They are about two feet apart now and mounted in the robot.
#14  
This is just a wild guess but it could be possible that the ez-bs have the same name and are causeing interference. If possible change the names.
#15  
Dave, I'm able to establish two EZB4s into one instance of EZ-B. The two units are sitting on a coffee table and are about 2 feet apart. I just added two ADC controls (one for each controller) The connection appears stable for both units.


User-inserted image
#16  
Hi @Dave

I have also verified success in connecting 2 EZ-Bv4s in client mode to one instance of ARC. At first I did have a bit of trouble when the EZ-Bs were a few inches from each other but once I spread them out to a bit farther than a foot apart they worked quite well.

Once your EZ-Bs are both in client mode and are successfully connected to the same network (green LED is flashing on both) it should be smooth sailing. Using the scanning tool it should pick up both EZ-Bs in one scan if you let it go through the entire range. Each EZ-B should beep once it's IP has been scanned.

You shouldn't need to go through the network setup process again as the EZ-Bs will save your network settings. What you can do is close the scanning tool and open it back up again if you don't have success the first time. I would also try to mount the EZ-Bs further from large pieces of metal on your robot as there could be signal interference, as large chunks of metal are known to pick up radio waves (well that's why we use metal for antennas in the first place:) ).

Another item I would check are the IP addresses that your router is assigning for the EZ-Bs. Are they the same every time you connect them or are they hoping around every time you scan? Do you have any other devices at home that have to reconnect to your network on a regular basis?
#17  
Thanks for the help. I actually have done all this and verified all the above several times. I can get both units found with scans and up and running nicely in ARC. However the only thing is after power down of laptop and both EZB's for several hours I can not connect to the second EZB if the first is powered up. If the first EZB is powered down I "can" connect to the second unit.

It seems like my problem centers around having both EZB's powered at the same time I want to connect to each. I see this problem with the scan also; I cant get a successful scan on the second unit if the other is powered up.

There is a lot of metal in my robot but both are about a foot apart and open to the air like sitting on shelf's. I don't have a pic of the V4's mounted but here are a couple shoots of the old V3 mounted. I have the V4's in the same place:

In this pic the EZB is on the very top shelf and you can see the second EZB sitting down in the leg section on the white plastic shelf:

User-inserted image


Here's a close up of the top mounted EZB (V3):

User-inserted image


Here the location of the bottom mounted location You can see the EZB (V3) mounted on the right:

User-inserted image
#18  
I would suggest configuring your router to always assign the same IP addresses to each ez-b (often called static dhcp. If you can't figure it out, post the make and model of the router and I'll look it up and give you instructions). That should eliminate thank the need to search for the EZ-Bs each time you power up. Just configure the connections to each IP and connect when you start up.

Alan
#19  
Thanks @Dave for doing those checks and providing photos they were quite helpful.

What I would do next is to see whether it is a router issue or the EZ-Bs interfering with each other.
I would start by removing the EZ-B from the top of your robot and power it on your bench a ways a way and do the same tests you were doing before.

Obviously, if there are still issues I would look into your router and it's settings, if not it is likely an interference issue and I would look into mounting the EZ-Bs a bit differently inside your robot.

I can't really tell by the photo but is the top EZ-B (I'm guessing that is EZ-B #1) mounted on top of a solid steel plate?

P.S. Thanks Alan for your offer to help!
United Kingdom
#20  
I've always suspected it's a router issue. More than likely it's some kind of IP clash. If only routers were simple to configure...

As Alan suggested (and as I mentioned previously) if you can post your router make/model we can try and guide you through the process of fixing those IPs.
#21  
Thanks for hanging in there with me on this.

The top EZB (#1) is mounted on 3/8" acrylic plastic and that's setting on 1'4" aluminum plate. Each shelf is made the same way and it's all tied together by threaded rod.

I pulled the bottom EZB in the leg section out this evening and set it on a table sitting next to the robot. This placed the two units about 3' apart. I powered up and could not connect. I then move it to the next room and this time I got both EZB's to connect to ARC.

My router in on the main floor and the robot is in the basement. When I moved the EZB and got it to connect it was actually right under the router one floor above. Could It be that a better signal is what caused it to work this time? I guess I'm hoping it not interference with each other because I'm not sure how I could get around this problem if it is. :(

I have a Belkin N wireless router Model F5D8236-4 V3. But I did get both to connect when #2 was in the other room and closer to the router. Here's the manual:

www.belkin.com/support/dl/man_f5d8236-4_pm01122_7-08.pdf

Thanks again!
#22  
Swamped at work today, but I'll take a look tonight at giving simple directions to assign static IPs via MAC address.

Alan
#23  
Thanks! I've been looking around myself for this and couldn't find a good answer. Maybe you can dig it up. :)
#24  
I was able to take a quick look. Your router doesn't support "static DHCP". However, you can make the DHCP leases last forever, so once an EZ-B gets an address, it should always get the same one again.

In your router's web interface, select LAn Setup: Lan Settings.

Set the "Lease Time" to "forever"

When you click Apply Changes, your router will probably reboot.

Start both EZ-B's, and after they say "connected to network" log back into your router, and click on Lan Settings | DHCP Client List

You should see both EZ-Bs listed in the list with different host names, but they should start EZ-B. Write down the IP addresses.

In ARC, In the connection dialog, enter the IP address of one of the EZ-B's followed by :23 in slot 0. Enter the IP address of the other EZ-B followed by :23 in slot 1.

Hit connect on both slots, and both EZ-B's should be visible.

When I get my EZ-B's I'll be able to determine if there are additional troubleshooting capabilities (like will they respond to a ping...), but that is going to probably be in July.

Alan
#25  
Thanks for going through all the trouble Alan. Sadly though I already had the Never Forget function enabled and had confirmed that both EZB's have been in the DHCP Client List all along. However they both appear as "Unknown" but I can ID them by their Subnet addresses. Mainly because I saw them appear in the list and know what the other devices on the list are.

In ARC I can not manually enter the numbers. I have to run a scan from each EZB slot and click on the address it gives me. The odd thing is that they both show in the list and each tells me they are connected to my network with the green light flashing. The "ONLY" times I was able to get both to connect was after I'd reset them and rescan for them with EZB of when I moved the one to another room.
United Kingdom
#26  
To manually enter the IP in the connection box;

1. Click on the box with the IP address in, a blue backgrounded dropdown should appear
2. Click in the same place you first clicked (i.e. don't select something from the dropdown)
3. The IP address in the connection box should become highlighted in blue
4. Type the IP you require.


User-inserted image


User-inserted image


User-inserted image
#28  
It sounds to me like it is a signal strength issue. You could put a wireless repeater in the basement right below the router. Wireless signals like going through interior walls much more than floors. These signals travel in a straight line. Going straight through a floor is much easier for these signals than going at drastic angle through a floor. If you take into account the thickness of the floor you are going though when going at a 90 degree angle, instead of say a 45 degree angle, you will see that the signal it far more obstructed when taking the 45 degree angle. Also, then adding in any interior walls, the signal can be very obstructed. Along with this, there may be other things in the way like hvac plumbing or water pipes. This too will limit the available signal.

The way to solve this is either to place a second wired wap (wireless access point) in the basement or use a wireless repeater placed in the optimum location to limit the amount of material between the wireless router and the new wireless repeater. The repeater will then be able to provide adequate wireless signal to the basement because the angles that the signal will be going through the walls will be much closer to 90 degrees.

I will keep monitoring this thread incase you have any questions about this post.

A question I have is how strong is your wireless signal on a smart phone or other device when in different locations in you're basement? If the ez-b is as bandwidth hungry as DJ described, you will need pretty strong signal to get things to work right.
#29  
@d.cochran, That's awesome info. Thanks so much for sharing your knowledge. ;) One of my plans is to move the router closer to the robot. B9 being a few hundred pounds make it hard to move the robot closer to the router. Whats that old biblical saying?; If Mohammed cant go to the mountain, bring the mountain to Mohammed?

Anyways, I've got a busy non-robot weekend coming up (Damm- it) so I'll have little time for the big guy and wrestling with this problem. But I'm sure I'll squeeze some in. I'll update with my progress as I move through this. :)
#30  
Fearing that the units are interfering with each other and thinking about what Jermie asked about the metal shelf the top EZB is mounted on I thought I'd post a pic of the center support system. As you can see it's made of aluminum plats topped by thick polycarbonate and held together by threaded rods.

So what do you all think? Could this be acting as a big antenna and overpowering the lower EZB?



User-inserted image
#31  
anything that is metal and the correct length could act as an antenna. More likely though, it could be acting as a shield, blocking some of the signal. Here is an idea. You could place a wifi repeater in the robot and have an external antenna. This would depend on the type of signal you could get in the location of the robot.

Here is a test you could do.
1. Take a smartphone and connect to your wifi.
2. Note the signal level you are getting on the smartphone.
3. Place the smartphone on the robot in the location that you are going to place the ez-b.
4. Note the signal level you are getting on the smartphone.

Did the signal drop? if so, the structure is blocking the wifi signal. The way around this is to use an external antenna to get the radio to pickup wifi outside of the structure.
#32  
Excellent ideas @d.cochran

@Dave I forgot to ask you to try something, you could place a plastic spacer between the EZ-Bs and the shelf that they are mounted on in order to get them more in the air and further away from the aluminum plates.
#33  
@Jeremie, there is already a 1/2 inch of polycarbonate plastic and 1/4 inch acrylic between the EZB and aluminum plate. That's a lot of plastic. However I do have screws run down into the plate a all over the place holding all the other equipment down. I guess I could pull that EZB off the robot to see if it makes a difference.

@d.cochran, I found a little time this evening to grab mine and my wife's cell phone and do the test you mentioned. I walked around the robot in a 5 foot radius with them and even stuck them inside the shelfs where I have the EZB's mounted. With my phone my varied in signal strength from good to fair and even dropped out a few times and I had to reconnect to the network. With my wife's phone I had good to excellent signal strength. Go figure. I have one of the newer motorola electrify's and my wife has one of the newer Samsung Galaxy's.

I guess my next step is to get the router closer to B9.
#34  
@Dave I'm not really concerned with the amount of plastic but rather the EZ-B's position in relation to the metal plates inside your robot. I was just thinking if you could position the lower EZ-B somewhere half way between the two metal plates and the upper EZ-B further off the top plate you may be able to get better signal strength getting to the EZ-Bs.

I do like the WiFi repeater idea though, those are getting popular these days.
PRO
Synthiam
#35  
Here's a video for connecting two EZ-B's to my Wi-Fi network via Client Mode. Dave, you might need to upgrade your router... Or, you can easily mount a cheap router in the robot:) They usually run on only 5 volts.

#37  
@DJ, thanks so much for taking time out of your very busy day to do this video. I'm touched that you care about helping.I'll certainly keep that open as an option. I never once thought that this is the fault of the V4 or a design flaw. Seeing your two EZB's sitting so close and connecting is confirmation that the problem is in my setup. Now the question is; Is the failure to connect to the second EZB the fault of all the aluminum I've built my robot out of or my geriatric router. ;)

@Jeremie, OK, I understand now where your coming from. I'll raise the First EZB or move it completely away from the robot to see the effect. I should have some extra time now over the next few days to play and test.

I just want to say I'm not in the least bummed or angry. Like I said above I know it's got something to do with my set up. I just need to find the right way to either work this new technology into my robot so it works or get the proper equipment that will let it work. I'm actually enjoying this trailblazing. Being one of the first to get a V4 EZB I figure every bump I hit now will that I can work out will help someone down the road that cones upon the same issue. :)

Happy building!
PRO
Synthiam
#38  
I really feel the best option is to get a cheap "newer" router and mount it in the robot. That way, your EZ-B's will connect to it and your laptop/phone/etc... It will be a little portable hotspot with Wi-Fi security

I bought a dlink router for my home a few weeks ago for $34 and it runs on 5 volts DC
South Africa
#39  
You can elevate your router and see if it is getting better signal from the router to your robot
#40  
OK, I made a few changes this evening:

I moved the wireless router into the basement and within 10 feet of B9 with only one wall between them.

I removed the top EZB from the top shelf of the robot and elevated it about 4" above the shelf. The lower EZB is sitting about 3 feet away from the robot.

I reset both EZB's and then reset them into client mode and power cycled. After the power cycle each reported it was "connected to my network". I then made sure each's "Connect/Disconnect" button showed "Connect"

Next I did a Scan on Board "0". This is the first time I was able to get both IP addresses appear in a scan without having one of the boards powered down. This is a huge deal! When I did a scan to assign board "1" the same two IP addresses popped up and I was able to assign the 2nd board. This Is great progress!

I've powered down everything for the night and I'll see if it holds overnight. In the past I've been able to get both boards connected but only by having one powered at a time. The next morning I always couldn't connect to a second board.

Now I still don't know if it's an interference problem because of having the top EZB mounted near the aluminum plate or a signal strength issue. If all is still OK tomorrow I'll start reversing my changes to see when things go wrong.
#41  
Update: 3 hours later after making the changes in the above post (things were working nicely before power down), Midnight;

I powered up the laptop and robot. Both EZB's reported "Connected to your network". Green light was blinking on both.

I started up ARC and clicked the connect button on board "0" - Connected right away.

Clicked the connect button on board "1" - Did not connect in ARC. *tired*

I guess I could get another "newer" router but the one I have is a "N" class and should be doing the job at 10 feet away. *confused*

Really not sure what my next step should be. *tired*
#42  
Hmmm, question for you @Dave if you now do a scan on board "1" does it appear as a different IP on the network?

Otherwise, If you reboot board "1" one more time does it connect to ARC again?
#43  
Thanks for offering you help so early on a Tuesday morning.

To answer your questions;

No the board not connection and can not be found in a scan (both units powered up but not connected to ARC).

No after a reboot (pushing the reset button and reconfiguring in Client Mode) I still cant find it with a scan.

I also tried to reboot the router with no results.

BTW, Before I rebooted the router and when I first powered up the laptop just now I could not connect to my router with the laptop. It reported that there was another computer on the network with the same IP address. This happened a couple times before also. Why would this happen?

It's getting late so I'll stop for the night and get some sleep.
#44  
Sorry @Dave I should have specified that by reboot I meant just powering the board down and applying power again.

From what you are saying it seems that your router likes to consistently re-assign IPs that it has given out already. I'm not sure why this would happen unless the settings are configured to not remember IPs for certain devices on the network. It may be time to borrow a friends router to do a few quick tests.

Have a great sleep!
#45  
The router's dhcp server has a dhcp lease time. It will try to assign the same IP for a specific amount of time. Most wireless routers (DHCP Servers) do this and usually you can tell the router to drop the lease on an IP.

I think the best option would be to get the wireless repeater (often called extenders also) and put it in the robot. I would get one with a detachable antenna and put the antenna on the outside of the robot or against the plastic skin on the inside of the robot. I would also put this on the same shelf as the ez-b's are going to be on.

This would be really cool because, as the robot moved around the house, you would have a mobile extender that would also extend the wireless signal to other devices close to the robot. This would include any table or phone that you might be using to help control the robot.
#46  
oops, I read earlier message, and realized that the router is assigning the same IP to multiple devices. I would pretty much do this.

Turn off the computers. Reboot the router. Wait for the router to come back up and then turn on the computers one at a time, waiting for each to connect to the network before turning on the next.

Here is what I did. The router for the wired network doesn't have wifi turned on. The antenna's normally aren't very good on those anyway. I then run an Engenius wifi access point off of the router. The engenius eap350 are the ones I have. They sell a lot of other ones also that are very good. I have 2 of these in a 2600 sqft house single floor house and the signal is 100% to my fence line of the property. I have also used these in schools. 1 of these is strong enough to cover a basketball court and 20 rows of bleachers without a problem at all.

For you, because of the thick metal in the robot, I would put the wireless extender in the robot.
PRO
Synthiam
#47  
Dave, when your EZ-B v4's are in Access Point Mode (i.e. the default AP mode after pressing the Reset button), what are the Wi-Fi names?

For example, are they EZ-B v4 3F or something...

Thanks!
#48  
@DJ, When in Access Point Mode the WiFI names are EZ-B V4 4a and EZ-B V4 04.

@d.cochran, Yours sound like good suggestions. I went ahead and ordered a engenius eap350 repeater incase this turns out to be the issue. It should arrive tomorrow. I can mount it inside the torso very easily. It's great that it runs on 12vdc as I have lots of that I can tap into in there. Here's a link to this item to look at:

www.tigerdirect.com/applications/SearchTools/item-details.asp?EdpNo=1759086&CatId=372

I've also bought a new router and should be here Thursday. I decided to get one of the better N class routers that got good reviews on PC World's web site. It's a ASUS RT-AC66U Dual-Band Wireless-AC1750 Gigabit Router. Here's a link to it to look at:

www.amazon.com/dp/B008ABOJKS/ref=pe_385040_30332190_TE_M3T1_ST1_dp_1

Between these two items I should have my signal and router issues covered. Heck, I'll be able to log onto my internet from a mile away from my house.:D This is getting kinda experience. I may be better off just finding a way to run everything off one EZB. However I really hate the idea of running wires between levels of the robot that will be bobbing, twisting and bending. :(
PRO
Synthiam
#49  
Wow. you got the 4th EZ-B ever made
#50  
You'll like that Asus router Dave, I've got two of the Asus N56 routers and they are rock solid.
#51  
Just for grins last night I added my 3rd v4 EZB to the mix last night. I thought I'd see if I would have any trouble connecting ARC to a new unit after power down, waiting overnight and power up in the morning.

I also moved my project onto a new laptop (through the EZ Cloud. I love that thing!) making sure I had the latest ARC installed. I then sat down close to the router.

First thing I noticed was the scan for IP addresses was super fast now. Before when I was in the basement and the router was on the main floor the scan would lag. I got all three units to show up in scans and connected to ARC. All three were working nicely and responding. The newly installed EZB was Board 2 (third board down) on the connection list. I then powered down for the night and got some sleep.

With much curiosity I powered everything up this morning. All three EZB v4's cheerfully reported that they had successfully connected to my network. I then started up the laptop and started ARC.

Clicked on connect button for Board 0 - Connected!
Clicked on connect button for Board 1 - Did not connect.
Clicked on connect button for Board 2 - Did not connect.

I rescanned for each EZB and the only that would show up in a scan was the one (Board 0) that would connect. I looked at the client list in my router and the other two are listed there. So odd.

Well, this at least tells me I should have no problems with the EZB's themselves.

With a little luck the repeater should arrive today and the new router tomorrow. Step by step. ;)
#52  
Well, it's been another frustrating evening. I got my Engenius EAP350 AP/repeater in this afternoon and have been trying to set it up all evening. I set it to Repeater Mode and I'm pretty sure I have all the settings right but it just wont connect to my network. *tired*

It seems real straight forward but I had never set something like this up so I read all of the manual, did a ton of reading on the internet and watched a bunch of Youtube vids.

Basically I just plugged in the EAP350 to my laptop with a LAN cable to access it's web interface and after entering some settings in my network card connection window and entering it's default IP address into Firefox I was in.

I then Changed it to Repeater Mode and waited for it to reconfigure it's self.

Once that was done I changed it's static IP address to match my network's Subnet mask and a ending number that should not interfere with any other device I have on the network: 192.168.2.31 (later I changed this to "Obtain IP Automatically" but that didn't work either). I also made the Gateway IP to match my router's IP: 192.168.2.1

I then went to the Network section and did a Site Survey and picked my home network and entered in my WEP Security info making sure it all matched. I thin clicked "Accept".

After a reboot this should have started the silly thing and allowed me to connect but I could not see it in my Wireless connection list. After going back into the interface (I was able to use the default address) I found that none of the setting s held and were back to default. *mad*

I disabled all my security, firewalls and antivirus and tried this over a and over making little changes. No go. This shouldn't be this hard. *tired* It's making me feel like a dope.

I do have a question about this EAP350, I read that Repeater cut the bandwidth in half. Does that mean The EZB and everything running through it will have less room to work? If this is the case would it be better to run in AP mode? There would be a physical cable between the router and the AP and I would expect that the full bandwidth would be available. I could be wrong about all that as my mind is a little addled right now with the recent struggles.

Tomorrow the new router should arrive. Hopefully that will make a difference and I can start making progress.
#53  
OK, I think I finally have some answers as to what may be happening here.:D

First, I haven't yet been able to get the Engenius 350 to connect and work. I've given up for now. My new modem arrived today and I moved on to retiring my old one and installing this new one (mentioned in a earlier post). I did try to get the Engenius 350 to work after I got the router installed but because they both have the same IP address (192.168.1.1) I'm getting a wicked IP address conflict and I cant get into the Engenius 350's software settings. I have no idea at this point how to resolve this conflict. Any help on this would be welcomed.

This new ASUS RT-AC66U Dual-Band Wireless-AC1750 Gigabit Router is a dream. It's quick and right away I saw how responsive and easy to use it is. I also get excellent signal strength where the EZB's and laptop sit. I'm able to see the wireless clients connect and disconnect almost right away with a simple refresh of it's client list screen. Because of this I think I've solved what may be happening:

I have both EZB v4's attached to a power strip and I've been powering them on at the same time. They must connect to my network at virtually the same moment and they even speak "I have successfully connected to your network" in unison. I think the router must see these two connections as one and assigns them both to the same IP address causing a conflict. When I power them up like this I can see their two different MAC addresses assigned to the same IP address in the routers Client list. When I power them up one at a time they are assigned the to original IP addresses that they were assigned when I set them up.

I've been able to reproduce this a few times now. The real test will be keeping everything powered down for a few hours or overnight and see if I can connect to ARC with both EZB's if I power them up at different times.

If this is the case I'll need to find a way for them to be automatically powered up with a delay between them. It may be as simple as that. ;)
#54  
Good troubleshooting Dave, strange that with the speed of electrons that one EZB4 would be just a bit faster than the other and not create this IP dilemma.
#55  
Two suggestions. First, for the conflict with the extender. You can change the IP address/subnet of the router. See page 63 of the manual (download here: http://www.asus.com/Networking/RTAC66U/HelpDesk_Manual/) to see how to change the IP. I would suggest just changing the 3rd octet (ie, change it from 192.168.1.1 to 192.168.0.1)

The, since you have the MAC addresses of the EZ-B's, you can specify the IP addresses for the DHCP server to assign (this was my initial recommendation, but your old router could not do it). See page 64/65 for instructions. Note, they recommend setting to 192.168.1.xxx, but if you follow my recommendation above to avoid the conflict on the repeater's default address, then you would need to assign addresses in the 192.168.0.xxx subnet.

Alan
#56  
Thanks Alan & R-Doc for the inspiration and support.

I may have been a little off in my solution. After a few hours I restarted everything making sure I had a delay in powering up each EZB. Well, once again the second board wouldn't connect to ARC after telling me she was connected to my network. I checked the client list of the router and saw that the one that connected had the original IP address and the one that didn't connect to ARC had been reassigned to an IP address all the way to the other end of the spectrum of numbers (198). So.........

I have taken Alan's advice finally and (after changing the router's ID 92.168.1.1 to 192.168.0.1 I added the two EZB to the list of IP's that the router will always assign.

Tomorrow I'll see if this finally is the answer.
#57  
AH HA! Success. This morning was the first time ever I was able to get both EZB's to connect to ARC after being powered down over night. Looks like the changes made have worked!

I'll now be doing the final setup, clean up all wires, do a few more tests (mainly on powering up both EZB's at the same time) and reattach the EZB's to the robot. Then I'll make my final declaration and summery of what has been happening over the past week or so and how I stand now with this issue.

Thanks all for all the help and support through this. Hopefully this will help others down the line.

Dave Schulpius
#59  
Thanks @d.cochran but I've hit another bump. I changed the set up around and wanted the EZB's and the laptop running ARC to be accessing the router through the Engenius 350 that's set in Repeater Mode and down in the basement game room. Everything else in the house assesses the internet straight through the router itself on the main floor. I quickly found that the Engenius 350 in repeater mode will not pass through the Mac Addresses of the EZB's and laptop. The Router see's the same Mac Address for the Engenius 350 and for all three units. So the result is I can't use static addresses with the router and the second EZB is getting lost again and wont connect. Only one EZB will appear at a time but each keeps swapping in and out of the list.

I've read that if I set it up as a wired access point instead of a repeater the Mac addresses of the wireless clients should pass through. That's one option. The other option is to move the router back down to the game room where the robot stands and move the repeater to the main floor. That way I can access the router directly with the EZB's and control laptop and the rest of the house can use the Engenius 350 as a repeater.

Not really sure which way to go yet. *confused* I guess I'll do like I've done with everything else so far and just do something even if it's wrong. ;)
#60  
Here is how I have setup these before and they work great like this.

1. all of the EAP's are wired to the main switch
2. All of the EAP's have the same SSID

When you move from one EAP to the other, it will pick you up and start sending traffic to the other EAP.

I would set both of these up in AP mode with both broadcasting the same SSID. Just be sure that your main router and this router are on different IP addresses.
#61  
just to be clear, I would hard wire the AP to the router. Use a power injector to provide power to the AP.

I would setup the AP to have a unique IP address and then set both the AP and the router up to have the same SSID.

When signal gets low, the device will try to connect to the router with the stronger signal. It works for cell phones, tablets, laptops and everything else I have tried. I don't have an EZ-B yet thought.
#62  
Thanks @d.cochran for the elegant and clear instructions. They were a big help changing over to AP mode.

I've completed the switch from Repeater to AP mode but I did make one change from your suggestion @d.cochran. I gave the SSID of the AP a unique name. I really don't want any other device accessing it other then the robot's EZB's and the control laptop.

Now that I understand the concept of and the way to change settings in the Engenius EAP350 it was really very simple. I almost had it the first time was mucking around. However I didn't know I had to not only apply the changes I made in the page I entered them into but also in the master Change folder that list all the changes made during that session. Why programmers insist on having you save the same information twice is beyond me. ARC makes you do this also. *eek* You not only need to save changes and settings in scripts and such but also when you exit the ARC or they won't be saved. Can someone tell me why this is the case? (Sorry I had to blow off a little steam *blush* ).

Anyway, now that I have the Engenius EAP350 in AP mode I have it hard-wired to my new router and have excellent signal strength near the robot. I also have confirmed that the original device's MAC Addresses are being passed through the Engenius to the router. The static IP address previously entered for the EZB's are working now and both EZB's are now popping up in the Client list and I can connect to both in ARC. I'm also pretty sure I can now power up both EZB's at the same time and the router will recognize each separately. I'll power down over night and confirm this hopefully for the last time in the morning.

The whole secret to success here was to have a good router that can assign and keep IP addresses associated with the Device's MAC Addresses. Because of this I need to give the Kudos to Alan as he's been saying this from the beginning. Thanks man!;)

Just a footnote: I think I would have been OK with running everything in the basement just on the new router on the main floor. Before I installed the Engenius EAP3500 in the basement in AP mode I tried several times and successfully connected to both the new router and ARC with both EZB's. I even powered them both on at the same time and the new router found both as separate units and with a "Good" signal strength message. However my anal personality with the need to complicate things needed an "Excellent" signal and to have everything attached to the robot on it's own AP. ;)

If something else happens concerning this thread I'll be sure to update. In the mean time THANKS to all who held my hand through this. I hope others have or will learn from this experience. I know I have! *cool*

Happy building and have fun!

Dave
#63  
Dave,

Glad they are working for you. Also glad you have crazy good wifi in your house now. Your family will appreciate it. I know mine has even though they have become numb to the fact that they can connect to the internet from anywhere around the house.

Grats and I look forward to following your project. It is a really nice build you have going on.
#64  
I've confirmed now that I can power everything up at once now (both EZB's and the entire robot) and have both EZB's connect in ARC. Looks like everything is working as designed.

Now I can finally get to work again and see just what the V4's can do for me!

Thanks again for the help and support. :)
#65  
Glad if worked out, and thanks for the answer credit- a lot of us contributed.

I am sure we'll be referring to this thread for other users who will face similar issues.

Alan
#66  
Ya, sometimes it hard giving credit to just one person when usually so many are a part of the answer in the end. Good thing most of us are able to put our bid boy pants and realize this and not get bent out of shape when a credit is given to someone else. ;)

I really cant imagine mine will be the only issue like this. There are a lot of older routers and network equipment that I'm sure wont take kindly to the "new kid on the block" (EZB v4). Just look at Steve; he was having a similar issue and he had to go out and get a new router to get just one EZB v4 to stay connected. This is why I took the time and explored as many different aspects of my WiFi network and EZB V4 as I could. I wanted to make sure the problem was completely resolved had the right way or ways to solve this. I also learned a lot about routers, access points and repeaters. New routers...... Good! Old routers......... Bad! ; Access points..... Good! Repeaters......Bad! ; Static EZB IP's for several EZB's......... Good! DHCP............ Bad! ; Strong signal strength........... Good! Weak Signal........... Bad!:P

Another footnote; I've closed up my B9 robot and fastened all the boards down to the CSS shelf's. All is still good and so far the EZB's are connecting nicely to the network and ARC. :)

Next comes a real challenge; I want to mount a EZB v4 inside the metel brain that sits inside my acrylic bubble. *eek* Will see how my new WiFi setup punches through all this:

User-inserted image


User-inserted image


User-inserted image
#67  
Dave, Alan and others. I got my v4s about a week ago and following this thread saved me a lot of grief setting them up...
United Kingdom
#68  
Great news Dave.

Just to throw a different option in the mix (a little late but useful for anyone else refereed to this topic), you could always add a wireless NIC USB dongle to the PC running ARC and connect via AP mode. 1 dongle per EZ-B. Something like this would do the trick and is pretty cheap. You would need spare USB ports though.
#69  
I did not have to do much extra research for my issue because of this thread once I realized my router was too old. This is what I like about the forum, we're all in this together and can band together to find answers that benefit everyone. I even changed the router IP address like Alan suggested to keep any possible router/EZ-B with the same IP issues.

@Rich - I don't know about everyone else, but I already have two USB hubs on my laptop just to keep up with all the devices connected to it.
#70  
***Edit*** see new thread
Have a problem... Similar to Dave's so I thought to add to this thread instead of making a new one... Anyway... Both my EZB4 will connect to the network no problem, however ARC can only find one of them at a time... meaning I cannot have more than one ezb4s connected to ARC at any given time. The scan tool will only find one ezb... usually the first one powered on... Long story short and judging by what Dave went through I am guessing its a router issue... I have an all in one router/moden ... an SMCD3GN from SMC.... I rent it from my local cable company by the way... So my question is should I turf it and just use a modem from them and then buy my own router?... Also need to mention that I barely get 30ft from the router when I start to get disconnect problems so range sucks...

Thanks
Richard
#71  
That's what I did Richard R. But I went one step further. I purchased my own cable modem from Amazon.com and then got the Asus WiFi router (RT-N56U). Make sure your cable company will let you use your own cable modem. I use SuddenLink and they recommend what modem to use and then let you either rent or purchase elsewhere.
#72  
Thanks Doc... Calling my Cable company now.... And respond to my new thread so I can give you the credit...
#73  
I personally like a separate access point on my network and let the cable modem just be a cable modem. I have used Engenius access points with a lot of success. Something like this would go great and could be mounted like a fire detector in the middle area of your house giving you great wifi throughout. It is PoE so you can run one cable and be done. You just need to pickup a power injector to go with it if it doesn't come with one.


Engenius AP
#74  
I've got my new network set up as @d.cochran suggests with the Engenius access point he points to and a ASUS RT-AC66U Dual-Band Wireless-AC1750 Gigabit Router. Works real sweet and I have plenty of signal near the robot. This set up and static IP addresses for the EZB's in the router took care of all my connection problems.