Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.
Get Started

Asked — Edited
Resolved Resolved by thetechguru!

Connecting To Two V4 Ezb's

First question and problem: I think the intent is to be able to connect up to 5 EZB's through EZ Builder. However I've hit a wall trying to connect EZ Builder to two V4 EZB's when they are in AP (Access Point) mode. Using my laptop I've followed directions and connected EZ Builder to the first V4 after establishing a wireless connection through the "Wireless Network Connection" icon on my Win 7 Taskbar. Then when I try to connect wirelessly to the second V4 EZB I lose the wireless connection to the first. My laptop will only let me have more then one wireless connection at a time. What am I missing here?

Second question and problem: With both V4's in Client mode and the Green light blinking (the voice says she's attached to my network), I can only have one EZB powered up at a time and have a successful search of my router for a IP address. If both are powered up and attached to the network EZ Builder cant find an address. Is this normal? I've watched the tutorial several times.

Third Problem: For two nights now after the laptop and robot are powered down the second EZB entry in EZ Builder will not connect to the second EZB board. I have to push the network reset button on EZB and redo the IP search in client mode.

#55  
Two suggestions. First, for the conflict with the extender. You can change the IP address/subnet of the router. See page 63 of the manual (download here: http://www.asus.com/Networking/RTAC66U/HelpDesk_Manual/) to see how to change the IP. I would suggest just changing the 3rd octet (ie, change it from 192.168.1.1 to 192.168.0.1)

The, since you have the MAC addresses of the EZ-B's, you can specify the IP addresses for the DHCP server to assign (this was my initial recommendation, but your old router could not do it). See page 64/65 for instructions. Note, they recommend setting to 192.168.1.xxx, but if you follow my recommendation above to avoid the conflict on the repeater's default address, then you would need to assign addresses in the 192.168.0.xxx subnet.

Alan
#56  
Thanks Alan & R-Doc for the inspiration and support.

I may have been a little off in my solution. After a few hours I restarted everything making sure I had a delay in powering up each EZB. Well, once again the second board wouldn't connect to ARC after telling me she was connected to my network. I checked the client list of the router and saw that the one that connected had the original IP address and the one that didn't connect to ARC had been reassigned to an IP address all the way to the other end of the spectrum of numbers (198). So.........

I have taken Alan's advice finally and (after changing the router's ID 92.168.1.1 to 192.168.0.1 I added the two EZB to the list of IP's that the router will always assign.

Tomorrow I'll see if this finally is the answer.
#57  
AH HA! Success. This morning was the first time ever I was able to get both EZB's to connect to ARC after being powered down over night. Looks like the changes made have worked!

I'll now be doing the final setup, clean up all wires, do a few more tests (mainly on powering up both EZB's at the same time) and reattach the EZB's to the robot. Then I'll make my final declaration and summery of what has been happening over the past week or so and how I stand now with this issue.

Thanks all for all the help and support through this. Hopefully this will help others down the line.

Dave Schulpius
#59  
Thanks @d.cochran but I've hit another bump. I changed the set up around and wanted the EZB's and the laptop running ARC to be accessing the router through the Engenius 350 that's set in Repeater Mode and down in the basement game room. Everything else in the house assesses the internet straight through the router itself on the main floor. I quickly found that the Engenius 350 in repeater mode will not pass through the Mac Addresses of the EZB's and laptop. The Router see's the same Mac Address for the Engenius 350 and for all three units. So the result is I can't use static addresses with the router and the second EZB is getting lost again and wont connect. Only one EZB will appear at a time but each keeps swapping in and out of the list.

I've read that if I set it up as a wired access point instead of a repeater the Mac addresses of the wireless clients should pass through. That's one option. The other option is to move the router back down to the game room where the robot stands and move the repeater to the main floor. That way I can access the router directly with the EZB's and control laptop and the rest of the house can use the Engenius 350 as a repeater.

Not really sure which way to go yet. *confused* I guess I'll do like I've done with everything else so far and just do something even if it's wrong. ;)
#60  
Here is how I have setup these before and they work great like this.

1. all of the EAP's are wired to the main switch
2. All of the EAP's have the same SSID

When you move from one EAP to the other, it will pick you up and start sending traffic to the other EAP.

I would set both of these up in AP mode with both broadcasting the same SSID. Just be sure that your main router and this router are on different IP addresses.
#61  
just to be clear, I would hard wire the AP to the router. Use a power injector to provide power to the AP.

I would setup the AP to have a unique IP address and then set both the AP and the router up to have the same SSID.

When signal gets low, the device will try to connect to the router with the stronger signal. It works for cell phones, tablets, laptops and everything else I have tried. I don't have an EZ-B yet thought.
#62  
Thanks @d.cochran for the elegant and clear instructions. They were a big help changing over to AP mode.

I've completed the switch from Repeater to AP mode but I did make one change from your suggestion @d.cochran. I gave the SSID of the AP a unique name. I really don't want any other device accessing it other then the robot's EZB's and the control laptop.

Now that I understand the concept of and the way to change settings in the Engenius EAP350 it was really very simple. I almost had it the first time was mucking around. However I didn't know I had to not only apply the changes I made in the page I entered them into but also in the master Change folder that list all the changes made during that session. Why programmers insist on having you save the same information twice is beyond me. ARC makes you do this also. *eek* You not only need to save changes and settings in scripts and such but also when you exit the ARC or they won't be saved. Can someone tell me why this is the case? (Sorry I had to blow off a little steam *blush* ).

Anyway, now that I have the Engenius EAP350 in AP mode I have it hard-wired to my new router and have excellent signal strength near the robot. I also have confirmed that the original device's MAC Addresses are being passed through the Engenius to the router. The static IP address previously entered for the EZB's are working now and both EZB's are now popping up in the Client list and I can connect to both in ARC. I'm also pretty sure I can now power up both EZB's at the same time and the router will recognize each separately. I'll power down over night and confirm this hopefully for the last time in the morning.

The whole secret to success here was to have a good router that can assign and keep IP addresses associated with the Device's MAC Addresses. Because of this I need to give the Kudos to Alan as he's been saying this from the beginning. Thanks man!;)

Just a footnote: I think I would have been OK with running everything in the basement just on the new router on the main floor. Before I installed the Engenius EAP3500 in the basement in AP mode I tried several times and successfully connected to both the new router and ARC with both EZB's. I even powered them both on at the same time and the new router found both as separate units and with a "Good" signal strength message. However my anal personality with the need to complicate things needed an "Excellent" signal and to have everything attached to the robot on it's own AP. ;)

If something else happens concerning this thread I'll be sure to update. In the mean time THANKS to all who held my hand through this. I hope others have or will learn from this experience. I know I have! *cool*

Happy building and have fun!

Dave
#63  
Dave,

Glad they are working for you. Also glad you have crazy good wifi in your house now. Your family will appreciate it. I know mine has even though they have become numb to the fact that they can connect to the internet from anywhere around the house.

Grats and I look forward to following your project. It is a really nice build you have going on.
#64  
I've confirmed now that I can power everything up at once now (both EZB's and the entire robot) and have both EZB's connect in ARC. Looks like everything is working as designed.

Now I can finally get to work again and see just what the V4's can do for me!

Thanks again for the help and support. :)
#65  
Glad if worked out, and thanks for the answer credit- a lot of us contributed.

I am sure we'll be referring to this thread for other users who will face similar issues.

Alan
#66  
Ya, sometimes it hard giving credit to just one person when usually so many are a part of the answer in the end. Good thing most of us are able to put our bid boy pants and realize this and not get bent out of shape when a credit is given to someone else. ;)

I really cant imagine mine will be the only issue like this. There are a lot of older routers and network equipment that I'm sure wont take kindly to the "new kid on the block" (EZB v4). Just look at Steve; he was having a similar issue and he had to go out and get a new router to get just one EZB v4 to stay connected. This is why I took the time and explored as many different aspects of my WiFi network and EZB V4 as I could. I wanted to make sure the problem was completely resolved had the right way or ways to solve this. I also learned a lot about routers, access points and repeaters. New routers...... Good! Old routers......... Bad! ; Access points..... Good! Repeaters......Bad! ; Static EZB IP's for several EZB's......... Good! DHCP............ Bad! ; Strong signal strength........... Good! Weak Signal........... Bad!:P

Another footnote; I've closed up my B9 robot and fastened all the boards down to the CSS shelf's. All is still good and so far the EZB's are connecting nicely to the network and ARC. :)

Next comes a real challenge; I want to mount a EZB v4 inside the metel brain that sits inside my acrylic bubble. *eek* Will see how my new WiFi setup punches through all this:

User-inserted image


User-inserted image


User-inserted image
#67  
Dave, Alan and others. I got my v4s about a week ago and following this thread saved me a lot of grief setting them up...
United Kingdom
#68  
Great news Dave.

Just to throw a different option in the mix (a little late but useful for anyone else refereed to this topic), you could always add a wireless NIC USB dongle to the PC running ARC and connect via AP mode. 1 dongle per EZ-B. Something like this would do the trick and is pretty cheap. You would need spare USB ports though.
#69  
I did not have to do much extra research for my issue because of this thread once I realized my router was too old. This is what I like about the forum, we're all in this together and can band together to find answers that benefit everyone. I even changed the router IP address like Alan suggested to keep any possible router/EZ-B with the same IP issues.

@Rich - I don't know about everyone else, but I already have two USB hubs on my laptop just to keep up with all the devices connected to it.
#70  
***Edit*** see new thread
Have a problem... Similar to Dave's so I thought to add to this thread instead of making a new one... Anyway... Both my EZB4 will connect to the network no problem, however ARC can only find one of them at a time... meaning I cannot have more than one ezb4s connected to ARC at any given time. The scan tool will only find one ezb... usually the first one powered on... Long story short and judging by what Dave went through I am guessing its a router issue... I have an all in one router/moden ... an SMCD3GN from SMC.... I rent it from my local cable company by the way... So my question is should I turf it and just use a modem from them and then buy my own router?... Also need to mention that I barely get 30ft from the router when I start to get disconnect problems so range sucks...

Thanks
Richard
#71  
That's what I did Richard R. But I went one step further. I purchased my own cable modem from Amazon.com and then got the Asus WiFi router (RT-N56U). Make sure your cable company will let you use your own cable modem. I use SuddenLink and they recommend what modem to use and then let you either rent or purchase elsewhere.
#72  
Thanks Doc... Calling my Cable company now.... And respond to my new thread so I can give you the credit...
#73  
I personally like a separate access point on my network and let the cable modem just be a cable modem. I have used Engenius access points with a lot of success. Something like this would go great and could be mounted like a fire detector in the middle area of your house giving you great wifi throughout. It is PoE so you can run one cable and be done. You just need to pickup a power injector to go with it if it doesn't come with one.


Engenius AP
#74  
I've got my new network set up as @d.cochran suggests with the Engenius access point he points to and a ASUS RT-AC66U Dual-Band Wireless-AC1750 Gigabit Router. Works real sweet and I have plenty of signal near the robot. This set up and static IP addresses for the EZB's in the router took care of all my connection problems.