Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Netherlands
Asked — Edited
Resolved Resolved by DJ Sures!

Bug In ARC While Adding New Script Robot Skill

The verticall scroll bar disappeard in 2020.11.02.00 early access and the regular version. See attached picture, right side.
Input for bug fixing:
I added on my second screen (F11 shortcut one) a new robot skill, the very basic script (https://synthiam.com/Support/Skills/Scripting/Script?id=16089). After that I vertical scroll bar was gone.
Tried various options like going to older save but that seems not affected as well.
The scroll bar is visible on the first (F10)and third (F12) screen.
Adding the same script robot skill on the first (F10) screen was possible and I could next move it to the second screen. When I deleted it over there (because I suspect the script created some more problems) the vertical scroll bar is gone again.
User-inserted image


Related Hardware EZ-Robot EZ-B v4
PRO
Synthiam
#1  
We've been experiencing similar strange behavior due to some Microsoft Windows updates. We're actively looking into it and will have a fix shortly. In the meantime, the issue can be circumvented by pressing the SMART ARRANGE button in the Workspace tab
PRO
Netherlands
#2  
Thanks for the quick reply and work-around
PRO
Synthiam
#3  
No prob:D Thanks for becoming a pro member! Much appreciated - we'll have an update for you soon with a fix for this
PRO
Netherlands
#4  
Thanks:)

I do see this error appearing recently, not sure if it related, boutght thought better leave a copy, maybe it helps

Code:

graph: System.InvalidOperationException: Object is currently in use elsewhere.
at System.Drawing.Image.get_Width()
at ARC.UCForms.UC.UCGraph.n6dOlxytZEamqfQUJ38G(Object )
at ARC.UCForms.UC.UCGraph.UpdateImage(Int32 value)
#5   — Edited
@DJ, we've been struggling with this problem for years. We've discussed it in the past many times. It's an ongoing issue. I've been having this happen forever and have gotten in the habit of just doing a Smart Arrange everytime it happens. That's all well and good but with a large project I arrange my controls a certain way to easily find them. A Smart Arrange jumbled them up. What a mess! In your defence you have tried several fixes in the past that didn't work. 

I've got a large project with all three virtual screens filled and extending down and off the screen. It seems that this issue starts when controls start to over fill the workspace and scroll bars are added. In addition to that, I notice an oddity when I move from one virtual desktop to another anter making changes or moving controls around. I notice the small icon showing the desktops at the top of the page won't alway refresh and show the changes. If the change of any curtin desktop has not happened in the little icon and the ARC is closed, the next time ARC is opened controls are slid up under the menu bar like the OP shows. 

I haven't pursued a fix for this in a long time because I got tired of hoping for a fix. Also till now ARC was free and it's hard to push for something to get resolved when you are not paying for it. LOL.;) :(
PRO
Synthiam
#6  
It's strange that I can't reproduce it. It would be easy to fix if i could merely experience the same thing. Can you describe a step-by-step way to reproduce it? If you do, i can fix it. I can fix anything that i can reproduce:D
PRO
Synthiam
#7   — Edited
Hmm I spent (ugh wasted) hours this morning on three different computers and I can not reproduce this. I’m losing my mind lol - please if you can provide a video or anything that gives me a way to reproduce it?
#8  
Hi DJ, I'll get this for you asap. I've able to reproduce this strange behavior fairly often. Hopefully Murphy "opposite" Law won't bite me in the bumm now. LOL:p

Relax till then. Not a huge game changer. IT's something I've learned to live with. Thanks for the effort so far and sorry for your waisted time.
#9   — Edited
OK @DJ, I've been able to consistently reproduce this issue on the latest version of ARC. I have a video I'll attach. However here are the steps:

Have a big project with controls that extend down the screen and need scroll bars to get to.
Scroll down the page and leave it. 
X out and close ARC.
When you are prompted to save you project click "Save"
ARC will close. 
Reopen ARC and you should see the workspace  you left scrolled down now up under the menu bar as you left them. 

It looks like ARC does not reset the whole workspace to a visible state. You can not use the scroll bar to bring the workspace down from under the menu bar. 

I hope this helps.

PRO
Synthiam
#10  
I'm on it! stay tuned:)
#11   — Edited
Outstanding ! You've never let us down yet. Just make sure you put on the cape and tights with the big S on the chest. S for Synthiam!
PRO
Synthiam
#12  
Ain't no one gotta picture me in tights, Dave!!!:D
PRO
Netherlands
#13  
Hi Dave,

Thank you for making the video.
To add to your observations: when you showed your screens-without-the-bug around time 1:04 you see the first desktop (F10 screen). It has the vertical scroll bar to the right. Later in the video when your show screens-with-the-bug around time 3:04 you see the first desktop and the vertical scroll bar is gone.
So, the problem is a little bigger than desktop underneath the top menu bar: I can't scroll up-and-down anymore to reach the controls not shown. Also the screen freezes for me often, even the controls shown I cannot click. Rearrange solves it. And I agree, my carefully arranged screens come back different causing to try to find my control I was looking for.

@DJ, I have out my project on a google drive and if needed can give you access to pull it. Just need a (temp) email address, drop my an email if needed,

Charel
#14  
Hi Charel,

No worries and no trouble. Glad to help. This is also a selfish motivation on my part as I've been annoyed with this problem for a while. To DJ's credit he's tried to fix it several times but probably didn't have the proper visual help and actions like in this video to figure see what's going on. Also, I've spent a lot of time watching this behaviour trying to understand it. I've have been able to reproduce this issue on three or four different computers running Windows 10 and earlier win versions .

I'll take some blame also because I just settled and learned to work with it. I kept quiet so DJ probably thought it was fixed and moved on. He does have a lot on his plate. DJ just doesn't have that kind of time if he can't reproduce it in the first place. This must be a tricky one.

As far as the disappearing scroll bar on the 1st screen, I have noticed it. I forgot to mention it, so thanks for bringing it up. It's good to know that the same thing is happening elsewhere. I know nothing of what is going on in the background. However in my childlike observation of this behaviour is, if you notice, there is no reason to scroll "down". All the controls are either in view on the workspace or slid "up" under the menu bar. For some reason ARC or Windows are not seeing the controls under the menu bar so it takes away the scroll bar. The offending party thinks all the controls are visible and (because of the reboot of the ARC) "forgot" the workspace was up there. Either that or it didn't take note of this before ARC shut down and didn't correct it. Again, that's an uneducated observation. 

On a different note; if this is not a secret project you can upload it to the Synthiam Cloud. DJ (or anyone) can see it from there. From within ARC find the Cloud Storage tab on the menu bar and simply click Save. You'll get prompted to enter some information about your project then you can send it away. 

Have fun and keep your fingers crossed for us.
PRO
Netherlands
#16  
Hi DJ,

First of all, many thanks for your fast reponses to solve this issue, much appreciated.
Here are the test results from the Netherlands (for you to find when you wake up)

Big progress, it looks like the issue is gone, I could not reproduce the problem. e.g. I kept the vertical scroll bar in all three screens while adding controls, saving/re-opening, shuffle, etc. I tried both my latest version that had the problem and older versions that did not have the problem.
Also my other issue is solved: Auto Start Command Line Options did now also work for my large project.

Some points for your attention:
+ When you load the project it does its usual thing and shows the first screen and next it takes over a minute to load the other 2 screens. So, the first time I loaded my larger project I thought the ARC was frozen. I was already collecting screen clippings to document the issue when I saw ARC came alive again and completed the load of the 2 other screens. I timed it from the moment I hit the open-button to select my project: after 12 seconds the first screen is build, after 1 minute 30 seconds the 2 other screens load and I can work on my project.
+ Screen 2 and 3 have a black background while my defaults are white background, somehow project defaults are not properly loaded?
+ I still saw the error appear, not sure if it is related to this problem but anyhow worth noticing in case it triggers a "aha" for you:

Code:

graph: System.InvalidOperationException: Object is currently in use elsewhere.
at System.Drawing.Image.get_Width()
at ARC.UCForms.UC.UCGraph.UpdateImage(Int32 value)
PRO
Synthiam
#17  
Interesting - I wonder if it’s specific to your project. Can I have access to your project for testing?
PRO
Netherlands
#18  
Certainly, uploading
PRO
Netherlands
#19  
called it R2D2 access for testing, made public, let me know when you got it
PRO
Synthiam
#20  
Got it! I'll take a look today for ya and see what's going on
PRO
Synthiam
#21  
Oh - i can verify it takes for ever to load! Wow... I'll figure it out and have a fix for you:)
PRO
Synthiam
#22  
Alright - it's fixed. I'll have a release posted at the end of today posted
PRO
Netherlands
#24  
Thank you for the fast turn-around.:D

I can confirm it works. Project loaded fast, as it used to do.*love*


Only remaining (minor) issues as fasr as I could see:
+ Screen 2 and 3 have a black background while my defaults are white background, somehow project defaults are not properly loaded?
+ I still saw the below error appear, not sure if it is related to this problem. I will see if I can track down when it is cast. and report out in a seperate issue. It does not break/stop anything.

Code:

graph: System.InvalidOperationException: Object is currently in use elsewhere.
at System.Drawing.Image.get_Width()
at ARC.UCForms.UC.UCGraph.UpdateImage(Int32 value)

Many thanks!
PRO
Netherlands
#25  
And closing this issue by marking it resolved
PRO
Synthiam
#26  
The error message and background color are on my list but not marked as urgent as the performance hit was:)
PRO
Synthiam
#27  
Okay - the error and background are fixed. I'll update ARC (Early Access) later this evening
#28  
Like I said in the update notice thread, The issue seems fixed and also ARC seems faster to shut down and start up!
Super job! I'm thrilled and can't wait to get started organizing my project. Thanks!!
PRO
Netherlands
#30  
I can confirm it works! Many thanks