Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Gibraltar
Asked — Edited

Need V8.5 Ez Builder

i think i need an earlyer version of ez build coz i can't connect to v15
plus keep gettingerr msg on ez update
Attempting connection to COM3
EZ-B reports EZ-B Firmware V8.5
Connected
Usending ping
Usending ping
Usending bootloader
Failed to load bootloader!
any advise
thanks

AI Support Bot
Related Content
Synthiam
PRO
Synthiam
#1  
there is no version 8.5.. you are connecting to your computer's internal modem. You'll need to follow the tutorial on the website on how to add the EZ-B to your computer. the tutorials can be found by clicking on the menu item labelled "Tutorials"
Gibraltar
#2  
sorry to be a pain
got rid of software that came with bt dongle useing Microsofts now
still getting err msg
Attempting connection to COM6
Connection Failed: System.TimeoutException: The write timed out.
at System.IO.Ports.SerialStream.Write(Byte[] array, Int32 offset, Int32 count, Int32 timeout)
at System.IO.Ports.SerialPort.Write(Byte[] buffer, Int32 offset, Int32 count)
at EZ_B.EZB.Connect(String portName)
Disconnected
any idea
watched tutes following it but sill having probs
what am i doing wrong *stress*
PRO
Synthiam
#3  
you've received two COM ports when adding? I suspect COM6 and COM7?

You can try the other COM port, but it's supposed to be the lowest - although i've heard a rumour that someone had it reversed and it worked... technically that's improbable, but i've seen stranger things in windows

When you attempt a connection, what do the LED's on the EZ-B do?
Gibraltar
#4  
got two com ports COM4 & COM6
the blue LED just keeps flashing
the bt LED stays on for few seconds then flashes as before
the best i had is bt LED slowly flashing
got this msg on ez-b firmware updater
Attempting connection to COM4
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String portName)
Disconnected
Netherlands
#5  
The EZ-B LED is supposed to be slowly fading while the BT LED is flashing.

When it's connected, they both just remain solid.

I think it's a problem with your bluetooth COM-port..
Gibraltar
#6  
and.........
sorry don't mean to be rude just getting frustrated,
so how do i fix it
PRO
Synthiam
#7  
When you power the EZ-B, you have red and blue flash?

When you press the CONNECT button in ARC for COM4, does the RED led stop flashing for a second? And the blue continues to flash?
Gibraltar
#8  
YES exactly what happens
i know i'm being thick
sorry. but it was a prezzy from my wife
and don't want her to be dissapointed
thanks
Netherlands
#9  
Haha, just follow the instructions in your avatar: Don't panic.:P
Gibraltar
#10  
cheers *blush* Niek
i just might have to change it but not yet.
thanks everyone for your patience *tired*
#12  
your not the only one having issues ....

got the builder up with bluetooth easy easy part.
then i got asked to upgrade, which i followed after that i havent been able to get the program to find it.
though removing it and finding it under bluetooth still no problem


error i get :
Attempting connection to COM10
Connection Failed: System.IO.IOException: A device attached to the system is not functioning.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
at System.IO.Ports.SerialPort.Open()
at EZ_B.EZB.Connect(String portName)
Disconnected

linvor - is set to com10. so that isnt the problem.

below is what i get when trying to verify image
Warning: Line 2: Fixing Diff: 4
Warning: Line 676: Skipping Type: 4
Warning: Line 677: Impossible Diff: -10780
Address: 0x0, SB Size: 0x5438
Image OK

*stress*
Gibraltar
#13  
BT LED gose solid for 2 seconds then flashes
EZ B just keeps flashig
this is msg i get
Attempting connection to COM7
Comm Err: The operation has timed out.
BbytesToExpect: 1

Received:
Disconnected
Connection Failed: System.Exception: Controller Not Responding
at EZ_B.EZB.Connect(String portName)
Disconnected
PRO
Synthiam
#14  
Can you remove the bluetooth module, it is located on the top of the black silicon chip. It should just slide out of the plug. Then re-add it by ensuring that the 4 center pins go into the female plug (leaving one pin on either side not connected).

And if you have a camera, can you post a picture of the bottom of the EZ-B so i can see the solder joints? I'd like to verify that there are no accidently solder shorts or missing joints.

If the red light stops flashing, that means a connection has been made with the bluetooth module. If the blue light does not stop flashing, that means there is a communication disconnection between the bluetooth module and the IC.

It's happened a few times before by a faulty solder point. However, all boards are tested before shipped. If the joint broke during shipping vibrations because it wasn't 100%, that can be expected.
Gibraltar
#15  
thanks for taking the time to help i,ll e mail some pictures
ps
the geek shall inherit the earth
(it was a typo in the good book)
User-inserted image


User-inserted image


User-inserted image
United Kingdom
#17  
Check the solder joints in the circle aren't touching


User-inserted image
Gibraltar
#18  
lucky i got magnifying glass
yes all three are touching but not bottom half of
ringed solder joint


User-inserted image
United Kingdom
#19  
If it was me I would use a soldering iron and suck off all the excess solder with a solder sucker then it would be easy to see what should be connected together and what shouldn't. These are the pins to the Bluetooth module and it definately looks like this is the area where the problem is.

Perhaps someone else can jump in here if they have the same connections on their board mine is different looks like yours is a 3.1?

I like Gibraltar btw been a few times
Gibraltar
#20  
thanks @winstn60

has anyone got a picture of what it should look like
i don't want to just jump in with my soldering iron
and where i live its hard to find a good electronics shop
i have to go to spain for stuff
Gibraltar
#21  
still having trouble can anybody help *stress*
United Kingdom
#22  
Anyone?

Just need a close up pic of the underside of the EZ-B board where the Bluetooth module is plugged in

Looking at your pic again the +5v should be bridged with a spot of solder but it looks like they used too big a blob of solder and it is touching the solder land next to it. Just heat it up with your soldering iron and drag it clear but leave the +5v lands bridged you cant really damage it
United Kingdom
#24  
What I said above. Your pic (circled) shows the +3.3v bridging lands they look ok its the one below the +5v thats touching the land next to it and shouldn't be.

It should still be bridged though
Gibraltar
#25  
ok thaks i'll take the plunge tomorrow
i'll let you know