Welcome to Synthiam!

Program robots using technologies created from industry experts. ARC is our free-to-use robot programming software that makes features like vision recognition, navigation and artificial intelligence easy.

Get Started
Asked — Edited

Is There A Better Wireless Camera For Ez Builder?

We have two issues with the existing camera that came in the kit.
1) It drops the link and can't get it back for hours or days.
2) Ever since the new SW builds, where we lost resolution control, it is inadequate to accomplish the tasks that we designed the bot to do.

We are now at the end of our time and we have nothing to demonstrate because it either does not work at all or it works but can't find the glyphs from the desired range.

All suggestions are welcome.

Thanks again

AI Support Bot
Related Content
Synthiam
#1  
if using a pc on you robot design ,usb web cam is the best way to go
dont really care for bluetooth to much,WIFI much better
this might work needs work in programming ,but remove the bluetooth and add a WIFI there are many WIFI web camera's out there
PRO
Synthiam
#2  
Troop, the resolution is in the next release, ironically:)
#3  
that might be ok DJ ,hope to test it when comes out
i notice my bluetooth drops signal alot too and new fix for that
PRO
Synthiam
#4  
I've never experienced an issue - most likely radio interference in your area.
#5  
it might be that,one reason dont like buetooth to much,so far WIFI i never seen that problem
are you going to add support for WIFI soon
#6  
Since day 1 the ON/OFF button never turned the unit OFF. It would turn ON but you would have to wait for the battery to die to turn OFF.

When camera reception drops out you either get colored horizontal lines or a black screen. We have learned to let the battery die and try again. Lately that does not always work.

We have shut down all of the BlueTooth and an all other WIFI. That does not make a difference. When I tell the laptop to add a BlueTooth device, it does not see any, once I shut mine down.

I even connect an antenna to the spectrum analyzer and scan for other emitters around 2.4 GHz. I don't think that is the issue.

I would just as soon get a new camera, if I were sure that it would work with our existing project.
#7  
mine gets horizonal lines and has a blank screen sometimes ,tried my other 2 bluetooth camera's still the same,i think it might be RFI problem on mine,seen it happen to other bluetooth just not as much
camera you will see it a lot more,it depends highly on good signal for video data
#9  
why do you need to remove the plastic shell from the usb dongle DJ, it makes the board week and can easy get damage or shorted

i re-look at the video and i see why the cover is removed the button on the side doesnt have a hole for it,(thats kinda dumb)
i hope that the cover is replaced,its not on the video,i would drill a hole on the side for that switch,maynbe hole for the sending and receiving leds ?
#10  
Awesome. I did not know about that pairing button inside the dongle. I will try it tonight!

Thanks again DJ
PRO
Synthiam
#11  
@Troop, you only need to pair if the camera doesn't work. It only requires pairing once per lifetime. The instructions about how to turn it On and Off are what i'm directing you to:) .. if your camera works, you don't need to re-pair it

@robotmaker, i do not understand your question.
#12  
not a question its a idea,instead of opening up the dongle each time,make a hole for the paring switch
Rest of the comments was before i saw the video

i had problems with my bluetooth mouse and i tried the paring button ,it has the button on the bottom
and found out that sometimes my bluetooth will work and sometimes it doesnt and tried paring it no fix

so like you said i might have a RFI problem or noise,since i have bluetooth running,WIFI running ,X10 thats both RF and IR and ac current signal all over my house,most likely it X10 NOISE since every outlet,every light ,pool,juccuzi ,A/C unit all use X10 SYSTEM plus my alarm systems uses X10
#13  
We are very familiar with how it should be turned on and off. I have held that button from seconds to many minutes. It does not turn off.
#14  
did DJ's idea about the paring button help ?
seems like a faulty camera
#15  
Hi robotmaker,

Thanks for asking. No, it did not restore the link, however my LEDs never looked the same as the ones in the video. And of course, I tried it many times. It is a good trick to know regardless. That DJ sure has a lot of tricks up his sleeves.

I am very willing to admit that the camera/dongle does not work. My fault. My question is: is there a camera that I can buy that will replace it and give me the performance that I used to have with this camera, several SW builds ago?

Thanks again
#16  
@troop. If you have a 2.4 ghz wifi router nearby try configuring it to operate on a different channel. Perhaps your router is flooding the frequency the ez cam is also running on. I have not had the problem but my netgear router is set to channel hop for best connection integrity.
#17  
Thanks jstarne1,

I will try it. That is another good tool to have. It doesn't feel like an EMI problem to me. It is not intermittent and Gaussian. It is all or nothing, lately nothing. I think the problem is more discrete. Like a HW failure. I may be wrong, usually.

Wow! Spellchecker, all right DJ.

What a great community of helpful folks. I am impressed. We'll figure it out.