EZ-Builder Windows Release 2016.10.18.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
Changes:

- Remove StartVoice() from prompt builder since it overwrote SetVoice() as per PTP's email suggestion (http://www.ez-robot.com/Community/Forum/Thread?threadId=9743)

- SetVolume() allows ez-b index (http://www.ez-robot.com/Community/Forum/Thread?threadId=9698)

- display the battery voltage and temperature of the ez-b when connection occurs in status window

- updated error message when importing Auto Position that doesn't match current configuration
United Kingdom
#59  
Thanks, DJ it now all works as it should - I now can select my Cereproc voices in English-UK.
I would also like to give a special thanks to PTP for all his great input that helped to solve this issue.

Tony
#60  
@bhouston,

Sorry to insist did you tried David's voice with Emphasis:Not Set ?

with Rate: Slow or Rate:Extra Slow ?

User-inserted image


still not working ?
#61  
I did not test with emphasis not set. It was set to Moderate (the default) for all of my rate tests.

I can't try changing to Not Set until I get home from work, and maybe not until very late.

Hopefully Bob can try that today.

Alan
#62  
Only to be clear Emphasis, Rate are handled by the voice provider.

You can have a voice supporting both attributes, only one or having trouble mixing them together.

Is not a Windows Speech API bug.

David, Zira, Hazel all come with windows, but are implemented by different providers, it's possible to find differences between them.

To help troubleshoot i always start with one Attribute off: e.g. Emphasis: Not set, than i test the Rate attribute, then i swap, and only after i try to combine both.
#63  
@ptp. That worked! I had tried that before and it didn't make a difference but now it does. I can now adjust the rate of both David and Hazel voices in EZ-Builder. Thanks for all your help.
#64  

Quote:

@ptp. That worked! I had tried that before and it didn't make a difference but now it does. I can now adjust the rate of both David and Hazel voices in EZ-Builder. Thanks for all your help.


Yup, that fixed David's rate issue for me too.

Thanks @PTP for helping @DJ fix this longstanding issue.

Alan