EZ-Builder Windows Release 2015.10.23.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
Changes:

- Display disconnected message when attempting to create a servo fine tune when not connected to an ez-b

- new EZ-Script command "Sort" (similar to the plugin but not built into the EZ-Script engine)

- increased EZ-Script parsing in runtime

- plugin updater when EZ-Builder loads
Synthiam
#8  
Bhouston can you post the command that doesn't work for you as well?
#9  
None of the commands for the Neo Pixel Ring work, For example,

Code:


SendSerial(1.d18, 9600, "F0,0,100,0,0,0,50,20,R")


and for the Custom Movement Panel controlling a Sabertooth2 x 12 none of the commands work

Code:


SendSerial(1.D0,9600,127) # motor 1 127 is full speed
SendSerial(1.D0,9600,255) # motor 2 255 is full speed
#10  
Houston we have a problem!

;-)


Thanx really much for testimony :-)

Now we have the evidence that i am not dump.


For Info:

I use 2 EZB to controll 2 Neo Pixel Rings.

No. 1 and No. 3

and both are not working. So with the Port i think this has nothing to do.

Boris


PS @ Houston:

Now with your trick the "Scanner" Mode from the NEO works everytime! Thanx Bob
Synthiam
#11  
Interesting - I'll take a look and see how it works in my lab and not yours. Sure it's something simple and may require an updated release. stay tuned
Synthiam
#13  
Man that was a tough one to debug. It's a pretty big bug with .Net - which i guess may be expected behavior because of the bug? Either way, the Enum.Parse() doesn't throw an exception if the input is an integer even if it's not a valid Enum entry. Anyway, it's fixed! http://www.ez-robot.com/Community/Forum/Thread?threadId=8556