EZ-Builder Release 2017.01.17.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
Changes:

- Blockly and SYNTAX script edit modes (read below)
- added GetServo for Blockly
- fix for camera tracking in Blockly
- fix for Blockly power() function in math function
- allow selecting the default editor mode (block or syntax programming when editing scripts)
- all camera rotation options supported (mobileapp rotation is limited to what is specified in the blue question mark help)
- fixed RoboScratch Say and SayWait
- added RoboScratch WaitForSpeech
- Blockly loop forever function
- bug fixes for the Blockly EZ-Script editor
- WaitForSpeech() displays the Confidence value when detected before closing
- WaitForSpeech() uses a mininum Confidence value that can be selected in the TOP MENU -> OPTIONS -> PREFERENCES
- Blockly fix for Repeat X Times
- Blockly has a longer WaitForSpeech timeout (10 seconds vs 5 seconds)

All script edits now default to Blockly mode, if there is not already a script. You can change the default behavior in the TOP MENU -> OPTIONS -> PREFERENCES -> DEFAULT EDITOR.

User-inserted image



Code is generated for the new Blockly script edit forms as well...
User-inserted image



You can change the default behavior in the TOP MENU -> OPTIONS -> PREFERENCES -> DEFAULT EDITOR.
User-inserted image



The last edited mode will be restored when editing the script in the future.
#9  
last button is wait for glyph

version shown when opening is 2017.01.16.01

running windows 10 -downloaded your new down file
ran the update, it only wanted to update/repair. SO, I deleted the EZ-Builder program, and then downloaded/ran the new update file. Got result above.

I am out of ideas?
#10  
@DJ... I am getting the same as Eagle218... Current version of EZ Builder (16.01)... went to the cloud downloaded current JD.EZB file... last button is wait for glyph. Nothing afterwards. However, I don't use RoboScratch so I could be missing a step here...
Synthiam
#11  
That's super strange. The project has nothing to do with the wait for speech bubble, and it displays on my pcs. I'll reupload a new build and maybe it's a corrupt file in the installer. Something like this has happened in the past once or twice we have experienced.

I'll upload a new build later this afternoon.
Synthiam
#12  
I re-compiled and uploaded a new build. This thread title has been renamed with the new build to reflect version. There are no changes to this build, other than a recompile.
#13  
OK, got the "wait for speech" button on the bottom of the list, thx