EZ-Builder Release 2012.11.13.00

Download and install the latest EZ-Builder robot programming software to experience these updates.

Download EZ-Builder
This update includes many interface enhancements and a few new features. This is a recommended update.

Here are some statistics for camera detection methods:
- Glyph Detection: ~2700 Ticks (<= 1ms)
- Motion Detection: ~6000 Ticks (<= 3ms)
- Face Detection (detected face): 14000 Ticks (<= 7ms)
- Face Detection (no face): 65000 Ticks (<= 31ms)
- Color Detection: 3200 Ticks (<= 1ms)

Changes:
- New UI windowing engine
- New webserver engine
- HTTP Remote Control update
- Check For New Updates includes "View Release Notes" shortcut
- Some controls contain their name within the control opposed to just title bar (for lengthy names)
- Script Flow enhancement
- Camera control supports Motion JPEG streaming
- HTTP Server includes static camera view which can now be viewed from another EZ-Builder instance
- TCP Server includes Password Protection
- MP3 Audio fix
- Camera includes FULL SCREEN button (rather than window maximize option)
- Send Serial bug fix for Strings
- Disables menu options when HTTP Server is running (prevents Open/New/Save/Etc)
- Camera timing for servo response increased

Enjoy:)

User-inserted image
#1  
Finally I can continue with my project:) Thanks man!
#2  
I can't install this version, the program said that "a new version of this program is already installed" *stress*
#3  
I don't have that problem. Always uninstall your old version, and reboot, before installing the new one, don't install over the existing one, that's called dirty install and sometime can cause problems.
#4  
This is the first time it happen to me, all the older versions installed just fine.
#5  
Same thing happened to me. I completely Uninstalled first, then it installed fine.

;)
Canada
#6  
Thank you for the continuous updates @DJ

I am noticing strange little glitches that might be related to my main project file, is there a way to generate a list of settings and scripting from a project that can be printed, in order to make it easier to rebuild from scratch?

And I have discovered two issues in this latest release:

A) In server/client mode, any servo release command on the client side actually sets the server connected servo to go to 100

B) When loading any saved project onto a PC that has a different (smaller) screen resolution and lots of controls that fill the screen, there seems to be a forced auto arrange (even if that feature is turned off). Totally messes up any prior control panel arrangement. I have not seen this happen before and I am constantly cross-loading projects between all my computers.

Thanks,

Gunner