Release 2013.12.18.00

(Autonomous Robot Control Software)
Make robots with the easiest robot programming software. Experience user-friendly features that make any robot easy to program.

Change Release Notes

This latest release of ARC has a pretty big change. We have upgraded to Visual Studio 2013 and a bunch of things have changed from VS 2010. Let me know if you have any installation issues...

Warning: This is a very beta installer. Only upgrade to this version if you are volunteering to help debug the installation issues

*Note: You must uninstall the previous ARC version before installing this
1) Visit Control Panel
2) select Programs and Features
3) Select ARC in the list and uninstall
4) Reboot
5) Install the latest version



- Updated GUI with flat buttons

- Connection control has Scan and Web config buttons for EZ-B v4

ARC Downloads

Teams FREE

Free

  • Includes 1 free plugin robot skill per project
  • Community support
  • Free with trial limitations

For schools, personal use & organizations. This edition is updated every 6-9 months.

Recommended

Early Access

As Low as $8.99/mo

  • 2 or more PCs simultaneously
  • Includes unlimited skills
  • Premium support
  • And much more

Experience the latest features and bug fixes weekly. A Pro subscription is required to use this edition.

Runtime FREE

Free

  • Load and run any ARC project
  • Operates in read-only mode
  • Unlimited robot skills
  • Early access fixes & features

Have you finished programming your robot? Use this to run existing ARC projects for free.

  • Minimum requirements are Windows 10 or higher with 2+gb ram and 500+MB free space.
  • Get more information about each ARC edition by clicking here.
  • See what's new in the latest versions with Release notes.

Compare Editions

Feature ARC Teams
FREE
ARC
PRO
  Get ARC for Free View Plans
Usage Personal
DIY
Education
Personal
DIY
Education
Business
Premium support $14.99/ticket
(optional)
1 request/month
($9.99 for additional requests)
Feature requests Yes
Early access to new features & fixes Yes
Simultaneous microcontroller connections* 1 255
Robot skills* 20 Unlimited
Skill Store plugins* 1 Unlimited
Cognitive services usage** 10/day 6,000/day
Auto-positions gait actions* 40 Unlimited
Speech recongition phrases* 10 Unlimited
Camera devices* 1 Unlimited
Vision resolution max 320x240 Unlimited
Interface builder* 2 Unlimited
Cloud project size 128 MB
Cloud project revision history Yes
Create Exosphere requests 50/month
Exosphere API access Contact Us
Volume license discounts Contact Us
  Get ARC for Free View Plans
* Per robot project
** 1,000 per cognitive type (vision recognition, speech recognition, face detection, sentiment, text recognition, emotion detection)

ARC Pro

Upgrade to ARC Pro

Experience early access to the latest features and updates. You'll have everything that is needed to unleash your robot's potential.

United Kingdom
#2  
Installation had no problems here (although I do have 2 firmware update tools in the start menu)

Projects opening perfectly too:)
PRO
Belgium
#3  
cant hardly wait to start.:)
#4  
Install went fine. But when I try to open a project, I get "Unable to load C:\Users\jdeba_000\Documents\EZ-Builder\MyProjects\gb-wbwithoutcam.EZB. Reason: There was an error reflecting type 'EZ_Builder.Config.ConfigurationV2'

I am going to uninstall and download again, And try again.

J

Uninstalled and download again. Installed okay. But same error. Using Windows 8.1. J

made new project it works, but unable to save get error "Unable to save C:\Users\jdeba_000\Documents\EZ-Builder\MyProjects\gb.EZB. Reason: There was an error reflecting type 'EZ_Builder.Config.ConfigurationV2' j
#5  
Same problem as jdebay, can't open user projects including sample projects or scripts... Also can't open anything from EZCloud.....
#6  
Same issue: Unable to open projects (locally saved or cloud)
PRO
Synthiam
#7  
Can you check and see if there is a previous version installed still? Uninstall all ARCs, reboot, and install this one.
#8  
There was a previous version installed as well as this new version. Deleted both versions, re-booted, installed latest version again ,same issue. - using Win 7 -
#9  
found two versions also.
uninstalled both.
clean register.
shutdown.
restart, install, same problems.
*stress* *stress* *stress* *stress*
j
PRO
Synthiam
#10  
Interesting... There is a cached file somewhere on your computer from the old version. Can you uninstall, then check the C:\Program Files(86) folder for an EZ-Robot folder?

If there is one, can you tell me what is in it?

After you screenshot or save what's in it, delete it. Then install the latest version
#11  
Did the same as jdebay and also have the same problem... Uninstalled all versions of ARC, re-started the computer and put a clean install of the new version of ARC... Still no worky...:(
PRO
Synthiam
#12  
Do you all have Windows 7 or Windows 8?

The trouble seems to be with the new installer for Visual Studio. They got rid of the old Setup and Deploy feature and replaced it with Install Shield. I spent nearly 8 hours yesterday evening trying to configure Install Shield. It is very buggy and kept losing my settings. The installer works on my computers for testing, we'll have to narrow down why it's giving you guys grief
#13  
After removing all versions of ARC... what's left in C:\Program Files(86) folder is a folder(s) named \EZ-Robot Inc\Ez-builder\media... Nothing is in the media folder
United Kingdom
#15  
Just to add (if it's of any use to anyone);

Windows 7 64bit
Downloaded and installed new version last night without uninstalling the old version
Works fine, opens any project I have tried locally and on the cloud.

Control Panel --> Programs and Features does show 2 versions installed but nothing is causing any problems.

Contents of my %Program Files (x86)% directory are;
User-inserted image


Edit: Also, this is what I have installed...
User-inserted image


Also, I have UAC turned off completely. I mention this as someone posted last night about not being able to install as they were not admin. A long shot but it may be related.
#16  
My Win 7 Pro does not have the x86 program files selection, only program files. After uninstalling both EZ-B folders and a reboot there is no reference to EZ-B folders within Program files. Downloading the latest version still results in the same error.
#17  
@Robot-Doc question do you have ms office 2010 installed?
@DJ question no ms office?

j
#18  
jdebay I have a license for MS Office 2003 and that's what is installed on this machine, Win-7 32 bit. Also installed Windows update for .net 4.5.1
#19  
@Robot-Doc the reason I asked was I have ms visual studio 10. installed. And I think that installed with office 2010.
j
#20  
I do have Visual Studio 2012 installed as well as VS 2012 Express.
#21  
@DJ Sures... It is installing, I just can not read current projects. I can make a new project and test it, but unable to save it. I have ms visual 10 install. I notice @Rich does not and all is fine with him. I can send install.log if that will help?
j
PRO
Synthiam
#22  
The installer is not installing the dependency files. I have isolated the issue - now I need to resolve it.

I'm confused of why Microsoft would have removed the Setup and Deployment feature from Visual Studio 2013. Install Shield is really buggy, bloated and has a confusing setup process. After doing some google searches, it seems there are countless number of people who are upset at Microsoft for removing that feature...

We will get through this guys!:D
#23  
@DJ Sures that is great news. I am here to install the latest, you are the man.

j
#24  
I have always (back as far as vb5) preferred MS Deployment over Installshield even when I had access to an enterprise license of Installshield. The MS tool was simple and effective. Tbe only Installshield feature I thought had any value was the ability to have it pull missing components from a local or Internet server rather than including them in my distribution package, so my packages could be smaller. But, that required Internet acess during the installation and caused problems for some of my enterprise customers, so I wound up always including the components anyway.

Alan
PRO
USA
#25  
Cannot load my robot file after update?
I never had to agree to license before an update?
I am not sure how to go back to previous version that worked on my windows 8.1 before?
Can someone tell me how?
I shut down, but no ARC.
I had a big long error message that I could not paste here.
Are things getting too complicated?
I do not have MS Offiice on this PC.
ARC needs a recovery option.
Steve S
United Kingdom
#26  
@Steve, ARC generally works fine after an update however in this instance, as pointed out, it is very much a beta. A "recovery mode" would be pointless to be honest.

ARC is, as always, evolving. If you have a robot that works and you are happy with it and don't plan to make any changes or updates to it then don't update the software.

If you want to roll back to the last version start by uninstalling the current one
Download this version and run it.
PRO
USA
#27  
Thank You so much Rich,
You offer great help!
I will try it.
I wanted to do the update to take advantage of faster response mentioned in the release notes.
Steve S
PRO
Synthiam
#28  
Steve, the update notes mention a warning that this version may cause issues. We're using the community to resolve the issues. You have no volunteered to help:)

I'm still actively working on a solution to find out why Install Shield won't work.

I have the merge modules all unselected, but it keeps attempting to include 64 bit merge modules even though they are all unselected. I select the 32 bit merge modules but Install Shield continues to force the 64 bit modules.

Also another bug with Install Shield is the "File Extension" is not saving the selected application.

I'm having a hard time believing that there is a world of people using Install Shield with all of these bugs i'm experiencing... *mad*
PRO
Synthiam
#29  
Now it keeps crashing when I try to change settings...

User-inserted image


Haha, it's not all fun and games building robots! When you're at the mercy of a company who doesn't make a reliable product...
#30  
So wait. do you need VB installed? I have vb 2012. Does this change anything about installing?
PRO
Synthiam
#31  
No you don't need VB installed.

This has to do with 64 bit merge modules being installed for a 32 bit application. Some of you may have the correct 32 bit merge modules from the previous installation - or another software program.
PRO
USA
#32  
Sorry DJ,
I should have checked the latest release notes, just opened ARC and chose update. Thought I was downloading 12.16 version.
You will get things resolved, you do awesome work!
Thank you for all your work and patience.
Merry Christmas to everyone @ EZ Robot.
Steve S
PRO
Synthiam
#33  
Can someone try this...

1) uninstall all copies of ARC from your Programs and Features in the Control Panel

2) and install this: Trial1Installer.msi
#34  
@DJ Sures... Tried no go, same errors. j
PRO
Synthiam
#36  
k working on another
PRO
Synthiam
#37  
How about this one.. Make sure you uninstall any ARC that you have previously installed from the Control Panel.

TesterInstaller.msi
United Kingdom
#38  
This one worked for me on Windows 7 64bit:)

Note: I also installed the latest version of .NET
#39  
okay, this one worked for me on Windows 8.1 64bit.

:):):):)

j